Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Accessories

Reply
Contributor
karlaporter
Posts: 10
Registered: ‎08-11-2011
My Device: Tour 9630

Re: Playbook charging Pod Issue

That's an interesting thought, I'll check mine out. It's clearly making contact.. If I have it on the pod viewing the battery meter it visibly drains it.

 

It's doing the opposite of what it should. It was fine the first couple of times i used it - I think it started happening after a software update.

 

Contributor
georgekGR
Posts: 19
Registered: ‎08-12-2011
My Device: playbook

Re: Playbook charging Pod Issue

my two cents really but this points out probably to "short circuit" behavior? i read on a forum some days ago that also the springs on the on the pod pin entries did not work well and got stuck somehow. have a look at those as well maybe?
New Contributor
leissp
Posts: 3
Registered: ‎05-23-2011
My Device: Bold 9700

Re: Playbook charging Pod Issue

Mine is doing the same thing, it shows that it is connected and it is discharging. I am contacting support re this issue.

Contributor
karlaporter
Posts: 10
Registered: ‎08-11-2011
My Device: Tour 9630

Re: Playbook charging Pod Issue

[ Edited ]

Since July 7 I'm in 10 emails and several calls to BB Playbook support - they refuse to do anything.

 

Here is the answer from customer support:

 

This is Zalia with BlackBerry Support and I do apologize for just now getting back to you but I was still looking into your issue and there is not a way that they can give you an accessory RMA for your rapid charger they only replace the wall charger, USB cord, and the sleeve that comes int he box with the PlayBook. I do apologize for this but it is no way that they can complete the RMA for me. If there is anything else that I can assist you with please let me know, if not then I will be resolving your case.

 

 


Developer
peter9477
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10

Re: Playbook charging Pod Issue

How long ago did you buy this, and did you ask Zalia what the warranty for the product is (and where that's documented)?

The piece of paper in my box says to go to www.blackberry.com/go/accessories "prior to accessory use" to find warranty information, but going there after I've used mine :-) I sure can't find anything other than generic warranty info under Tablets -> Accessories (which redirects me to the GWS store) and way down the bottom under Legal. (That's in Canada though... perhaps the US site will direct you elsewhere.)

Another thing you could do is tell her you're not satisfied with the response so far and could she please put you in touch with her supervisor. Some people claim that sort of thing can be helpful...

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Contributor
karlaporter
Posts: 10
Registered: ‎08-11-2011
My Device: Tour 9630

Re: Playbook charging Pod Issue

It was just over 60 day when it started to drain instead of charge the battery. The first thing I did was try to find the warranty when the retail store (Best Buy) wouldn't take it back more than 30 days after purchase and told me to contact the manufacturer. 

 

I visited the very same link you kindly provided me. The Playbook charging pod doesn't seem to be listed there. If it is I don't see it. I requested it from customer support and that request was never fulfilled. 

 

I requested escalation to a supervisor to no avail. It was a series of many calls and emails - I spoke to and corresponded with many people. I specifically asked for the appropriate contact for official BB accessories and I never got an answer.

 

In the end I was basically told there is no product support for the charging pod after the 30 day retail warranty. 

 

As the co-director of a professional association for customer service best practices I assist companies with protocol... I'm in disbelief where this has gone.

 

I appreicate all the very kind and helpful people on this forum. In the many years I have been a BB customer it's the first time I have posted here. You guys all rock :Clap:

New Contributor
leissp
Posts: 3
Registered: ‎05-23-2011
My Device: Bold 9700

Re: Playbook charging Pod Issue

Hi all,  I have unplugged and repluged the charging unit in and now it is working. Worth a shot especially since BB won't help.

New Member
jmclaughlin
Posts: 1
Registered: ‎02-22-2013
My Device: playbook

Re: Playbook charging Pod Issue

I am experiencing draining power on my playbook while on the charging dock. I recently did an OS upgrade! What is going on?