Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Accessories

Reply
New Contributor
rmccool
Posts: 9
Registered: ‎05-17-2011
My Device: Pearl 8100 (waiting for Torch 2)
My Carrier: AT&T
Accepted Solution

Problem using BlackBerry Presenter with Torch 9810

I am trying to set up my Torch 9810 to work with a BlackBerry Presenter.  According to the Presenter page ( www.blackberry.com/presenter/ ), the Torch 9810 is supported, but when I attempt to install the software on my phone I get a message that says that my phone is not supported.  (This occurs regardless of whether I attempt to install the software OTA or via BlackBerry Desktop.)

 

I'm not sure if the "the Torch 9810 is supported / oops, no it's not" is just another example of RIM's occasional schizophrenia, or if there's a problem with my phone.  (According to BlackBerry Desktop, it's running the latest version of OS 7.)

 

Any help or constructive suggestions would be greatly appreciated.

 

Please use plain text.
Elite II
BillJ
Posts: 8,978
Registered: ‎01-05-2009
My Device: BlackBerry Z30
My Carrier: Rogers

Re: Problem using BlackBerry Presenter with Torch 9810

According to the BlackBerry site, you first have to download the desktop software THEN download the software for the presenter software to your phone.  Without having the desktop software downloaded first, you'll run into trouble.

 

If you haven't downloaded the desktop software first, here's the link:

 

http://us.blackberry.com/smartphones/accessories/presenter/download.jsp

 

Once that's been downloaded, enter your email address associated with your phone to download the rest of the software to your phone.

 

 

I hope that helps you.  :smileyhappy:


- If my response has helped you, please click "Options" beside my post and mark it as solved. Clicking the "thumbs up" icon near the bottom of my response would also be appreciated.



Please use plain text.
New Contributor
rmccool
Posts: 9
Registered: ‎05-17-2011
My Device: Pearl 8100 (waiting for Torch 2)
My Carrier: AT&T

Re: Problem using BlackBerry Presenter with Torch 9810

Ooops, I guess I wasn't clear in the original post.

 

I did download the Presenter Desktop software first - and then tried to use it (the desktop software) to install the phone portion of the system on my Torch 9810. That's when I got the first error message: "Unsupported Device.  Sorry, your device does not meet the system requirements that are needed to support BlackBerry Presenter."

 

At that point, I tried the alternate method of having a link e-mailed to my phone, and downloading OTA. That produced the same result.

 

I rebooted my PC and did a shutdown and battery pull on the Torch, just to make sure that it wasn't a temporary error, but I still received the same results when I attempted the installation yet again.

 

I've been a BlackBerry fan for a long time, but issues like this - conflicting information on their web site, and no easy source of direct support - make me realize why so many people seem to be down on RIM these days.

 

Please use plain text.
New Contributor
rmccool
Posts: 9
Registered: ‎05-17-2011
My Device: Pearl 8100 (waiting for Torch 2)
My Carrier: AT&T

Re: Problem using BlackBerry Presenter with Torch 9810

Another clarification... when I say that I tried to use "the desktop software" to download the phone portion of the Presenter software, I don't mean the Presenter Desktop software.  The Presenter Desktop software doesn't connect to the smartphone at all, merely to the Presenter hardware.  Rather, I mean that I tried to use the web-based installer that requires the smartphone to be connected to the PC, and which downloads the software to the smartphone through the PC.  When that didn't work, I tried the direct OTA download.  Neither method was successful; both returned the "Unsupported Device" error I mentioned in my previous post.

Please use plain text.
Visitor
susanji
Posts: 1
Registered: ‎02-10-2012
My Device: Torch 9810
My Carrier: AT&T

Re: Problem using BlackBerry Presenter with Torch 9810

Go to blackberry app world on your phone and download it from there. 

Please use plain text.
New Contributor
ZG862
Posts: 6
Registered: ‎03-15-2012
My Device: Torch 9860
My Carrier: Vodafone

Re: Problem using BlackBerry Presenter with Torch 9810

Alas I can't just go to AppWorld to find it Susanji - as it is not there.

 

I have experienced the very same problem as the original poster. The software claims that my 9860 is not a supported device - contrary to the supported devices list on the box.

 

Stuck & not very impressed.

Please use plain text.
Guru III
knottyrope
Posts: 30,353
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Problem using BlackBerry Presenter with Torch 9810

Supported deviec according to thier webpage
 
 
BlackBerry® Curve™ 8520 smartphone
BlackBerry® Curve™ 8530 smartphone
BlackBerry® Curve™ 8900 smartphone
BlackBerry® Tour™ 9630 smartphone
BlackBerry® Torch™ 9800 smartphone
BlackBerry® Bold™ 9000 smartphone
BlackBerry® Bold™ 9700 smartphone
BlackBerry® Bold™ 9780 smartphone
BlackBerry® Storm™ 9530 smartphone
BlackBerry® Storm2™ 9550 smartphone
BlackBerry® Style™ 9670 smartphone

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 5.0.4 and BES 10.2.2 with Exchange 2010 and SQL 2008


Please use plain text.
New Contributor
ZG862
Posts: 6
Registered: ‎03-15-2012
My Device: Torch 9860
My Carrier: Vodafone

Re: Problem using BlackBerry Presenter with Torch 9810

Hi there.

 

According to Amazon (where I bought it) the supported model list is:

 

BlackBerry Presenter for BlackBerry 8520 8530 8900 9000 9100 9105 9300 9330 9350 8520; 8530; 8900; 9000; 9100; 9105; 9300; 9330; 9350; 9360; 9370; 9500; 9520; 9530; 9550; 9630; 9650; 9670; 9700; 9780; 9800; 9850; 9860; 9900; 9930

 

I guess this answers the question though, but places the device in the "useless technology" category. Looks like I'll be sending it back - which is a shame.

 

Z

Please use plain text.
New Member
spicytofu
Posts: 1
Registered: ‎02-29-2012
My Device: Playbook 64GB
My Carrier: No Carrier

Re: Problem using BlackBerry Presenter with Torch 9810

There is in fact a solution however it is not an officially supported process.

 

Presenter is not natively supported by OS7 devices, however the OS6 files are compatible. 

 

Run BBSAK BlackBerry Swiss Army Knife, and install COD's. 

 

Download the software files from the presenter blackberry website, the phone software.

 

Unzip and select all of the cod's in os6 signed files. (Hold down shift select first on the list and then select the last one, and click open.

 

It will install and your phone will shut down. Turn it on and test it out on the Presenter

Please use plain text.
New Contributor
adh0883
Posts: 3
Registered: ‎10-17-2011
My Device: Bold 9900
My Carrier: Vodafone UK

Re: Problem using BlackBerry Presenter with Torch 9810

BBSAK rules.  I used this to put presenter software for os^ on my 9900 and works a treat.

 

Next test, can I get it on a BB10 device :smileyhappy:

Please use plain text.