Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Advertising Service

Reply
New Contributor
noel_ramos
Posts: 4
Registered: ‎10-05-2010
My Device: BlackBerry Bold 9700

Error: The returned page had no content type, and therefore cannot be processed

I just got the advertising API and easily created a banner component with a custom image placeholder into my screen by following the documentation, and upon testing the app on both the simulator and actual device (Bold 9700), I got the error below as seen in the audit log:

 

The returned page had no content type, and therefore cannot be processed

 

Looking further at the logs, I can say that

* Navigation handlers has been set

* Banner has initialized

* Strangely, "Banner Id is !!!!!!!!!! - 1" has been set

* Transport string has been set

* Data seems to be posted

* Phone info is fetched

 

Right after the line "Displaying contents of URL" in the logs, is where the error I stated gets displayed. 

 

Logging into the Advertising Service Portal, I can also see and say that the requests from my application has been sent and received.

 

Can someone help me to determine what I still need to do to display the ads banner that should replace my image placeholder.

 

Retired
jreda
Posts: 76
Registered: ‎09-28-2009
My Device: BlackBerry Torch

Re: Error: The returned page had no content type, and therefore cannot be processed

What device are you trying this on?

 

Are you using your APID in the constructor of the banner object?

New Contributor
noel_ramos
Posts: 4
Registered: ‎10-05-2010
My Device: BlackBerry Bold 9700

Re: Error: The returned page had no content type, and therefore cannot be processed

my device is blackberry bold but the same problem is experienced in the simulator.

 

I am using the application id given to me in the constructor.

 

Is it possible that I am actually getting a null respose from the service? I registered my account using Phils as my country and I am thinking that it may return no ads for my country.

Retired
jreda
Posts: 76
Registered: ‎09-28-2009
My Device: BlackBerry Torch

Re: Error: The returned page had no content type, and therefore cannot be processed

[ Edited ]

Which BlackBerry are you using and what is the OS version installed on that device?

New Contributor
noel_ramos
Posts: 4
Registered: ‎10-05-2010
My Device: BlackBerry Bold 9700

Re: Error: The returned page had no content type, and therefore cannot be processed

BlackBerry 9700

v5.0.0.351 (Platform 5.1.0.98)

New Contributor
noel_ramos
Posts: 4
Registered: ‎10-05-2010
My Device: BlackBerry Bold 9700

Re: Error: The returned page had no content type, and therefore cannot be processed

Just want to give you guys an update regarding my problem. My application is already displaying ads, the error I got previously is probably caused by a null response from the ads service.

 

Now that I have ads displayed, I noticed some weird behavior wherein my screen flickers. My screen utilizes a BrowserField which gets resources and stuff from the net and displays it on the screen. I only got this problem when I added the Banner and when its functioning as expected, is it ok for me to have the Banner and BrowserField on my screen? Any ideas on how to resolve this?

 

-oOo- nOeL -oOo-

Retired
jreda
Posts: 76
Registered: ‎09-28-2009
My Device: BlackBerry Torch

Re: Error: The returned page had no content type, and therefore cannot be processed

Which ad library are you using? You need to be using the 5.0 library on 5.0 devices.  The libraries for 4.x can result in issues.

Developer
pfiffi78
Posts: 242
Registered: ‎01-29-2009
My Device: Not Specified

Re: Error: The returned page had no content type, and therefore cannot be processed

I have the exact same problem.

 

Is there any known explanation what is causing that? Any solution?

 

Thanks.

New Contributor
jmarcog
Posts: 2
Registered: ‎03-03-2011
My Device: Not Specified

Re: Error: The returned page had no content type, and therefore cannot be processed

 

I am experiencing the same or a very similar problem. The banner shows up blank. I see a connection being made and then the banner flickering grey and back to white. I have this behavior both on the Simulator and on a real device. I am testing with a 8300 (also the simulator) from Italy (the device is set to English though).

 

In the event log I see the following relevant events (XXXXX is our  APID)

*******************************************************************
Name: Banner-XXXXX
apid=XXXXX&ua=BlackBerry8300%2f4.5.0.55+Profile%2fMIDP-2.0+Configuration%2fCLDC-1.1+VendorID%2f179&auid=cd403ed9ffdd91f4bdb3f4045a45af72f18eee12
&mmisdk=1.0.0.1.b&countrycode=222&isolang=en&displang=English
&libver=1.0.0.40&aw=0&hsht=53&hswd=320&transport=TCP
********************************************************************
Name: net.rim.browser
No Content-Type on 200
*********************************************************************
Name: net.rim.browser
type=null, length=0, date=1299067084000
*********************************************************************
In the advertising portal I see the requests being made, but the fill rate is 0% even though I should be in the testing phase.
Can somebody please help finding what is going on?
Thanks,
Marco

 

Developer
pfiffi78
Posts: 242
Registered: ‎01-29-2009
My Device: Not Specified

Re: Error: The returned page had no content type, and therefore cannot be processed

You should contact the advertising support guys. I have been speaking with them and there was a misconfiguration on their mediation platform. After the corrected it, it works now.