Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Bold™

Reply
New Contributor
chantanito
Posts: 2
Registered: ‎01-05-2010
My Device: Bold Onyx

Re: 9700 Trackpad issue

Same problem here. I bought my Onix the week it was released but all of a sudden, my trackpad stopped working at all. Several battery pull outs and still the same... Pressed the plate and the thing is still dead... This is a shame.. What's happening with RIM's quality controls? I mean, i'm paying some bucks for technology not for worries

New Contributor
DLB63
Posts: 3
Registered: ‎02-07-2010
My Device: Not Specified

Re: 9700 Trackpad issue

Bold 9700 user here. Seven (7) phones in 10 months, ALL trackpad issues. That I paid $400+ dollars for a brand new phone in April, only to have it replaced by several defective phones over the next few months is a joke! Tracking pad, for me, is worse than the tracking ball. I've talked to RIM (bigger joke), and after their lengthy attempts at fix, they advised T-Mobile to replace my phone. Same problem as the rest, pad stops working, can't scroll can only click / select. Got replacement phone last night and already on phone with tech support with issue. LAST blackberry for me...good luck, all...
Super Contributor
jm312
Posts: 329
Registered: ‎01-31-2011
My Device: Bold 9700 v6.0.0.576
My Carrier: Orange UK

Re: 9700 Trackpad issue

It is strange and difficult to believe that you changed phones and the problem persists. 

 

I have also upgraded many 9700s and many times, never ever saw any problems except for the bugs with os itself.

_________________________________________________________________________________________
Install this on your phone, it helps: http://us.blackberry.com/apps-software/protect/

Be sure to click Kudos! for those who have helped you.
Click Solution? for posts that have solved your issue(s)!
New Contributor
DLB63
Posts: 3
Registered: ‎02-07-2010
My Device: Not Specified

Re: 9700 Trackpad issue

Strange? Yes. Difficult to believe? For me, too, especially since I'm the one dealing with the issue. Spoke with TMobile rep this morning as I was packing replacement phone to send back. Seems they see plenty of issues with the trackpad, but not as much with the tracking ball. My particular phone was made in Hungary, as were several of my replacements. Don't know of that's relevant or not. I've had both the tracking ball and pad, and at least with the ball you can sometimes coax it to work. With the pad I get nothing, only the ability to click. Four of the phones I took to TMobile store, and they were also unable to get sensor to work (permanently). It wasn't that it didn't work at all, all the time, but that it wasn't reliable. I want a product that works all the time, as that is what I paid for. Glad your 9700 trackpad has worked for you.
Super Contributor
jm312
Posts: 329
Registered: ‎01-31-2011
My Device: Bold 9700 v6.0.0.576
My Carrier: Orange UK

Re: 9700 Trackpad issue

Then this may lead to a defective batch of 9700s for T-Mobile. No offense for my earlier post.

_________________________________________________________________________________________
Install this on your phone, it helps: http://us.blackberry.com/apps-software/protect/

Be sure to click Kudos! for those who have helped you.
Click Solution? for posts that have solved your issue(s)!
New Contributor
DLB63
Posts: 3
Registered: ‎02-07-2010
My Device: Not Specified

Re: 9700 Trackpad issue

No offense taken. I hope my response didn't come off as snippy. I was fresh off my phone call with TMobile and extremely frustrated. They may be dealing with a defective batch, though they wouldn't share that info with me. But they were very sympathetic and have no problem replacing the phone multiple times. Which leads me to think that there is, indeed, a problem.
New Member
anaeichenberg
Posts: 1
Registered: ‎01-06-2012
My Device: Blackberry 9700

Re: 9700 Trackpad issue

Wow I am so happy/relieved this works! Thank you so much for this advice!
New Member
brightronics
Posts: 1
Registered: ‎05-28-2012
My Device: bold 9790

Re: 9700 Trackpad issue

U are my hero :smileytongue: 100% perfect solution for this problem. Thx :smileywink:
New Member
Stringdriver
Posts: 1
Registered: ‎02-05-2013
My Device: Bold 9700

Re: 9700 Trackpad issue

[ Edited ]

I've yet to hear a more bizarre solution that works.

 

However, removing the SIM and pressing on the plate worked perfectly to solve:

 

Touchpad on Bold 9700 not scrolling

 

Touchpad clicked / selected but would not scroll.

 

To save the time and effort  (not to mention the possibility of breaking plastic parts) of device disassembly, this solution is a great one.

 

Saving many dollars in repair or multiple hundreds of dollars in a new purchase, I give a hearty 2 thumbs up!

 

As has been mentioned before, this is not a resolution that fits a Utopian society, but it works in the one in which I live.

 

Thanks to whomever dreamt up the plan.

 

EDIT: This "fix" worked for about a couple of hours...then, no dice. So, it's entirely possible that the time between battery pulls etc., was the main reason for it working again.

 

So, I changed the trackpad and it worked like new for about 40 minutes. Now, I'm not certain what to do with it. I may update the OS and see if that helps. Otherwise, it will become a recycled phone, unfortunately.

 

By the way... the connector for the track pad is NOT under the sim card space... it is exactly opposite and (on the phone I have) under the label, not the SIM card.

 

Frustrating for certain.

New Contributor
jaime_vazquez
Posts: 7
Registered: ‎02-06-2013
My Device: Bold 9700

Re: 9700 Trackpad issue

Mine began to behave like this AFTER I upgraded the OS software to 6.0.  All the buttons work when depressed but the trackpad does not track to anything.  Power off/power on sometimes worked.  Taking out the battery wait 10 seconds, replace and reboot would work sometimes.

 

There is a KB article (the number escapes me) of booting the phone to "Safe" mode. For whatever reason, that seems to be working for me now.  Not sure what is happening in thie "Safe" mode. I've asked on this forum, no response as yet.

 

Basically (at 6.0 and later), when the red LED quits blinking and you start the power on (line starts to scroll on screen), depress and hold the ESCAPE button until the scroll line compeletes, and then release it.  If you did it right you will get some message about being in Safe mode and if you want to stay there.  I said yes, and it's been working for now.  The screen has a "Safe Mode" line at the top of the screen.

 

Bottom line - no I am pretty darn sure this is not a hardware (press the metal clip thing) problem.  All was OK until I upgraded the software. GRRRR. 

 

I hope this works for you.