Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Bold™

Reply
Highlighted
New Contributor
Posts: 3
Registered: ‎10-08-2012
My Device: 9900
My Carrier: Virgin

9900 keeps trying to use poor 2G signal, instead of full strength wifi

At home, I get very poor 2G/3G signals, but have superb wifi service. This works fine when I have no telephone signal at all ... but as soon as the phone detects a 2G network, my data connection fails and only recovers to a poor 2G service, if it gets that far.  To recover, I need to turn off the mobile network, or move to a part of the house where I loose the phone signal, then re-connect to wifi.

 

Are there some settings I need to tweak .. this is really annoying!!

Elite II
Posts: 8,978
Registered: ‎01-05-2009
My Device: BlackBerry Z30
My Carrier: Rogers

Re: 9900 keeps trying to use poor 2G signal, instead of full strength wifi

Your phone should default to the Wi-Fi signal for browsing if both a network signal and a Wi-Fi signal are present. Just to see how you're connecting, fire up your phone while in your house then on your homescreen click Manage Connections>Service Status and see what is listed beside BlackBerry Internet Service.


Try that and post back. Smiley Happy

- If my response has helped you, please click "Options" beside my post and mark it as solved. Clicking the "thumbs up" icon near the bottom of my response would also be appreciated.



New Contributor
Posts: 3
Registered: ‎10-08-2012
My Device: 9900
My Carrier: Virgin

Re: 9900 keeps trying to use poor 2G signal, instead of full strength wifi

Thanks for your reply... but yes, this is the problem.  If I check the 'service status', it shows wifi against internet.. but the service either doesn;t work or is really slow.

 

However, if I disable 'mobile network'   (don't touch wifi) .... then the data connection springs to life....

 

this only seems ot happen when I have a really weak mobile network signal ... which drops in and out... wifi seems to work perfects when I'm in the office and have a really strong 3G signal.

 

I've googles a bit and see other people with 9900's have the same issue, but I've not seen a fix for it