Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Bold™

Reply
Contributor
Posts: 11
Registered: ‎07-20-2012
My Device: Blackberry bold 9900
My Carrier: Elit Electronics

9900 not turning on, Red LED, JVM Error

 

I bought 9900 7 months ago and phone has 3 years warranty. After ı used phone 4 months, One night, before sleeping, I plugged it to charger and went to sleep. Morning my mobile was dead. I took out the battery and the reput it. only red indicator was blinking.

 

- I tried to reinstall BBOS 7 but phone was not connecting to desktop software.

- I tried bbsak it also couldnt connect

- I tried to install OS with application ( after deleting vendor.xml file) loader, but when it comes to middle it gives " JVM couldnt be loaded " 

 

Then I putted it into its box and went to warranty service. Warranty service took it for a week. Then they called me and said,

- You have your phone dropped and thats why your phones "mainboard" and "processor" has been damaged. So, it will cost 50 dollars for fix.

I said,

+ I didint drop the phone and there isnt anything visually damaged on the phone(It is same as new phone), On the other hand phone has warranty, so why should ı pay 50 dollars? 

- because you have dropped your phone and it makes it out of warranty.

 

Then I gave 50 dollars and waited for a week. while waiting I realized something. what kind of "mainboard and processor cost 50 dollars? Isnt it very cheap? even impossible.

 

anyway they called me and said that " we couldnt repair your phone and your phone is dead !!!"

 

Now, I really dont know what to do, and dont want to live it like that. Somehow I have to access to blackberry or RIM and explain my situation.

 

BUT HOW? I live in Georgia, I am Turkish and there is no official blackberry service in this country, So What can I do ? Please Help

Hall of Famer II
Posts: 50,675
Registered: ‎11-28-2008
My Device: Z30/Z10/Q10 (10.3.1.2582), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: 9900 not turning on, Red LED, JVM Error

Hi and Welcome to the Community!

As a user-to-user community, no one here can answer your question with any level of authority whatsoever. RIM provides zero front line support to end users, including warranty...all support starts with the carriers, authorized resellers, and authorized service centers, all who can escalate cases into RIM at no charge to the end user.

So, your escalation path is not here, in these forums. Rather, it is through your existing channel...even if they so far have been rather unhelpful to you. You have no free path by which to bypass them and seek any answers from RIM.

There is something called incident support, but it costs to just ask the initial question, since you are bypassing the contract you signed upon purchase. If you wish to investigate that, you can review it here:

There also might be some good reading here:

Good luck!




Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code