Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Bold™

Reply
New Member
Posts: 1
Registered: ‎09-17-2012
My Device: 9900
My Carrier: T-mobile

9900 won't start after plugging power lead in, maybe moisture problem.

I use my 9900 for listening to music whilst running, yesterday it rained and although it was in my pocket there was a lot of moisture on the phone (yes my fault I know) anyway phone was working OK then it went off so I took the back off made sure the battery area was dry and it started up OK. I though all was well till I plugged it in to the mains charger when it switched off and now won’t start. Also after around 20 seconds there is a battery icon with a red cross come up over it ?

 

I have taken it apart and it all appeared dry but it refuses to start, I have tried plugging it in to PC with USB and mails lead and neither make a difference. As usual the last back up was a couple of weeks ago with all latest appointments….

 

Any help welcome.

Elite II
Posts: 7,973
Registered: ‎06-01-2012
My Device: Curve
My Carrier: BSNL

Re: 9900 won't start after plugging power lead in, maybe moisture problem.

Hi Astonchap

 

Welcome to the Community

 

 

It seems but yes the problem is just because the device got wet ,So remove the Battery and don't try to power it unless you are sure that it is completely dry.Have a look at this Article and do whatever it says. Got Your BlackBerry Wet? . So follow it .

 

Prince

 

Click " Like " if you want to Thank someone.

If Problem Resolves mark the post(s) as " Solution ", so that other can make use of it.

___________________________________________________________________________

Click " Like " if you want to Thank someone.
If Problem Resolves mark the post(s) as " Solution ", so that other can make use of it.