Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Bold™

Reply
New Contributor
BCBC
Posts: 2
Registered: ‎09-06-2012
My Device: Bold 9900

Blackberry ID not recognized on my phone

I've registered my ID on the bb site, I can log in on the site no problem.  But when I try on my phone it says it's not valid!

Any ideas??  Getting very frustrated.

 

I'm at 8/10 attempts, how do I reset that as well?

Guru I
John_Clark
Posts: 16,229
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.3.0.1154; PlayBook w/OS 2.1.0.1917

Re: Blackberry ID not recognized on my phone

You can reset your BBID at BBID.com
--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
New Contributor
BCBC
Posts: 2
Registered: ‎09-06-2012
My Device: Bold 9900

Re: Blackberry ID not recognized on my phone

Thanks for the reply John Clark, there's nothing wrong with my password though, I can log in with it just fine on the blackberry site. It's my phone that isn't recognizing the username and password combo.

 

Is there anyone from BB that can help with this?  I'm now at 9/10 attempts, I don't want my phone to lock up.

 

 

Guru I
John_Clark
Posts: 16,229
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.3.0.1154; PlayBook w/OS 2.1.0.1917

Re: Blackberry ID not recognized on my phone

BB doesn't give official support on this forum. For that you have to go through your carrier.

Are you using the email address or your username to login on your device? Everything is done with the email address and password, not the username and password.
--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!