Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Bold™

Reply
Contributor
toontech
Posts: 43
Registered: ‎03-18-2010
My Device: 9700
Accepted Solution

Blackberry not receiving email but can send

I have a colleague who has sporadic problems with his blackberry.

 

It seems he can not receive emails but can send as he wishes.

This is more of an intermittent problem but can sometimes take days to resolve, usually resolving itself.

 

has anyone experienced this? or can anyone of any advice as to what may be the cause and fix of the problem?

Hall of Famer II
sdgardne
Posts: 48,767
Registered: ‎11-28-2008
My Device: Z30, Z10 & Q10 (10.2.2.1531), Playbook (2.1.0.1526)

Re: Blackberry not receiving email but can send

Hi and Welcome to the Forums!!

I suggest the following steps:

1) Register HRT


  • Homescreen > Options > Advanced Options > Host Routing Table > blackberry_logo.jpg (it does not matter which line is current) > Register Now

2) Resend Service Books


  • KB02830 Send the service books for the BlackBerry Internet Service

3) Batt Pull Reboot


  • Anytime random strange behavior or sluggishness creeps in, the first thing to do is a battery pop reboot. With power ON, remove the back cover and pull out the battery. Wait about a minute then replace the battery and cover. Power up and wait patiently through the long reboot -- ~5 minutes. See if things have returned to good operation. Like all computing devices, BB's suffer from memory leaks and such...with a hard reboot being the best cure.

Hopefully that will get things going again for you! If not, then you should try deleting and re-adding the BIS conduits for the affected email accounts.

 


Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Contributor
toontech
Posts: 43
Registered: ‎03-18-2010
My Device: 9700

Re: Blackberry not receiving email but can send

I do not have the option to send service books from my phone, the email settings icon is not there.

 

I do not have a login to do this online and i'd like to try an avoid calling T-mobile everytime I have to do this (its a company device and its a long-ish process to get t-mobile to do this for us)

 

anyway i can browse to a site on the internet through the BB browser to send service books?

why am i missing the email settings icon?

Hall of Famer II
sdgardne
Posts: 48,767
Registered: ‎11-28-2008
My Device: Z30, Z10 & Q10 (10.2.2.1531), Playbook (2.1.0.1526)

Re: Blackberry not receiving email but can send

Given what you've now revealed, I have a new question. Is this BES email? Is this a BES-controlled device? If so, then see your BES admins as they control everything, even the features and functions of any BIS email accounts that may be configured.


Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Contributor
toontech
Posts: 43
Registered: ‎03-18-2010
My Device: 9700

Re: Blackberry not receiving email but can send

yes it's BES, didnt realise there was a difference.

thanks for your help, i'll talk to the BES admin.

New Contributor
guruvenketraman
Posts: 9
Registered: ‎02-01-2013
My Device: BlackBerry Bold 9900

Re: Blackberry not receiving email but can send

I too have the same exact problem. I'm in BIS. Give me any solution other than Host routing table, service books, battery pull, firewall settings, because I tried all of them several times.
Hall of Famer II
sdgardne
Posts: 48,767
Registered: ‎11-28-2008
My Device: Z30, Z10 & Q10 (10.2.2.1531), Playbook (2.1.0.1526)

Re: Blackberry not receiving email but can send


guruvenketraman wrote:
I too have the same exact problem. I'm in BIS. Give me any solution other than Host routing table, service books, battery pull, firewall settings, because I tried all of them several times.

Hi and Welcome to the Community!

 

Given that you have already tried all of those, I see only one option left for you -- contact your mobile service provider for formal support. It is their system that is supposed to deliver your services to you, and it is not doing so. But, only they can look "behind the scenes" at their systems to see why this is not working for you. No one here has any such system access. Your carrier can escalate to BlackBerry if they require enhanced assistance.

 

Good luck!


Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
New Contributor
guruvenketraman
Posts: 9
Registered: ‎02-01-2013
My Device: BlackBerry Bold 9900

Re: Blackberry not receiving email but can send

Dear sdgardne

 

As per your advice i reported the problem to the network provider (Qtel in Qatar). I explained all that i have done and they said there might be some software issues and asked me to reinstall it. I even done it but still the problem exsist as same before. Then i tried using diffrent sim card assuming that there might be problem with my sim card (Like damage..etc) but unfortunately the problem never changed. Now i dont know what to do with my new Bold 9900. Could there be any hardware issues? pls advice.

 

Thanks for your prompt response,and my reply was late because all these days i was battling with network ppl end up no use.

 

Hall of Famer II
sdgardne
Posts: 48,767
Registered: ‎11-28-2008
My Device: Z30, Z10 & Q10 (10.2.2.1531), Playbook (2.1.0.1526)

Re: Blackberry not receiving email but can send

There could be a hardware problem -- or a software problem -- or a carrier configuration problem -- or many other possible problems. Truly diagnosing at an internet distance is quite impossible. Rather, all we can do is deduce what may be causal, by slowly ruling out things that are possible...whatever is left is the most likely cause.

So let's go back...are your voice services working correctly (calls, voice mail, SMS), and working correctly on the Qtel network? This is a prerequisite before trying anything with data.

If so, then when you did the HRT step, exactly what happened? If the correct thing did not happen, then proceeding to Service Books and such is actually not useful.

Did you buy your 9900 from Qtel? If so, then you should pressure them harder for providing you with services. Devices and services bought from the same place result in that one place being 100% responsible for everything regarding service delivery and support. Hence, you would pressure them to live up to their contractual arrangement with you and do whatever they must to get the device working properly on their network.

If you did not buy it from them, then you may want to seek recourse from wherever it was that you did buy it. Further, if the prior owner did not properly cleanse it of all things (e.g., if it was associated with BES, then there could be a latent IT Policy), then it may be impossible for you to use until that is completed.

Something is not correct, and the results of what I've asked you above may provide some insight into what that is. But, there are some things that simply cannot be deduced in this manner. For example, if you bought your BB used, and the prior owner reported it as lost or stolen, then no carrier will be able to register it to their network as it is blacklisted. But, again, only the carrier can confirm such a situation...as just other users, we have no access to any systems that can provide us with that information.

Good luck and let us know!

Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
New Contributor
guruvenketraman
Posts: 9
Registered: ‎02-01-2013
My Device: BlackBerry Bold 9900

Re: Blackberry not receiving email but can send

Dear sdgardne,

 

Answering to your questions

 

1. I have no problems with Calls, Voice calls, SMS.

 

2. While doing HRT, i am getting a message "your hanheld has been registered with the wireless network" immediately

3. I bought the device in carrefour (Well known big hypermarket in all over middle east) as a brand new device and not from Qtel (Network provider) so no previous owner problem like you have mentioned.

 

Infact i dont face any  problem when i connected to wifi. While i am connected to WIFI everything works normal, i can able to send/revieve emails, BBM messages.

 

The problem happens only when i am out of WIFI- i.e. Cellular network (EDGE,3G)

 

Thanks,