Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Bold™

Reply
Contributor
RaverWild
Posts: 41
Registered: ‎08-08-2012
My Device: BlackBerry Bold 9790
My Carrier: Wind Mobile
Accepted Solution

Bug: 9790: Wikitude does not work and cannot be upgraded

Bug: 9790: Wikitude does not work and cannot be upgraded

 

Priority: Low (Guess nobody is going to use Wikitude now anyway)

Severity: Low

 

Note: I understand that this is not a RIM application, but this is a pre-installed application in BlackBerry Bold 9790, so please take care of this. I tried to document the issue as much as possible.

 

I cannot re-test, simply because I don't know how to install old-version. So these are the steps I went to reach to the bug:

 

1) have a 9790 Bold with the BlackBerry OS 7.0 as it was officially sold

2) upgrade to Bundle 2466 (7.0.0.609, platform 9.16.0.77)

3) fully upgrade all official RIM software from AppWorld (Protect, Facebook etc)

4) setup the phone to use the location services

5) launch Wikitude

 

OBSERVE:

Wikitude starts and appears window "Version no longer supported. Please update" and button "OK"

 

6) click button "OK"

 

OBSERVE: Wikitude closes and opens browser with URL:

http://blackberrydl.mobilizy.mobi/Wikitude.jad

Two button appears: "Download" and "Cancel" and checkbox "Set application permissions"

 

7) check the checkbox "Set application permissions" (same end-test result is observed with this checkbox unchecked)

8) click button "Download"

 

Observe: window appears: "Wikitude: Wikitude GmbH contains a module called Wikitude. A module with that name already exists in the "Wikitude" application. If you proceed "Wikitude" will be replaced by Wikitude:Wikitude GmbH. Proceed?"

Buttons "Yes" and "No" appear.

 

9) click button "Yes"

 

Observe: Download process starts, downloading file with 4366kb size

 

Observe:  after successful download a new window appears with message "Error" and buttons "Ok" and "Details".

 

10) Click button "Details"

 

Observe: New window with message "Invalid COD" appears and buttons "OK" and "Copy"

 

11) Click button "OK"

 

Observe: Window is closed and "Wikitude" application is not installed.

 

Please use plain text.
New Member
NR9900
Posts: 2
Registered: ‎01-30-2012
My Device: Bold 9900
My Carrier: t-mobile

Re: Bug: 9790: Wikitude does not work and cannot be upgraded

Hi,

 

Please try to clear your browser cache and start the update process again. If this does not solve the issue please uninstall Wikitude and install it freshly.

 

If you have further issues please contact blackberry(at)wikitude.com

Thx

Nicola

Please use plain text.
Contributor
RaverWild
Posts: 41
Registered: ‎08-08-2012
My Device: BlackBerry Bold 9790
My Carrier: Wind Mobile

Re: Bug: 9790: Wikitude does not work and cannot be upgraded

Thank you! Issue solved. Here is what I did:

 

1) uninstalled Wikitude

2) installed Wikitude from AppWorld

Result: Wikitude runs successfully

 

(clearing browser cache and trying to download from browser don't work)

Please use plain text.