Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Bold™

New Contributor
Posts: 2
Registered: ‎11-12-2008
My Device: Not Specified

Contact information disappearing when replying to emails

Hi everyone,

Let me start off by saying that I have noticed this problem most frequently with my previous 8130 and it has happened once already with my 9000.

Whenever I try to send a reply to an email I've received, I will get the message status: "Message included an invalid address" and if I go to the address book and look up the contact I tried sending to, it would be completely blank.

My solution to this problem has been to lock the phone, unlock it, then resend the message.  This is annoying to say the least.


Also, the reply is always sent to an arbitrary email address for the contact I'm trying to reply to.  So for example, if my colleague is sending me a message from his work account, and I try sending a reply which gets returned for having an invalid email address, after I highlight the email address which was purported to be "invalid", I see that it was sent to his hotmail account.  This problem prevents me from simply hitting menu>resend.


For some background, I have gone to address book>Filter and neither business nor personal are checked.

I have password and content protection enabled and I have installed.


Thank you in advance for any help you may be able to provide.

Forums Veteran I
Posts: 1,546
Registered: ‎04-01-2008
My Device: 8120, Storm, 8200

Re: Contact information disappearing when replying to emails