Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Bold™

Reply
New Member
stuart214
Posts: 1
Registered: ‎08-16-2011
My Device: Bold 9650

Downgrade from Device Software Version 6.0 to 5.0.1

I inadvertently upgraded my software on desktop and device to 6.0 from 5.0.1 on my work BB. I was able to revert to version 5.0.1 for BB desktop software, but am looking for assistance on how to downgrade/revert to version 5.0 on the device.

 

Any assistance is appreciated.

 

Thanks...

Please use plain text.
JSanders
Posts: 85,729
Likes: 23,109
Solutions: 5,955
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Downgrade from Device Software Version 6.0 to 5.0.1

1. Delete the newer OS from your PC by going to Control Panel >Add/Remove Programs. (If you never physically installed the OS to your PC, skip to step 2.)

 

2. Then download and install the older version of the OS. BlackBerry Operating System Downloads

 

3. Install the older OS to the PC by running (double clicking) the file you downloaded.
4. Go to c:\program files\common files\research in motion\apploader and delete the file named "vendor.xml."
5. Plug in BB and double click on "Loader.exe." It's located in the same place as the above vendor.xml file.




1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes


Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Please use plain text.
Visitor
JeffWheeler
Posts: 1
Registered: ‎05-24-2013
My Device: BlackBerry Bold 9850

Re: Downgrade from Device Software Version 6.0 to 5.0.1

5-30-13
I have a BlackBerry Bold 9650 that was originally sold by Verizon.

I have Unlocked it (with Verizon and BlackBerry Tech Support),
I'm now trying to use thru T-Mobile.

With my T-Mobile SIM Card, I only get T-Mobile "edge" service, so

I can talk or text, but I get NO Internet or email; Or BlackBerry Data Services.

T-Mobile assures me they have set up BlackBerry Data Service plan for my phone.

After about 8 hrs total with different T-Mobile Tech Support staff, they still refuse to transfer me to BlacbBerry Tech Support.
Last direction was to downgrade from BB os6 to BB os5.
BB Site has articles about os5, but when I try to downgrade, site says no updates needed.
I can't find anyplace where I can download 5.0 on T-Mobile or BlackBerry sites.

Can you help me?   :smileysad:  

 :smileysad:


 

Please use plain text.
JSanders
Posts: 85,729
Likes: 23,109
Solutions: 5,955
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Downgrade from Device Software Version 6.0 to 5.0.1

Sorry, even an unlocked Verizon device will not work on Tmobile or ATT without a GREAT deal of under-the-hood work.

You can try the settings I wrote up here

Attention: Unlocked Storm on AT&T or T-Mobile

 

but I don't guarantee they will work on a 9650. And you will need Desktop Manager v5

 

If you have questions about THAT process, please ask in that thread.

 

I will tell you now, after having done that above over a hundred + times, you're better off getting the proper device set for Tmobile.




1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes


Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Please use plain text.