Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Bold™

Reply
New Contributor
Posts: 2
Registered: ‎04-24-2012
My Device: Blackberry Bold 9900
My Carrier: O2

Problem after problem?

I recently bought a new Bold 9900, having grown tired of my Iphones reliability. I thought BlackBerry, as a market leader would be a good choice. This was three months ago. The first phone came and didn't even switch on! The replacement came and all was well for three weeks. Then the phone started developing an issue with charging. I noticed that it only charged to 80%, but gradually the issue grew to the point where I would plug the phone in, the charge symbol was displayed for around a minute and then it said the battery was full.

 

I checked forums and a suggested workaround was to put the phone on charge, take out the battery and then put it back in and it would charge. Annoying yes, but this seemed to work for a few weeks. However it didn't last. Soon that didn't help and I had to sit and plug and unplug the phone thirty times until it started to charge. It would then charge to 35% and say it was full every time. I went back to my service provider and they firstly tried a new battery, then a charger and finally sent the phone away to be looked at. They then replaced the handset with a new one without an explanation, but I just assumed it was a faulty phone as can happen.

 

I picked the new one up last Friday and all was great until last night when low and behold the same issue started. However, this has been anything but gradual. I put the phone on charge going to bed and woke up eight hours later and it was at 35%. It now will not charge and has switched itself off. I have contacted my service provider and am now being sent yet another phone and charger.

 

Four phones in three months. By the end of this week I will have had four new handsets, five new batteries and two new chargers within three months. Is there a known issue with the Bold 9900? Or have I just been unlucky? If it fails again I'm going to have to give up on BlackBerry, which is a real, real shame because I love the phone (though the battery leaves a lot to be desired even when it does charge).

Elite II
Posts: 8,978
Registered: ‎01-05-2009
My Device: BlackBerry Z30
My Carrier: Rogers

Re: Problem after problem?

There is no known issue with the phone as far as I'm aware.  I was a 9900 owner for a few months and the only issue I encountered was battery life (which is normal on a 9900).

 

Before you jump ship from BlackBerry, let's get your OS reloaded.  This is a pretty simple task and many times an OS reload will correct some problems.

 

Plug your phone in to your PC and open BlackBerry Desktop Software.  Click Device at the top of the software then Restore from the drop-down menu.  Choose the most recent restore point and reload it.  In addition, it doesn't hurt to remove your battery while your phone is powered on then replace it.  Do this a couple of times each week for maximum performance.  You can also use an app that simulates a battery pull so you don't have to physically remove the battery.  I use QuickPull and I've included a link to it in App World.

 

http://appworld.blackberry.com/webstore/content/1300?lang=en

 

 

I hope that helps you.  Please keep us up to date with your issue.  :smileyhappy:


- If my response has helped you, please click "Options" beside my post and mark it as solved. Clicking the "thumbs up" icon near the bottom of my response would also be appreciated.



New Contributor
Posts: 2
Registered: ‎04-24-2012
My Device: Blackberry Bold 9900
My Carrier: O2

Re: Problem after problem?

Thanks for the advice. I picked up a new phone and once again it did the same!! After testing myself it turns out that the problem was with the USB lead! Took the charger back and got a new one and so far everything seems to be working fine!

 

I suspect there was never an issue with any of the handsets, but because the problem was with the USB lead rather than the actual charger it meant the problem kept happening even when plugged into a computer which threw my service provider.

 

What I will say is the problem was with two separate leads which would suggest an issue with them. I'll keep you informed should any further issues develop with the phone. I'll also install Quickpull as recommended.

Elite II
Posts: 8,978
Registered: ‎01-05-2009
My Device: BlackBerry Z30
My Carrier: Rogers

Re: Problem after problem?

Yes, we would appreciate you keeping us up to date.  :smileyhappy:


- If my response has helped you, please click "Options" beside my post and mark it as solved. Clicking the "thumbs up" icon near the bottom of my response would also be appreciated.