Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Bold™

Reply
New Contributor
scottfrasernz
Posts: 2
Registered: ‎01-07-2009
My Device: Not Specified

Problem with Yahoo Personal Mail on BlackBerry

Hi can anyone with experience of solving this issue please help?

I have asked Yahoo themselves for help but they have been unable to advise. Likewise with the support team from my BlackBerry service provider.

Can anyone help? Sorry it's a long post but I'm trying to explain the problem clearly.

BACKGROUND

I have a Bold on the T-Mobile UK network.

I use Yahoo as my main email provider.

I have two main email addresses, one is 'native' Yahoo e.g.
me@yahoo.com

The other is a Yahoo Personal Mail address, i.e. a 'custom' email using my own domain e.g. me@mydomain.com this is provided by Yahoo

My 'custom' and 'native' email addresses are INTEGRATED into a single Yahoo inbox. That is, when I log in to Yahoo Mail on the web, all my mail sits in one inbox regardless of whether it was sent to my 'custom' or 'native' Yahoo-provided email account.

And I have dozens of Disposable Addresses setup in Yahoo (for spam protection, which works perfectly).

In the BIS I have the following Filters setup:

'native' Yahoo email = When no filters apply: forward to device
'custom' email = When no filters apply: do NOT forward to device

I have found that this filters setup is required because without it, any mails sent to my 'custom' email are received twice: once to the 'custom' account and then a duplicate, to the 'native' account. This is because with the Yahoo Personal Mail address setup, you must have a 'native' Yahoo account which serves as the ultimate destination for your 'custom' addressed email.

Finally, this mail setup works flawlessly from the Yahoo Mail web site. The problem I will set out now is only experience when using my email addresses from my BlackBerry Bold.

THE PROBLEM

OK, so here's the issue. It's driving me up the wall!

Say I send a mail to my 'custom' account, say from my work email.

When I receive it on my Berry, and check the 'Received Using' field, it shows the 'native' email address.

So, if I just use the 'Reply' function on the Berry, it defaults the 'Send Using' field to my 'native' Yahoo email.

I double checked my BIS setup and I do have the 'Reply To' fields set for each email account, to the same email address as the account.

If I go for the inverse setup (i.e. to 'not forward to device' the 'native' emails), then I am exposing my 'custom' email address to all and sundry.

Does anyone know a solution?

PS Please don't tell me to install a Yahoo mail application on the Berry, I also have Gmail accounts and couple of other private domain email accounts and I only want all emails handled 'in one place' by the native BlackBerry email application.

A solution would be massively appreciated!

Many thanks guys and Happy New Year

Scott

Please use plain text.