Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Bold™

Reply
New Contributor
Terrycmc
Posts: 2
Registered: ‎01-01-2013
My Carrier: Rogers
Accepted Solution

Unable to turn Wi-fi on

I have a Blackberry Bold 9000 with 3G, Wi-fi, data plan. Service provider is Rogers.

 

My wi-fi has been working fine for a couple of years but has stopped working the last few weeks. When I try to turn wi-fi on the Wi-Fi check box goes grey and then blank. When I scan for networks from setup and try to turn Wi-fi on from there I get an error message, "Unable to turn Wi-fi on."

 

I have popped the battery multiple times, leaving it out for a few minutes. I have also tried wiping the 3rd party apps from my device and restarting. All in vain. Can anyone help me please?

Please use plain text.
Elite III
John_Clark
Posts: 13,043
Registered: ‎04-01-2008
My Carrier: AT&T

Re: Unable to turn Wi-fi on

I believe this indicates a hardware problem with the wifi. I have seen it before and have not seen any kind of solution other than replacing the device.
--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Please use plain text.
New Contributor
Terrycmc
Posts: 2
Registered: ‎01-01-2013
My Carrier: Rogers

Re: Unable to turn Wi-fi on

Thank you for such a speedy response. When you say "replace the device" I presume that you must mean the BB cell phone, right? I have a number of other devices successfully accessing the wi-fi on the router.

Please use plain text.
Elite III
John_Clark
Posts: 13,043
Registered: ‎04-01-2008
My Carrier: AT&T

Re: Unable to turn Wi-fi on

Yeah, it's usually a problem with the wifi hardware on the phone. Sorry...
--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Please use plain text.