Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Bold™

Reply
Forums Veteran I
Posts: 1,977
Registered: ‎07-08-2013
My Device: Passport/ Curve 9320

Re: Update installed current version Bold 9900

Then contact your service provider about it.
_____________________________________________________________________________________________
Click if you want to Thank someone. If Problem is resolved, so that others can make use of it.
Super Contributor
Posts: 389
Registered: ‎09-11-2010
My Device: BB Q10
My Carrier: vodafone UK

Re: Update installed current version Bold 9900

Hello again,

Noone knows anything... 'Let me check, stay with me, hold the line...'
Blackberry! Here, now, forever!
Hall of Famer II
Posts: 51,248
Registered: ‎11-28-2008
My Device: Z30/Z10/Q10 (10.3.1.2582), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Update installed current version Bold 9900

Hello!

 

From what I see in this thread, you have left out a critical step in your process (deleting the VENDOR.XML files). In order to use an OS package from a different carrier, then you must do that...if you don't, then the installed (to your PC) BBOS package is totally ignored, and instead you can only obtain what your carrier supports. To override the automatic process, you must carefully follow all of this.

The simplest way is to, on a PC (you cannot do this on MAC):

1) Make sure you have a current and complete backup of your BB...you can find complete instructions via the link in my auto-sig below.

2) Uninstall, from your PC, any BB OS packages

3) Make sure you have the BB Desktop Software already installed

4) Download and install, to your PC, the BB OS package you desire:

  • http://us.blackberry.com/support/downloads/download_sites.jsp
  • It is sorted first by carrier -- so if all you want are the OS levels your carrier supports, your search will be quick. However, some carriers are much slower than others to release updates. To truly seek out the most up-to-date OS package for your BB, you must dig through and find all carriers that support your specific model BB, and then compare the OS levels that they support.

5) Delete, on your PC, all copies of VENDOR.XML...there will be at least one, and perhaps 2, and they will be located in or similarly to (it changes based on your Windows version) these folders:

  • C:\Program Files (x86)\Common Files\Research In Motion\AppLoader
  • C:\Users\(your Windows UserName)\AppData\Roaming\Research In Motion\BlackBerry\Loader XML

6a) For changing your installed BB OS level (upgrade or downgrade), you can launch the Desktop Software and connect your BB...the software should offer you the OS package you installed to your PC.

6b) Or, for reloading your currently installed BB OS level as well as for changing it, bypass the Desktop Software and use LOADER.EXE directly, by proceeding to step 2 in this process:

If, during the processes of 6a or 6b, your BB presents a "507" error, simply unplug the USB cord from the BB and re-insert it...don't do anything else...this should allow the install to continue.

 

Good luck and let us know!




Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Super Contributor
Posts: 389
Registered: ‎09-11-2010
My Device: BB Q10
My Carrier: vodafone UK

Re: Update installed current version Bold 9900

Hello,
I haven't deleted the Vendor file, true, but because Vodafon UK is my carrier. :smileyhappy:

Regards.
Blackberry! Here, now, forever!
Hall of Famer II
Posts: 51,248
Registered: ‎11-28-2008
My Device: Z30/Z10/Q10 (10.3.1.2582), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Update installed current version Bold 9900

Sometimes, the automatic process just gets stuck, and you need to override and take control (by deleting the VENDOR.XML files).

Sometimes, your device VendorID may not be the same carrier that you are actually operating the device on, which might confuse the automatic process, requiring you to override in order to succeed.

When using a carrier OS package from your own carrier, removal of VENDOR.XML does no harm...hence, I always recommend doing so, regardless of your carrier, just in case something (like the two examples above) is impeding it from working correctly.

Good luck!



Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Super Contributor
Posts: 389
Registered: ‎09-11-2010
My Device: BB Q10
My Carrier: vodafone UK

Re: Update installed current version Bold 9900

I'll give this a try and will share what happened. :smileyhappy:

Thanks.
Blackberry! Here, now, forever!
Super Contributor
Posts: 389
Registered: ‎09-11-2010
My Device: BB Q10
My Carrier: vodafone UK

Re: Update installed current version Bold 9900

Same thing, still with .714 :smileysad:
Blackberry! Here, now, forever!
Hall of Famer II
Posts: 51,248
Registered: ‎11-28-2008
My Device: Z30/Z10/Q10 (10.3.1.2582), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Update installed current version Bold 9900

Unfortunately, given the complexity of the instructions in post 13, coupled with the simplicity of this report of your result, I can deduce nothing. Can you provide more details? Please remember...we can't see you, and have only your words to help us understand.



Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Super Contributor
Posts: 389
Registered: ‎09-11-2010
My Device: BB Q10
My Carrier: vodafone UK

Re: Update installed current version Bold 9900

Hello,
Did every step from you post. Deleted the Vendor file, started apploader.exe, waited for all the process to come to an end and after that the OS installed was still .714. Didn't use the BBDM because it didn't find the new .1033 update. But most likely as I mentioned it before the file presented as a new update .1033 is the very old one .714. It would be really helpful if someone else has tried to install it and share the outcome.

Regards.
Blackberry! Here, now, forever!
Hall of Famer II
Posts: 51,248
Registered: ‎11-28-2008
My Device: Z30/Z10/Q10 (10.3.1.2582), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Update installed current version Bold 9900

Well, a couple of things...and apologies in advance for being ultra-picky here, but done correctly, this process definitely works...done wrongly, it doesn't work...and it is very easy to make a mistake during it...so we need to figure out what may have accidentally gone wrong...


kosten4 wrote:
Deleted the Vendor file

Only one VENDOR.XML file? In most of the more recent (e.g., since sometime early in the OS7 range) levels, there are always two of those to delete...and if either remains, then the installed OS package is ignored, and the automatic process instead kicks in.


kosten4 wrote:
started apploader.exe

Normally, it's called LOADER.EXE...are you sure you ran the correct thing? It is located in the AppLoader folder, but the actual executable is LOADER.EXE.


kosten4 wrote:
waited for all the process to come to an end and after that the OS installed was still .714.

Did it make any offers or provide an information during the process? Any indication, before it finished (indeed, usually at the very start) of the OS level it was going to work with? If not, then it ignored the installed OS package, and instead did the automatic process, which may well mean that your carrier (as per VendorID) supports nothing newer than .714.


kosten4 wrote:
Didn't use the BBDM because it didn't find the new .1033 update.

All that the Desktop Software does is call LOADER.EXE...so if the desktop software failed to find what you'd installed to your PC, then the expectation for directly running LOADER.EXE would be no different.


kosten4 wrote:
But most likely as I mentioned it before the file presented as a new update .1033 is the very old one .714.

I don't think I understand those words...

 


 

Normally, if the manual process is skipped (as appears to be happening for you), that is for one (or more) of the following reasons:

  1. There is no BBOS package installed to the PC, and the automatic process then takes over
  2. There is a BBOS package installed to the PC, but it's not valid (e.g., for a different model number BB) -- in which case the installed package is ignored and the automatic process takes over
  3. There is more than one BBOS package installed to the PC -- this can sometimes confuse LOADER
  4. A single valid BBOS package is installed to the PC, but the two VENDOR.XML files have not been properly deleted -- and then the installed package is ignored and the automatic process takes over

From all you have said, the package you have installed to your PC is being ignored, and the automatic process is taking over...why that is so is likely due to one of the above reasons.

 

Good luck and let us know




Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code