Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Bold™

New Contributor
Posts: 2
Registered: ‎11-14-2012
My Device: Bold 9900
My Carrier: Vodafone GR

bbm, mail, fb, twitt dont work



I bought a Bold 9900 recently. I am a vodafone greece consumer with a full 12 monts programme for my bb.  when i got the bb the bbm and email didnt work. i was only able to make my profile for bbm and for the mail it doesnt have the option for a personal email account only the enterprise. 

I went to the vodafone store and i asked about the bbm internet service. They opened that for me and i have BIS too. i thought that would solve my problems but nothing. Still nothing works. I register the GPRS bla bla bla many times. I receive a msg that tells me that im registered to tte wifi network but nothing again. Ofcourse i made the batt trick many times. 


Please help me couse i really need all the apps for my work.

thank u in advance

Elite II
Posts: 8,978
Registered: ‎01-05-2009
My Device: BlackBerry Z30
My Carrier: Rogers

Re: bbm, mail, fb, twitt dont work

Everything, from not having BBM, mail, facebook and twitter, to only having the enterprise option during email setup would suggest your BIS isn't set up.


I'd suggest calling Vodafone back and asking them to reset your BIS.  That's got to be the root of the problem.



I hope that helps you.  Smiley Happy

- If my response has helped you, please click "Options" beside my post and mark it as solved. Clicking the "thumbs up" icon near the bottom of my response would also be appreciated.

New Member
Posts: 1
Registered: ‎11-14-2012
My Device: Bold 9900
My Carrier: Telstra

Re: bbm, mail, fb, twitt dont work

Hi there,


Sorry to cut in the on coversation, but it sounds similar to my issue. 


I bought a BB Bold 9900 yesterday through Telstra in Australia.  The internet, text, phone and all works, except I can't add an email account or use BBMessenger.  Telstra have washed their hands of the issue.  When I look at the settings, it says Activated Accounts (none).  It won't let me setup an email account.  Any suggestions?