Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Bold™

Reply
Visitor
miss_alysss
Posts: 1
Registered: ‎03-30-2012
My Device: Bold 9900
My Carrier: T-Mobile

"Uncaught exception: Cannot find image: search_browser_web" Error?

I have the 9900 and did the 7.1 update unforunately OTA as opposed via computer like others have suggested (I read about OTA problems after I already updated of course grrr) but anyways once it started up after installing  I got "Uncaught exception: Cannot find image: search_browser_web" and which ulitmately makes the phone un-usable. Zero color minus the app boxes, little or no response touch screen wise, crazy small icons, etc etc (see picture) but I DID reinstall 7.1 via Desktop 5 seperate times now and it's perfectly fine once it starts back up except for A.) All my previously installed apps aren't there and B.) If I do a hard restart it'll start back up doing the "Uncaught exception: Cannot find image: search_browser_web" error again and it looks just like it did before I reinstall-ed. I also did try the Apploader and after countless times trying it's always the same message something about "The Blackberry Desktop software doesn't have the device software that you have connected to this computer"

 


So suggestions, help, questions anything please and thank you! I appreciate it

 

 

 

 

Please use plain text.
Elite I
Krypto
Posts: 6,657
Registered: ‎01-14-2009
My Device: BlackBerry Z10
My Carrier: Telus

Re: "Uncaught exception: Cannot find image: search_browser_web" Error?

Hi there,

Try reloading the OS using the methods in the following link:

http://supportforums.blackberry.com/t5/Device-software-for-BlackBerry/How-To-Reload-Your-Operating-S...

Make sure to download the OS for the carrier the device is originally from. If you're still getting the message that prevents you from reloading the OS, then download a program called BBSAK from http://bbsak.org. Once you've installed this to your computer, plug your BlackBerry in and run it. Enter your password (if you have one) and press OK. On the next screen you should see your PIN. Next, click on Wipe Device. This will wipe everything off your BB and will leave you with a 507 error. If your PIN doesn't appear on the screen, press Ctrl+Alt+Del, go to the Processes tab and shut down the bbdevmgr process. Then go back to BBSAK and press Connect and proceed.

Once that's done, you can proceed with reloading the OS.

Good luck and I hope this info helps!

If you want to thank someone for their comment, do so by clicking the Thumbs Up icon.

If your issue is resolved, don't forget to click the Solution button on the resolution!

Please use plain text.
New Contributor
johnespo
Posts: 2
Registered: ‎05-17-2012
My Device: Torch 9850
My Carrier: Sprint

Re: "Uncaught exception: Cannot find image: search_browser_web" Error?

thanks for posting. I am currently experiencing the exact same thing. Small icons / interface basically becomes unusable.  The cause is exactly the same as well.  I performed an OTA upgrade to the latest 7.1.

 

What I have done:  Reinstalled the OS more than 6 times.  Old version / newest version.  All looks fine after the OS reinstall.  But as soon as I reboot the device - i.e. an update to ANY app that asks you to reboot - I get this error.  All exactly the same, small whacky icons, can't really click on anything, phone works but numbers are white on a white background, etc.

 

I've also used JL_Cmdr to do a "507" wipe of the device, then installed the older version of the OS, recovered my data, and the first reboot.... bam.. same problem.

 

My next attempt.   1)  Wipe the device  2) Use Desktop Mngr (again) to install the older OS 3) Only restore Contacts and Passwords and NOTHING else.    4) Reboot the device.  

 

Again the only common factor is that either I or the techs at the sprint store were doing, was a restore of my data that was saved after the problem started.  I wouldn't think my data would corrupt the OS from working, but it's my only conclusion at this point.

 

I can't mess with it again until tomorrow sometime and will try what I listed above.

Please use plain text.
New Contributor
johnespo
Posts: 2
Registered: ‎05-17-2012
My Device: Torch 9850
My Carrier: Sprint

Re: "Uncaught exception: Cannot find image: search_browser_web" Error?

Solved:

 

1)  Wipe the device (I used JL_Cmdr)

2) Use Desktop Mngr (again) to install the older OS (previously downloaded the OS I wanted from blackberry support site)

3) I did a complete restore from a back-up I made months ago, prior to this this problem.

4) From a recent copy of a backup (after this problem started), I only restored Contacts and Passwords and NOTHING else.   

4) Reboot the device / updated some apps / rebooted again, etc.  No issues after the reboots this time.

 

All seems fine ... for now.   I have not attempted to install the latest version of the OS, but when I do it will NOT be done OTA (over-the-air).

 

Please use plain text.
New Member
lgill
Posts: 1
Registered: ‎05-28-2012
My Device: Bold 9900
My Carrier: Bell Canada

Re: "Uncaught exception: Cannot find image: search_browser_web" Error?

Hi, I have a similar problem but it happens very often. Since December I have had this happen about 10 times. I have sent my phone in 4 times, and eventually RIM sent me a new phone all together. I continue to have this problem - the only way I can fix it is to delete my entire phone by misspelling my password 10 times and then start again from scratch. This will happen any time when my phone tries to reboot - whether its installing an app, shuts down due to too much activity, forced OS upgrade. Can some one please tell me the cause of this problem so I can prevent it from reoccuring so much? I have a brand new Blackberry 9900.

thank you

Please use plain text.
Elite I
Krypto
Posts: 6,657
Registered: ‎01-14-2009
My Device: BlackBerry Z10
My Carrier: Telus

Re: "Uncaught exception: Cannot find image: search_browser_web" Error?

Wipe your phone again after backing it up, then do a selective restore where you only select the databases you need (e.g. Address Book, Calendar, Messages, etc). The fewer the databases, the better.

Hopefully that will help if the problem is due to a corrupted database as it seems to have been for a previous poster.

If you want to thank someone for their comment, do so by clicking the Thumbs Up icon.

If your issue is resolved, don't forget to click the Solution button on the resolution!

Please use plain text.
Trusted Contributor
kris0725pl
Posts: 115
Registered: ‎03-24-2011
My Device: 8310 curve
My Carrier: PLAY

Re: "Uncaught exception: Cannot find image: search_browser_web" Error?

[ Edited ]

Problem is Easy to FIX. NO WIPE REQUIRED...just one click and everything is normal :smileywink: I got today this error on my 9360 with OS 7.1.746 

 

3 minutes and solved :smileywink:

 

 

 

And FIXED :smileyhappy:

 

Please use plain text.
New Member
Octagonprro
Posts: 1
Registered: ‎11-15-2012
My Device: Bold 9900
My Carrier: MTN

Re: "Uncaught exception: Cannot find image: search_browser_web" Error?

Hey buddy! How can I get it done simple?
Please use plain text.