Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Curve™

Reply
New Contributor
thani
Posts: 2
Registered: ‎10-13-2008
My Device: Not Specified

Arabic

I got my 8320 Device from the states but I had to move to Dubai. The Device is working Perfectly except for the language support. I can't read any Arabic texts on the Device. Since 8310 is the only curve sold in dubai and I was told that the OS is not the same, I couldn't find any local support for my Device. please help
Guru I
Xandrex
Posts: 18,406
Registered: ‎07-29-2008
My Device: Z30, Playbook, 9320BES
My Carrier: B&You _ SFR

Re: Arabic

go here :
http://supportforums.blackberry.com/rim/board/message?board.id=8300&thread.id=6807&jump=true

find an arabic carrier, and install the OS on your computer.



The search box on top-right of this page is your true friend, and the public Knowledge Base too:
New Contributor
tarique24
Posts: 6
Registered: ‎10-31-2008
My Device: Not Specified

Re: Arabic

Hello there

 

I have the exact same problem, would finding an arabic carrier and installing their os solve this issue? that simple?

should not everyone stick to their service provider's os?

would this install make my blackberry os in arabic instead of english?

 

thanks

Guru I
Xandrex
Posts: 18,406
Registered: ‎07-29-2008
My Device: Z30, Playbook, 9320BES
My Carrier: B&You _ SFR

Re: Arabic


tarique24 wrote:

I have the exact same problem, would finding an arabic carrier and installing their os solve this issue? that simple?


Yes

 


tarique24 wrote:

should not everyone stick to their service provider's os?


Answer from your carrier : "NO YOU CANNOT"

answer from many people : you can, but then you can't call the hotline of your carrier.

 


tarique24 wrote:

would this install make my blackberry os in arabic instead of english?


 

As far as I know, English is always available.




The search box on top-right of this page is your true friend, and the public Knowledge Base too:
New Contributor
tarique24
Posts: 6
Registered: ‎10-31-2008
My Device: Not Specified

Re: Arabic

Hello Xandres

 

another question please, now for me to update my os, i'd go to this page

 

na.blackberry.com/eng/support/downloads/download_sites.jsp

 

choose my carrier, which is "bell mobility" under north america

 

it asks me then to download both, the desktop software and my handheld software. So I'd go and download

 

1. BlackBerry Desktop Software v4.6

2. BlackBerry 8830 (TM)

 

now for number 2, the latest they have listed is:

 

Software For BlackBerry 8830 (TM)   BlackBerry Handheld Software v4.2.2.353 (Multilanguage)

Package Version: 4.2.2.353
Consisting of:
  • Applications: 4.2.2.196
  • Software Platform: 3.0.0.81
  • File name: 8830EFS_PBr4.2.2_rel353_PL3.0.0.81_A4.2.2.196_Bell_Mobility.exe
  • File size: 88.83MB

 

So now I'm getting confused, is there a handheld device 4.5 and a blackberry desktop software 4.5 & 4.6??

or what's the deal?

 

when i go to options, then about in my bb device, it shows that my version is: 4.2.2.196

 

so If I go and install the desktop software 4.6, would that make my bb version 4.6?

and if not, where can i find a 4.5 version for my bb, under which other carrier?

 

the middle easter carriers that support arabic do not have my handheld.

Now if I go back to that list and choose, blackberry curve (tm) 8330, I can see this handheld software with bell mobility

 

 

Software For BlackBerry® Curve (TM) 8330 smartphone   BlackBerry Handheld Software v4.5.0.101 (Multilanguage)

Package Version: 4.5.0.101
Consisting of:
  • Applications: 4.5.0.77
  • Software Platform: 3.2.0.51
  • File name: 8330AMEA_PBr4.5.0_rel101_PL3.2.0.51_A4.5.0.77_Bell_Mobility.exe
  • File size: 68.04MB

 

so now if i download this one, would it upgrade my os? would this cause any problems on my handheld?

 

thanks a lot, and sorry but i am actually a bit confused!!

Guru I
Xandrex
Posts: 18,406
Registered: ‎07-29-2008
My Device: Z30, Playbook, 9320BES
My Carrier: B&You _ SFR

Re: Arabic

hello,

the Desktop Manager is an application, and the versions varies. Latest are 4.3, 4.5 and 4.6.
On the other hand ,you have an OS on your Blackberry Curve. Versions vary : 4.2.2, 4.3, 4.5.

the two things are completely different and it's a shame that RIM continues giving numbers that look alike. Some people use Desktop Manager 4.3 with an OS 4.5. Most people (like me) use Desktop Manager 4.5 with OS 4.2.2.

Now, about upgrading an OS on your Blackberry, please read :
http://supportforums.blackberry.com/rim/board/message?board.id=8300&thread.id=6807&jump=true
just remember you need an OS for 8330. That is the only requirement for the installation of the OS to work for you.



The search box on top-right of this page is your true friend, and the public Knowledge Base too:
New Contributor
tarique24
Posts: 6
Registered: ‎10-31-2008
My Device: Not Specified

Re: Arabic

Hello Xandrex

 

Thanks a lot sir, that was helpful. However I have a bb 8830 (world edition) ... so I can only download the 4.5 os from any other carrier as long as it's for the 8830, right?

ok ... now I can't locate any carrier that have 4.5 for the 8830. do you know of any?

 

The middle eastern providers who support Arabic, they only have the curve (but i do not have the curve, i have the 8830), so can i intsall the 4.5 os for the curve on my 8830 BY ANY POSSIBLE WAY?

 

Thanks again,

Guru I
Xandrex
Posts: 18,406
Registered: ‎07-29-2008
My Device: Z30, Playbook, 9320BES
My Carrier: B&You _ SFR

Re: Arabic


tarique24 wrote:

Hello Xandrex

 

I have a bb 8830 (world edition) ... so I can only download the 4.5 os from any other carrier as long as it's for the 8830, right?

ok ... now I can't locate any carrier that have 4.5 for the 8830. do you know of any?


Yes you need an OS for 8830.

about carriers that have 4.5, you can look on google :

http://www.google.com/search?hl=en&q=8830+4.5

 


tarique24 wrote:

The middle eastern providers who support Arabic, they only have the curve (but i do not have the curve, i have the 8830), so can i intsall the 4.5 os for the curve on my 8830 BY ANY POSSIBLE WAY?


You can't. But you can buy another device that is supported by an arabic carrier.




The search box on top-right of this page is your true friend, and the public Knowledge Base too:
New Contributor
tarique24
Posts: 6
Registered: ‎10-31-2008
My Device: Not Specified

Re: Arabic

Looks like I'm gonna wait until they officially release the os 4.5 for the 8830 cdma device. everyone is expecting it to be very soon. Thanks man!

 

all i could find out there now, just beta os and they all have problems.

New Developer
gt5l
Posts: 9
Registered: ‎07-13-2009
My Device: Not Specified

Re: Arabic

[ Edited ]
I can help you with this. Please email me at {personal info removed - please provide help where possible on the forums so that all can benefit}
Message Edited by Jonathan_K on 07-13-2009 02:35 PM