Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Curve™

Reply
New Contributor
plavala
Posts: 2
Registered: ‎12-12-2008
My Device: Not Specified

Blackberry 8300 sim card trouble

My sim card worked fine in my Blackberry. I did some upgrades and now it "searches for Network" and finds nothing so my connection is a "red sos". I tried my sim card on my old Sony Ericsson and a Nokia and it works fine.

I cleaned the connectors in the Blackberry.

I put a different sim card in the Blackberry and it worked fine.

I don't know why it is not working with my sim card now.. Please Help.

Please use plain text.
Forums Veteran I
bbhorrigan
Posts: 2,036
Registered: ‎12-04-2008
My Device: 8900

Re: Blackberry 8300 sim card trouble

what model 8300?
******************************************************************


If someone helped you give them kudos. Research all info!
Please use plain text.
New Contributor
plavala
Posts: 2
Registered: ‎12-12-2008
My Device: Not Specified

Re: Blackberry 8300 sim card trouble

Oh. Didnt know there was more than one.. It's an 8300 Curve.

 

I also tried taking the battery out when the phone is on for it to re-boot itself. No go.

I looked at my Mobil network and it has 'TELIA' ( I live in Stockholm) but my card is to ComVIQ.

Like i said, the sim card was working in the phone before...

 

When I take the battery out the Mobil Network has '240.7' in the space...(or something to that effect).

 

I loaded the Desktop software into my PC.

Loaded in Upgrade installer package into phone. Had sim card in phone while upgrading.

Could that have made a difference?

Should  I have loaded a basic package before the upgraded package?

 

 

Please use plain text.