Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Curve™

Reply
New Member
mickael__242
Posts: 2
Registered: ‎06-04-2012
My Device: blackberry 8900

Re: Blackbery Curve 8900 wont turn on, solid red light only!!! HELP PLEASE???!!!!

it is deadbattery. too much drained and you just need to pull out your battery. charge your device in to wall charger or in usb in your laptop/pc then when the red light appears, insert your battery, and it will charge, a battery with blue lighting will appears and this means that your phone is charging. wait for 5-10 mins and it will turn on:Balloon:

New Contributor
OmarMel
Posts: 3
Registered: ‎08-26-2012
My Device: Blackberry Curve

Re: Blackbery Curve 8900 wont turn on, solid red light only!!! HELP PLEASE???!!!!

I have had my Blackberry Curve for just over a year and it's been recently restarting itself and killing the charge.  Today, my Curve froze so I took the battery out (since that seems to be the default remedy as suggested by Blackberry) and then the red light came on.  I haven't been able to get it working since.  There are some serious product flaws with Blackberry.

New Contributor
ilovevegans
Posts: 7
Registered: ‎02-27-2011
My Device: Blackberry Curve 8900

Re: Blackberry Curve 8900 wont turn on, solid red light only!!! HELP PLEASE???!!!!

[ Edited ]

i don't know if it's a coincidence or not but the same thing was happening to mine and i came to this page....didn't do anything complicated or try to reload the OS...I was watching the little light go off and come on and stay on for along time and repeat that going off for a long time ...to make a long story short,I pulled the battery[again] and put in the old battery(a Blackberry battery,the original one that came with it,i replaced it just a few days ago because the original battery is getting old and temperamental...  but it is a 3.7 1400 the one i got was a 3.6 1300 rayovac,i can't get a BB battery anywhere[two from Amazon were junk,they were BB batteries,but were junk anyway(one came absolutely dead and the other one worked for about two months then kept draining realy fast and dying...i was using the old battery but went to a local battery store and got the Rayovac 3.6 1300) at Sprint and Tmobile they said they can't order a BB battery,what's up with that,where can i get a BB battery for my Curve 8900? i never thought it would be a problem]...mine died tonight and i had deleted the the first game i ever put in(and it was a "deletion will be complete on start up")...so it's been there for a long time,and maybe the battery was not up to the task of doing what it should do,or the new battery is messing up the way it should run[the guy said it was fine and just a different measurement... that it would work and i took his word for it;or he plain lied because they didn't have a Rayovac 3.7 1400...BUT....(what fixed it,or it was a coincnidence and it was going to start working anyway)I ran my fingers over the little posts the battery fits onto...those four little gold things...i had told myself praying wouldn't revive it and didn't pray[God knows i don't or almost never pray anyhow...]...but the white bar came up and it rebooted...i repaired the memory card and got the wallpaper i put on[a picture...totally dead batteries will make your pictures vanish but repairing the memory card usually fixes that....charingg a dead battery with your BB off will lose your picutres and your voicenotes forever...so i always recharge a drained battery with it on...turning it off can get you in rouble too if you don't turn it on once it starts charging...](and i had it on the wall charger and switched to the USB,thinking maybe my wall charger was fried...also did the wet the finger with a tiny bt of spit to help the connection{my old Razr phone needed that sometimes}....but,unless it was going to start working anyway,it immediately started working after i ran my finger over the posts the battery goes onto abnd out the battery back in,it was on the USB charger but i unpligged it while i was messing around with it,and when i plugged it back in,with the old battery,it started up. I'm almost afraid to put the rayovac battery back in. I probably will but i really don't want to lose the things that i know will be gone if this one is ever lost or stops working and never starts again. It could be the old battery was just too dead and because a 3.6 1300 is obvioulsy not a 3.7 1400...there might be a problem with that if it was totally drained. It had been working okay;but i was on  a game for a long time [Draky] and maybe the battery was more dead than the three bars it showed. I also deleted two things,two games,and ended up on the Red light stays on my BB dead waaa page

New Contributor
ilovevegans
Posts: 7
Registered: ‎02-27-2011
My Device: Blackberry Curve 8900

Re: Blackberry Curve 8900 wont turn on, solid red light only!!! HELP PLEASE???!!!!

me again. i got brave and put in the rayovac battery,and connected it to the usb charger...it's rebooting fine;i really think the battery was just too dead and the BB didn't know what to do...it took awhile of playing around with it and maybe it was me running my finger over the posts that did it,plus the time it was on a charger was awhile too,with the new and the old battery...the old battery was fully charged and a few days ago when i put the new rayovac 3.6 1300 in...and when i pulled it and  took it off the charger just now[it's been plugged into to my laptop all this time],it had a full charge on it;my laptop also couldn't find my BB,it was nowhere on the disc defragmenter page and it always shows up there,also tether app was not found...when i tried running tether(all of this was when it was just showing the red light and nothing else was happening);it just rebooted [with the rayovac battery in]and shows two battery bars and the gold slash right now...maybe i did just delete too many games[two]at one time and the second was a "deletion will be completed on restart"...that was the last thing it said before i got the red light silent treatment. but it looks like everyhing is okay now.  whew!glad of that. Maybe i didn't have to repair the memory to get my wallpaper up...it showed the default wallpaper (when it rebooted after i put the rayovac battery back in) and i unplugged the USB and my own wall paper showed up....i had to unplug the usb to repair the media card the first time because it said it wouldn't repair it because the mass media storage was in use...i assumed that meant i should take it off the usb so i did and that message went away and i repaired the card. And it's okay now[note.;in the Settings folder under Memory is the repair choice;if you repair the memory card,SAVE any lost fragments....(it asks about that,click the SAVE choice]....now if i could only get my bathtub faucet to stop dripping....(seriously,i tried fixing it tonight but i'm thinking O rings aren't the answer and i'll just have to replace the valve (again-after about 7 years since i replaced the other one).no big deal i was just thinking it wouldn't need replaced. But,if i have to,i have to...)