Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Curve™

Reply
New Member
smr12
Posts: 1
Registered: ‎10-12-2012
My Device: 8520 Curve
My Carrier: T-Mobile

Continuing Issues

I have a Blackberry Curve 8520. I have been having ongoing issues for the last several months. I am still experiencing these isssue. I have had the phone replaced 2 times, a new battery, a new sim card, a new charger. Nothing has solved the issues I am experiencing. If I make a couple of call one after the other during the 2 or 3 call the screen goes completely blank, i loose the call. If I am out the phone is of no use any longer. I also get terrible static. The people to whom I am speaking tell me all the time that there is terrible interference and they are only hearing a couple of words, I am now experiencing that same issue, not be able to hear all of the conversation. When I am able to plug the phone into the charger, it is still showing that it fully charged,  it always goes back to the welcome blackberry screen and I must start all over, re-verify my email etc. I also can not get the phone to sync back to my car's bluetooth.

 

This phone cost me $500. I am not happy. I want a Brand New Phone not a refurnished one, I want a different model. I am extremely unhappy with this situation. I need this to be resolved now! As this is my only phone.

Please use plain text.
Super Contributor
f0xx386
Posts: 298
Registered: ‎06-10-2012
My Device: Curve 9360
My Carrier: MTN - SOUTH AFRICA

Re: Continuing Issues

Hello Smr

It appears from your post that you are under the impression that this is "the official blackberry forum", a support forum provided by blackberry manufacturers, RIM, themselves.

I'm afraid this is not the case, we are just blackberry fans providing a service free.

With that being said, I'm sorry to hear about your problems you are facing.

Getting to your phone by any chance did you note what OS (version of operating system) was installed on all 8520s. In the rare case they are same it may require an upgrade to latest OS 5 version.

The os may contain buggy radio files that are causing your problem. If still under warranty, request the phone replaced with a 8520 from a different batch manufactured elsewhere.

If its a batch from mexico, see if you can get one made in Hungary for example. Not to say Mexico makes lousy phones.

Personally I think an os upgrade should be done.
Please use plain text.