Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Curve™

Reply
New Contributor
Posts: 2
Registered: ‎01-18-2012
My Device: 11111111111111

Curve 3G shuts down when using browser.

Device info

Your carrier: Three

Model info and OS version: 9300 (3G) OS 6.0 bundle 2949

Free space

Free memory: 46824673 bytes.

Did a battery pull fix your issue? At first it did, however it no longer works

When writing your question

Any other details that would help us out with your issue: This issue suddenly occured, my phone is still in good condition (1.5 years old).

 

Basically, my issue is whenever I go on the browser (or Opera and Ebay), my phone announces it is out of battery (even when on around 80%) and then shuts off. You can turn it back on with a battery pull, however the same will happen again if you try and go on the internet. Recently, it has got worse, turning off without a warning.

Anyone else had this issue?



New Member
Posts: 1
Registered: ‎02-09-2012
My Device: Curve 8830
My Carrier: America Movil - Telcel

Re: Curve 3G shuts down when using browser.

I am having the exact same problem, i live in Mexico city, and both a technician and customer support of my carrier say that it is a battery issue, I'll buy a new one and let you know if the issue is fixed, if you find another way to solve this, please let me know.

 

Good Luck

New Contributor
Posts: 2
Registered: ‎01-18-2012
My Device: 11111111111111

Re: Curve 3G shuts down when using browser.

Yes, it is a battery problem. I got a new battery last week and it works perfectly now!

Highlighted
New Contributor
Posts: 9
Registered: ‎10-27-2011
My Device: Curve 8520
My Carrier: T-Mobile

Re: Curve 3G shuts down when using browser.

I have the same problem, mine even shuts down when I'm using the phone. When I plug it to a power source, it comes back on. I was going to post this but decided to see if anyone had this problem, glad I did. I will take your advice and get a new battery and hopefully it will resolve my problem too.

Thanks.