Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Curve™

Reply
New Contributor
Posts: 2
Registered: ‎07-07-2012
My Device: Curve 9300
My Carrier: Rogers

Curve 9300. Missing USB drivers?

I get an error that says "This device cannot charge your phone" and clicking more information tells me I don't have the USB drivers installed. Two problems. The first is that I have the desktop app which supposeduly was supposed to install these automatically, and second was that the first time I saw this error, I had it plugged into the wall via a USB -> AC adapter. So, no computer involved.

I'm getting seriously frustrated, because I've already had to take the phone back twice for replacement and a new battery. This seems like it can be fixed on my end, but I can't find a download for the drivers. All previous links in the forums seem to be broken.

Hall of Famer II
Posts: 51,278
Registered: ‎11-28-2008
My Device: Z30/Z10/Q10 (10.3.1.2582), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Curve 9300. Missing USB drivers?

Hi and Welcome to the Community!

 

You are correct...the Desktop Software includes all necessary drivers...maybe a clean "start over" will help. I suggest this thread:

It starts with a process for cleanly starting over, and there is some discussion, and there is also a post (15) with links to older Desktop Software versions, if those are needed. Note that this is not, by any means, guaranteed to work...but it has worked for many to resolve issues they are having.

 

Or, you can try this link:

  • KB04761 How to install the USB drivers for the BlackBerry Device Manager without the BlackBerry Desktop Manager installed

But, this concerns me:


Disatisfied wrote:

the first time I saw this error, I had it plugged into the wall via a USB -> AC adapter. So, no computer involved.


That sounds like a serious problem. If the charger was known-good and the wall outlet was also good, then that message should never appear on your BB. To me, it would indicate a hardware problem inside the BB...as in, the connections inside, between the USB port and the motherboard, are damaged, loose, or otherwise not connecting properly. If that is the case, then there is no software on earth that will cure it. And, sadly, it would mean yet another trip to seek warranty support.

 

I know it's frustrating, but devices designed and built by humans can never achieve perfection. But, you are perhaps in that unlucky tiny subset of users that experiences multiple failures sequentially. Sad, but not impossible.

Good luck!




Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code