Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Curve™

Reply
New Contributor
Posts: 2
Registered: ‎07-03-2012
My Device: Curve 9360

Help Anybody?

I've been trying to fix my curve 9360 for a while now, but I'm not having any success. The phone won't charge, turn on, or even connect to my computer. Sometimes when I connect it, the little red led light comes on and it connects for a bit.. but after a few seconds it disconnects again. I've tried pulling the battery a few times, but it still didn't work. Before when it was working, it wouldn't hold much charge.. so I'm wondering if it's a problem with the battery? Has anyone had the same problem as me? :Helpsmilie:

ssrxo
Forums Advisor III
Posts: 1,077
Registered: ‎04-23-2012
My Device: 9780

Re: Help Anybody?

Hello Ssrxo,

 

Welcome to the community.

 

I have faced this issue with many blackberry devices and belw mentioned procedure helped me many times, hope you will have luck as well.

 

Pull out battery > Connect handheld with charger  & wait till you get a red cross with battery sign on handheld > once you get the sign, please insert battery without un plugging charger and wait for few mins.

 

Hope this will resolve your issue.

 

Good luck..!

New Contributor
Posts: 2
Registered: ‎07-03-2012
My Device: Curve 9360

Re: Help Anybody?

I did exactly what you said but it didn't work. I pulled the battery, waited for the battery sign with the red cross, then put the battery back in. The charging screen came on for a bit then went back off and the red led flashed for a bit, then everything went blank again. :smileyfrustrated:

ssrxo
Forums Advisor III
Posts: 1,392
Registered: ‎03-29-2012
My Device: BlackBerry Z10 OS Leaked 10.2.0.1725 | STL100-2

Re: Help Anybody?

Hi

 

You may also try this. Read this article.

How to force the detection of the BlackBerry smartphone using Application Loader

 

Thanks. Hope it helps.

 

Good luck!



Please thank those who help you by clicking the button.
If your issue has been solved, please resolve it by marking "Accept as Solution"