Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Curve™

Reply
New Contributor
miochan984
Posts: 7
Registered: ‎06-14-2013
My Device: curve 9300

I REALLY NEED HELP WITH MY CURVE 9300'S WIFI!

HI !

 

i have a blackberry curve 9300, OS5. I got it secondhand. It worked really great, but the problem started when I've done that thing within the host routing table. Though my wifi is connected, I can't use the internet. whenever I tried the BB browser and any other application (e.g. facebook, opera mini, etc.) i get a message that says 'i am not in an area that supports blah blah...' or 'unable to connect to internet please try again later'. I checked the browser under browser config and it is set to my local network provider. i changed it to hotspot browser, saved it. But whenever I go back it also goes back to my local network provider. i have tried almost EVERY troubleshooting I've read on this forums and in other forums but still no luck. The problem worsened when I did a security wipe on the emails, contacts, etc.

 

-APN settings are disabled

-default browser set to hotspot browser

-firewall disabled

-data services are on

 

 

Everyone said that it has nothing to do with that activation enterprise so I did not configured it after wiping.

I also tried doing a hard reboot (pulling the battery out and waiting for 5 minutes before turning it on) but it will only fix the problem for sometime and it will go back again.

Calling my network provider would just suggest to get a plan when in fact, I was able to use the device's wifi well before without any plan.

I don't want to upgrade my BB to OS6 coz it easily drains the battery of device and I cannot afford doing that because I go out a lot.

I also tried changing my sim card and network provider but wasn't successful.

I also tried deleting the name of my local network provider in the service book under options.

 

 

What do you think could be the problem? Any suggestions? I really, really, REALLY, need help.

 

 

PLEASE ! THANK YOU VERY MUCH IN ADVANCE!

Retired
FrankieS
Posts: 2,795
Registered: ‎05-10-2010
My Device: BlackBerry Z10 smartphone

Re: I REALLY NEED HELP WITH MY CURVE 9300'S WIFI!

Hi miochan984,

 

Welcome to the support community!
A supported data plan from your mobile network provider may actually be required to use the Facebook for BlackBerry smartphones application as well as the browser. I would recommend verifying with them which services they support over a Wi-Fi connection without a data plan.

Let me know if you have any other questions.


-FS


 


Come follow your BlackBerry Technical Team on Twitter! @BlackBerryHelp


Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!



New Contributor
jellyjam7
Posts: 5
Registered: ‎11-21-2013
My Device: 9300 curve

Re: I REALLY NEED HELP WITH MY CURVE 9300'S WIFI!

Hi. want to check if you were able to resolve your issue?i am having same now,been having lots of problem connecting to wifi ever since my battery got drained.

 

hope you could share.

New Contributor
miochan984
Posts: 7
Registered: ‎06-14-2013
My Device: curve 9300

Re: I REALLY NEED HELP WITH MY CURVE 9300'S WIFI!

It wasn't resolve. All of the applications I have were supported over wifi, even facebook. But at some point, it still goes back to that 'no connection' thingy. but I had a discovery; it also happens with bb 9320 and 8570. The 9320 has an active data plan subscription and was brought brand new but got the same problem. I guess there's nothing we could do with it, eh?
New Contributor
jellyjam7
Posts: 5
Registered: ‎11-21-2013
My Device: 9300 curve

Re: I REALLY NEED HELP WITH MY CURVE 9300'S WIFI!

:smileysad: so disappointed with switching to blackberry, am now contemplating on going back to samsung...thanks anyways, do keep me posted if you get any update on how to resolve this:Yes: