Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Curve™

Reply
Contributor
Posts: 13
Registered: ‎06-18-2009
My Device: Not Specified
Accepted Solution

TCP/IP issues with OS v. 4.6

Greetings, all.

 

Just got my 8900 last night, and so far I'm very impressed indeed. Most of the applications that I've needed have been immediately and easily available, the handset itself is intuitive and easy to use - a great n00b experience all 'round. My problem is that I'm trying to get some third-party SSH, FTP, and SFTP clients working properly. I'm getting tunneling exceptions, which is apparently caused by an incorrectly configured APN.

 

I tried to change the APN settings as per instructions here (my carrier is Cincinnati Bell). Unfortunately, something seems to have changed between the article's publishing time and the current OS revision: I am no longer able to specify gateway IP or port. While I can provide the APN's url and a username and password, that doesn't seem to be sufficient to fix my tunneling problems.

 

TL;DR: This application is saying "Session error; Writer: tunnel failed". This is apparently caused, as per here, by incorrectly configured connection details. The recommended solutions page here points me to here, which tells me to do something that I cannot. For one thing, Options->TCP appears to have been replaced with Options->Advanced Options->TCP/IP, and seems to have had some functionality removed. The recommended actions caused no change in the application's behavior.

 

Ideas? Any help would be greatly appreciated.

 

Many thanks,

Chris Akins

Hall of Famer II
Posts: 50,642
Registered: ‎11-28-2008
My Device: Z30/Z10/Q10 (10.3.1.2582), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: TCP/IP issues with OS v. 4.6

Hi and Welcome to the Forums!

 

First -- great report! Excellent! Stick around a while and help others, OK?

 

Second...while I've never attempted what you are attempting, I didn't see any RIM KB's cited in your links. So, here's the links to the RIM KB's that discuss the "tunnel failed" message:

 

http://www.blackberry.com/btsc/microsites/search.do?cmd=displayKC&docType=kc&externalId=KB11221&slic...

 

http://www.blackberry.com/btsc/microsites/search.do?cmd=displayKC&docType=kc&externalId=KB05365&slic...

 

Hopefully something will be helpful. But, just in case, here's the link to the public KB's that you can search using different terms:

 

http://www.blackberry.com/btsc/microsites/microsite.do

 

Hope that helps!




Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Contributor
Posts: 13
Registered: ‎06-18-2009
My Device: Not Specified

Re: TCP/IP issues with OS v. 4.6

...gremlins. That's the only explanation I can think of. An hour and a half after I changed the APN settings, it fixed itself. I guess there's a bit of lag somewhere in the system somewhere.

 

Regardless, it works now, and thanks for the advice. I'd not found the BTSC earlier; thanks much for pointing me at it. And I do believe I might hang around. It seems a friendly place.

 

-Chris

 

 

Hall of Famer II
Posts: 50,642
Registered: ‎11-28-2008
My Device: Z30/Z10/Q10 (10.3.1.2582), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: TCP/IP issues with OS v. 4.6

You are most welcome! We will be watching for you!! :smileytongue:

 

Cheers!




Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
New Contributor
Posts: 8
Registered: ‎06-25-2009
My Device: Not Specified

Re: TCP/IP issues with OS v. 4.6

Hello and HELP.

I have been unable to get my personal email sertup on my BB8900 and seem to have messed up some configuration,

While I was able to connect to my home wi-fi before, I am now unable to do so.The signal is there but no coneection is being made.

 

I was messing around with TCP/IP where it says APN settings enabled (ticked)and I changed the APN: ?????????

Now there is nothing written there and I don't remember what was written there to put it back.

 

Would anyone know what was there from the original configuration so I can recover my Wi-Fi?

 

reason W010: Wi-Fi conection failed

 

Thanks,

 

Ricardo