Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Curve™

Reply
New Contributor
Jessycar
Posts: 2
Registered: ‎12-08-2012
My Device: blackberry curve 8520
My Carrier: any

signal blackberry curve 8520

[ Edited ]

OK so basically, iv ulocked my blackberry myself from Virgin mobile to any network, but ever since that, my signal is always saying 'off' everytime I press the box next to mobile network in the MANAGE CONNECTIONS, It keeps on going on to 'SOS' I have a 3 sim in the phone and its not letting me text, call, go on the internet etc:.But before I unlocked my phone it was working perfectly...What can I do to make it working in order again?

Please use plain text.
Guru I
John_Clark
Posts: 14,975
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.3.0.1052; PlayBook w/OS 2.1.0.1917
My Carrier: at&t

Re: signal blackberry curve 8520

Have you tried rebooting the phone by removing the battery?
--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Please use plain text.
New Contributor
Jessycar
Posts: 2
Registered: ‎12-08-2012
My Device: blackberry curve 8520
My Carrier: any

Re: signal blackberry curve 8520

Yes, iv tried hard reset, wiping the phone, battery pull out, everything, and it doens't seem to solve it..

Please use plain text.