Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Desktop Software

Reply
New Contributor
Rev_Lyn
Posts: 5
Registered: ‎08-19-2009
My Device: Bold - 9650

BBDS v7.0.0.43 requires MS Vis C++ 2008 SP1

New BBDS v7.0.0.43 requires MS Visual C++ 2008 SP1 Redistrubutable Pkg.

 

BUT in checking into this download from the Microsoft Download Center, I noted a MS message there stating "a security issue has been identified that could allow an attacker to compromise your Windows-based system with Microsoft Visual C++ 2008 Service Pack 1 Redistributable package."

 

Don't think I will make this BBDS update, given this warning and possible risk.  Think I will wait for the next BBDS version - and w/o this risk!!

 

Blessings, Lyn

New Contributor
RedOyster
Posts: 5
Registered: ‎08-16-2010
My Device: Pearl 3G (9100)

Re: BBDS v7.0.0.43 requires MS Vis C++ 2008 SP1

I think you may have mis-interpreted the warning - the SP1 update was supposed to fix the vulnerability.  However, even after downloading & installing the update, the BBdesktop software still stops with the same error message.  If I were you, I'd check back in a few days to see if a BB tech has posted a fix.

 

I'm having the exact same problem - I even downloaded the update from Microsoft 3 times and I still get the error message.  The last few updates of BBdesktop have been problematic for me - I had to skip the last one because the sync kept on crashing.  My loyalty to the brand is beginning to falter....:smileymad:

New Member
Barcud
Posts: 1
Registered: ‎02-15-2012
My Device: Curve 9300

Re: BBDS v7.0.0.43 requires MS Vis C++ 2008 SP1

Exactly same problem here.  Downloaded 3 times .  Downloaded and re-installed VB 2008 (and 2010) to be on safe side.  Still no good....Doh Blackberry.....

Contributor
kermit1
Posts: 14
Registered: ‎02-15-2012
My Device: Q5

Re: BBDS v7.0.0.43 requires MS Vis C++ 2008 SP1

Hello BB users,

 

I am getting the same error (C++ 2008...) when trying to upgrade BB desktop to verion 7.0.0.43.

 

Anyone has any solutions ?