Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Desktop Software

Reply
Contributor
nasher45
Posts: 10
Registered: ‎09-28-2012
My Device: 9800

DM won't update to latest bundle for 9800

I recently updated my 9800 to what I thought was the latest os bundle, 2647. I then realised that 2949 is the latest one on 9800 but the web, the dm, over the air, all say that the currently installed 2647 is the latest. I also removed the DM and tried the manual apploader way after downloading the 2949 bundle direct from BB website.

The 9800 is now freezing regularly and I went to downgrade the OS but desktop manager only lists the current bundle. I am desperate to try and resolve this either by upgrade or downgrade. Can someone please help me!

Hope all this makes sense!
Retired
hmthepirate
Posts: 3,246
Registered: ‎07-26-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: DM won't update to latest bundle for 9800

Hello nasher45 and welcome to the BlackBerry® Support Community Forums.

 

Software updates are determined by your mobile network provider. Ensure you are installing software that has been approved and released by your mobile network provider.

 

You can find the latest software updates from your carrier here.

 

If your BlackBerry® Desktop Software only see the bundle from your carrier's site then it would be advised that you install that bundle.

 

Hope this answers your question.

-HMthePirate

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!



Contributor
nasher45
Posts: 10
Registered: ‎09-28-2012
My Device: 9800

Re: DM won't update to latest bundle for 9800

I tried that link and downloaded latest file but apploader said I had latest software despite the fact my carrier has the 2949 bundle listed on that link, and that's what I downloaded. Also I can't downgrade to previous software which I thought you could do through desktop software
Retired
hmthepirate
Posts: 3,246
Registered: ‎07-26-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: DM won't update to latest bundle for 9800

Is your device unlocked from another mobile carrier or did you purchase if from your carrier?

If it is unlocked then you need to check the branded carrier of the BlackBerry as you can only install software released by the branded carrier on your device.

If your device isn't unlocked and you bought it direct from your carrier and are unable to upgrade then it is recommended you contact them to investigate this matter further.

Hope this helps!

-HMthePirate

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!



Contributor
nasher45
Posts: 10
Registered: ‎09-28-2012
My Device: 9800

Re: DM won't update to latest bundle for 9800

Yes it is an unlocked handset but don't know original carrier! Is there anyway I can find that information out
Retired
hmthepirate
Posts: 3,246
Registered: ‎07-26-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: DM won't update to latest bundle for 9800

If you can send me a private message with your PIN I can investigate for you.

Also, hold ALT, the Left Shift (aA) and H key to access your Help Me Screen and provide the Vendor ID.

Thanks!

-HMthePirate

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!