Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Desktop Software

New Member
Posts: 0
Registered: ‎10-19-2011
My Device: Torch - 9800

Desktop software for Windows 7 (64bit)

I seem to have a problem with the Blackberry desktop software that is availible from the website. It only downloads the 32 bit version for Windows 7. I need the 64 bit version, please help??

Guru III
Posts: 30,779
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Desktop software for Windows 7 (64bit)

i downloaded it from here, i dont think it is a true 64 bit program but it does run on 7 SP 1 64 bit OS on my laptop.




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!

Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.

SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope

Want to thank me? Buy my KnottyRope App here

BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V

New Member
Posts: 0
Registered: ‎10-19-2011
My Device: Torch - 9800

Re: Desktop software for Windows 7 (64bit)

Nope, sorry. Have tried it but still giving me the same 32 bit error. Thanx for the efford....
Forums Advisor III
Posts: 1,069
Registered: ‎04-12-2009
My Device: Samsung Galaxy S II SkyRocket (yes, Android)

Re: Desktop software for Windows 7 (64bit)

Well, what is the error? Because I'm using that, too, and it works fine.
New Member
Posts: 1
Registered: ‎01-11-2012
My Device: Bold 9700

Re: Desktop software for Windows 7 (64bit)

you need to download the hotfix here :