Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Desktop Software

Reply
Developer
ubuntaur
Posts: 41
Registered: ‎09-11-2009
My Device: Not Specified

Trouble using MDS with Blackberry Simulator

So I've been using JDE to build applications and they run on my Blackberry simulator just fine.  Now I want to access the internet using my simulator.  I installed MDS and when I run it it opens and stays open (I've read about the issue where it won't stay open, that isn't the case).  Once MDS is running, I boot up my simulator.  I try to access www.google.com in the simulator's brower but I still get the "Unable to connect to the selected Mobile Data Service, please try again later.  If the problem persists please contact your system administrator." error. Is there a trick to using the MDS?

 

Black Berry JDE 4.7.0

BlackBerry JDE Component Package  4.7.0

BlackBerry Smarthphone Simulators 4.7.1.40 9630

BlackBerry E-mail and MDS Services Simulators 4.1.2

 

Developer
ubuntaur
Posts: 41
Registered: ‎09-11-2009
My Device: Not Specified

Re: Trouble using MDS with Blackberry Simulator

Also, I've gone to the "Manage Connections" menu and turned on all connections, but it still won't work.
New Developer
shubhra
Posts: 39
Registered: ‎10-13-2009
My Device: Not Specified

Re: Trouble using MDS with Blackberry Simulator

I'm facing the same problem. Do u have a solution for that?
Developer
ubuntaur
Posts: 41
Registered: ‎09-11-2009
My Device: Not Specified

Re: Trouble using MDS with Blackberry Simulator

My application uses a TCP socket  to talk to a server and it seems to work even when I don't use the MDS so I ended up not really having a solution.

New Developer
DDHSoftware
Posts: 4
Registered: ‎11-04-2009
My Device: Not Specified

Re: Trouble using MDS with Blackberry Simulator

In case you haven't found the solution, check out this thread for the answer.

 

http://supportforums.blackberry.com/t5/Java-Development/9630-Simulator-NOT-working-with-MDS-Simulato...