Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Device software

Reply
New Contributor
jtomberg
Posts: 5
Registered: ‎05-29-2012
My Device: OS7
My Carrier: Various

Blank html emails - not a BES issue

Hi - this is my first post here so please bear with me.

 

I run a website that sends transactional emails to users.  The emails work fine on all clients except for Blackberrys running OS7.  For those users, they receive just the header information and then the rest of the email is completely blank.  They are able to click to get the text version and that works fine, but the html version is completely blank.  Other Blackberry users see the same emails just fine (images are not displayed, but they can click to display the images and then all is ok).

 

I've spent days searching and only found 1 other report of something similar and they have yet to resolve the issue.  Does anyone here have any ideas on what the problem might be?

 

Thanks in advance.

Please use plain text.
JSanders
Posts: 83,986
Likes: 22,839
Solutions: 5,881
Registered: ‎04-01-2008
My Device: Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Blank html emails - not a BES issue

This is your finding for both OS7.0 and 7.1?

 

If I send you my email via a private message on this board, could you test me?




1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes


Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Please use plain text.
New Contributor
jtomberg
Posts: 5
Registered: ‎05-29-2012
My Device: OS7
My Carrier: Various

Re: Blank html emails - not a BES issue

I'll send you a test email in a few minutes.  It will come from support@groupvalet.com.

 

To be fair, I've found this with OS7.1.

Please use plain text.
JSanders
Posts: 83,986
Likes: 22,839
Solutions: 5,881
Registered: ‎04-01-2008
My Device: Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Blank html emails - not a BES issue

I received your test email.

When I first opened it, it was blank with no body in the email (the subj line was populated).

 

I closed it and re-opened again and the full body of the email was there (with the images and graphics (to click yes or no to the golf invite) along with the footer to unsubscribe, etc.

 

So, this is working on OS 7.1. although it was slow in coming across.

 

I clicked "Get plain text" and could read the message again, but when I clicked again on "Get HTML", the body was blank again. I will look again later to see if the body has populated again.




1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes


Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Please use plain text.
New Contributor
jtomberg
Posts: 5
Registered: ‎05-29-2012
My Device: OS7
My Carrier: Various

Re: Blank html emails - not a BES issue

Interesting.  About how long did you wait before going back to the html version where you saw the email?  I've had users go back multiple times and always see the blank one.  Any thoughts as to what might cause this?

Please use plain text.
New Contributor
gentrysm
Posts: 5
Registered: ‎02-17-2012
My Device: Torch 9800
My Carrier: AT&T

Re: Blank HTML emails

I have this same issue with a 9810 running OS7. It only happens on the emails to my BB account not my yahoo.com emails. 9800 running OS5 never had any issues with this and it is the same type of emails (almost all from Pageonce and a few others). It is soooooo infuriating.

Please use plain text.
JSanders
Posts: 83,986
Likes: 22,839
Solutions: 5,881
Registered: ‎04-01-2008
My Device: Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Blank HTML emails

Let me first advise you to get a new email account other than your BlackBerry email address... those accounts do not have server viewing and if anything ever happened to your handheld, you'd never see the emails at all.

 

For those PageOnce emails... when you open the email, do you see the email headers at the top (the To:, From: and CC: etc), and the subject line?

At that point, try turning your 9800 sideways horizontal or if already there, turn it vertical to Portrait.

 

Does your message appear then?




1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes


Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Please use plain text.
New Contributor
gentrysm
Posts: 5
Registered: ‎02-17-2012
My Device: Torch 9800
My Carrier: AT&T

Re: Blank html emails - not a BES issue

Yes all the header info shows up and yes when I turn the 9810 (9800 didn't ever have this issue) the msg shows up. While I'm grateful for this simple solution I am left wondering why this is so. The 9800 with OS5 never had this problem. Could it be related to having 11 pt font as the default instead of the teeny tiny default?
Please use plain text.
JSanders
Posts: 83,986
Likes: 22,839
Solutions: 5,881
Registered: ‎04-01-2008
My Device: Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Blank html emails - not a BES issue

Yea, I have the same issue with emails from Twitter.com and very few other servers, I don't know a long term solution.

Just flipping it back and forth once usually does it for me.

 


gentrysm wrote:
The 9800 with OS5 never had this problem.

The 9800 Torch never had OS5... released with OS6 and still on OS6.


gentrysm wrote:
 Could it be related to having 11 pt font as the default instead of the teeny tiny default?

Likely not, mine is on 10pt.





1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes


Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Please use plain text.
New Contributor
gentrysm
Posts: 5
Registered: ‎02-17-2012
My Device: Torch 9800
My Carrier: AT&T

Re: Blank html emails - not a BES issue

Yep you are right it was OS6, regardless it was not an issue in prior version. I tried reducing the font to default and it had no effect.  This is only an issue with my BB email, no other email accounts on my phone have this problem. Very irritating. Can't believe RIM hasn't seen fit to fix this. Makes we wonder if BB10 is worth it.

Please use plain text.