Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Device software

Posts: 1
Registered: ‎09-20-2012
My Device: Curve 9300
My Carrier: Telcel

Browse isnt working on my CURVE 9300

Hi !!!!


I have a curve 9300, and it was all working fine.. Ive onlhy had it for a year.. until it started to slowly go crazy... but still manageable.. the last thing - which i havent been able to fix - is my browser stopped working from literally one day to the next!!!!!!! It is still there, but when clicking on it it doesnt even open!!!!! The WAP window opens but doesnt download anything which is ok because i've never even looked at it, but the Internet Browser does nothing!!! Facebook, Whatsapp, Twitter they are all working correctly, SMS, MMS, music, everything seems to be normal except for the IB!!!!!!! It is driving me crazy because I have no idea on how to solve it!!!


PLEASE HELP !!!!!!!!!!!!!!!!!!! 

Elite I
Posts: 6,657
Registered: ‎01-14-2009
My Device: BlackBerry Z10
My Carrier: Telus

Re: Browse isnt working on my CURVE 9300

Start by doing a battery pull. While the device is on, remove the battery for 15-30 seconds, reinsert and wait for the device to reboot. Does this help?

If not, the next step might be to reload the software on the device to start from scratch. To do that, use the instructions in the following link:


Hopefully that will help!

If you want to thank someone for their comment, do so by clicking the Thumbs Up icon.

If your issue is resolved, don't forget to click the Solution button on the resolution!