Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Device software

Reply
New Contributor
giacorne
Posts: 7
Registered: ‎06-20-2008
My Device: Not Specified

Duplicate e-mail received with BIS

I have set up a BIS solution with an Outlook Exchange Server 2007.

When I am at my laptop (with Outlook) and open, forward or reply to mails that are in my inbox, they are sent again to my Blackberry device. every time I open, forward or reply to the same mail (or even move it from a .pst file back in the inbox) it is duplicated and sent again to my device.

Anyone can help?

Thanks in advance.

 

Please use plain text.
Trusted Contributor
frfghtr
Posts: 139
Registered: ‎04-01-2008
My Device: Storm 9530 / PlayBook 64GB

Re: Duplicate e-mail received with BIS

Try this.

 

Go into your BIS account and create a filter for the email address you set up.

 

In the:

 

Apply filter when: enter "From" field

 

Contains: enter your email address xxxxx@xxx.xxx

 

Then tick Do not forward messages to device. 

Please use plain text.
New Contributor
giacorne
Posts: 7
Registered: ‎06-20-2008
My Device: Not Specified

Re: Duplicate e-mail received with BIS

Thanks for your input. But it does not work.

I have set the Filter but mails are sent again and again to my device every time I open them or view them in my inbox.

Any other suggestion?

Thanks.

 

Please use plain text.
Forums Veteran I
BBsingh
Posts: 1,546
Registered: ‎04-01-2008
My Device: 8120, Storm, 8200

Re: Duplicate e-mail received with BIS

technicaly this should not happen. It seems like the UID (unique id's) for the messages are being changed on your mail server which makes hte BIS think its  a new message and poll it. WHat kind of email address is it? do you use outlook for the same email address on your PC or you check it online only via web mail? is it only one message or all messages being duplicating? if possible, download your mail to oulook and then clear everyhting that is old from webmail .
*****************************************************************************
Click on KUDOS to appreciate our efforts and mark the thread RESOLVED if your issue is resolved.
Please use plain text.
New Contributor
giacorne
Posts: 7
Registered: ‎06-20-2008
My Device: Not Specified

Re: Duplicate e-mail received with BIS

It is my company's e-mail address.

I use Outlook on my Laptop  when I am connected to the LAN in the office, but the same thing happens if I check my mail through OWA on any Internet connection. The account has been configured on the BIS with IMAP/POP protocols.

All messages are being sent duplicated if I read them or reply (or do whatever) to them and they remain in the inbox.

A temporary solution I have used is to use a dummy folder to manage the inbox.

I move all messages to this folder as soon as they arrive. In this way my inbox is always empty and the problem obviously does not show up. But this solution cannot be accepted as BIS should recognize messages already read or not (correct?).

 

Please note that I have also configured my GMAIL account on the same device, and it works properly. No problem with that.

 

Please use plain text.
Forums Veteran I
BBsingh
Posts: 1,546
Registered: ‎04-01-2008
My Device: 8120, Storm, 8200

Re: Duplicate e-mail received with BIS

BIS does not talk to your Outlook, it does to the pop/imap mail server. seems like the issue is on your mail server as it is changing UID's of the messages and BIS thinks its a nerw mail since the UID is changed (thats how BIS works, bu UID's) and then push the same message back to BB>

 

can you delete POP/IMAP inteagrtion and integrate same email address using OWA instead. this is how you will do it:

http://www.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB03133&sliceId=SAL_Pub...

*****************************************************************************
Click on KUDOS to appreciate our efforts and mark the thread RESOLVED if your issue is resolved.
Please use plain text.
New Contributor
giacorne
Posts: 7
Registered: ‎06-20-2008
My Device: Not Specified

Re: Duplicate e-mail received with BIS

It is not possible for me to integrate my business account with OWA, athough we are using OWA in our business.

One reason could be explained in the below message from RIM:

http://www.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB04804&sliceId=SAL_Pub...

We are actually using ISA server 2006 and not 2004, but this is a very standard solution, and if RIM does not support it then they should clearly state that BIS is not going to work with business accounts.

Seems like there is no solution to this issue.

I will have to re-consider the BIS solution since ... IT IS NOT WORKING PROPERLY.

I am really angry about this.

Thanks for your support anyway.

Please use plain text.
Forums Veteran I
BBsingh
Posts: 1,546
Registered: ‎04-01-2008
My Device: 8120, Storm, 8200

Re: Duplicate e-mail received with BIS

this might be fixed in BIS2.5 upgrdae which is happening this weekend, so on Monday to integrate OWA. also if the UID's are changing its you rmail server problem, not BIS. UID should not change based on industry standards.
*****************************************************************************
Click on KUDOS to appreciate our efforts and mark the thread RESOLVED if your issue is resolved.
Please use plain text.
New Member
metoor30
Posts: 1
Registered: ‎06-25-2008
My Device: Not Specified

Re: Duplicate e-mail received with BIS

I have this same problem.  I am in charge of the email here and we are using a hosted exchange 2007 solution.  We just moved to 2007 from 2003.  Is this a problem with exchange 2007?
Please use plain text.
New Contributor
giacorne
Posts: 7
Registered: ‎06-20-2008
My Device: Not Specified

Re: Duplicate e-mail received with BIS

I have made parallel escalation with RIM and they admitted that there is no solution to this problem.

It is for sure related to Exchange Server 2007 and (they say) to the ISA server configuration. But since both behave properly (seen from their side) it is the BIS (as a third party application) which is not able to act correctly.

I personally think that Exchange behaves properly in changing UID's to messages when they are modified, but BIS is (obviously) not able to discriminate between new mails and mails whose UID has been changed. 

Their only solution is to install BES.

Hope they will aknowledge a good discount ...

 

Please use plain text.