Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Device software

Reply
New Contributor
aaronmakkc
Posts: 6
Registered: ‎11-18-2009
My Device: Not Specified

New Bold 9700 not connected to BB Internest service

Hi, I just bought my first blackberry and its the new bold.

 

I was very excited at first, but soon turned sour when I have encountered so many setup problems and found out its not as easy to use as I first expected.

 

Anyhow, my first problem is, when I turned on my Blackberry for the first time, I ran through the setup wizard, and when I click on the "Email Setup", it only had 1 option of "I want to use a work email account with a Blackberry Enterprise server", but according to the instruction manual, there should  be another option of "I want to create or add an email address", that wasnt there on my phone. As I have no business enterprise server, I could not registered.

 

Another problem is after I talked to my sister who also started using BB awhile ago, she said that on the right top corner of the home screen, there should be indicators of WIFI, 3G, EDGE etc. But I just have WIFI and 3G on the top right hand corner. And when I check the "Service Status" in "Manage Connections", I found out that I am not connected to Blackberry internet service.

 

I did some research on the web, and did the "Options" -> Advanced Options -> Host Routing Table -> Register now: and got a message saying "registration message sent!"  but with no effects whatsoever.

 

I also did battery pull couple of times to no avail.

 

I bought the phone from www.unlocked-mobiles.co.uk, and my contract is with T-mobile in UK with Unlimited internet and email. However, I could, for some reason that even the T-mobile staff couldnt explain, have access to the internet on my phone even without registering on the T-mobile blackberry account nor being connected to BIS.

 

The T-mobile staff  wasnt too helpful, and said there was a problem with the phone. And said that I need to pay an additional 5 pounds to have access to the T-mobile Blackberry email service, despite the fact that it says unlimited email and internet on the price plan.

 

Anyhow, the main problem for now is the BIS problem and only 1 option to choose the BB Enterprise Server on the email setup screen.

 

Any...ANY help would be greatly appreciated!

Aaron

Please use plain text.
Hall of Famer II
sdgardne
Posts: 47,208
Registered: ‎11-28-2008
My Device: Z30, Z10 & Q10 (10.2.1.3247), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: New Bold 9700 not connected to BB Internest service

Hi and Welcome to the Forums!

 

First off - thank you for the excellent report! Can you stick around and help others? Please? :smileytongue: :smileytongue:

 

The root issue is your service plan from your carrier. There are Data Plans and then there are Blackberry Data Plans...they go by different names with different carriers, but basically generic data plans do not provide you access to the BIS infrastructure. And it's the BIS infrastructure that provides you access to web browsing, email, etc. And the BIS infrastructure is controlled by your carrier. You already have seen both critical symptoms about not being connected to BIS -- the fact that you only saw Enterprise for email and that the Manage Connections status said not connected to BIS. To use the full features of the BB, you must connect to BIS...and most carriers do charge extra to have access to that. They control their BIS infrastructure...and set the pricing for their customers to be able to use it.

 

Good luck and let us know!


Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Please use plain text.
New Contributor
aaronmakkc
Posts: 6
Registered: ‎11-18-2009
My Device: Not Specified

Re: New Bold 9700 not connected to BB Internest service

Hmmm....thanks for the information. So I tried to register myself onto the T-mobile Blackberry Internet Service website for the UK T-mobile network on:

 

http://www.instantemail.t-mobile.co.uk/

 

Agreed with their terms and conditions, and on came a screen which told me to put my DEVICE PIN number and DEVICE IMEI in order to continue.

 

I got both from the "Status" category in "Options" and when I pressed "continue" this message came out:

___________________________________________________________________________________________

Cannot create account:

This BlackBerry(R) device is not registered with your wireless service provider.
Please register this device and verify that the URL of the current web site matches
the one provided by your wireless service provider.

To register:

1. In the Application list on your device, click Options, or click Settings Options.

2. Click Advanced Options > Host Routing Table.

3. Click the Menu key and click Register Now.

If the error persists, contact your wireless service provider.

_____________________________________________________________________________________

 

As stated in my first post, I have already done this numerous times with no noticeable effect.

 

What is the next stop that I have to do to continue with the registration process?

 

Thanks for the help!

Aaron

 

 

Please use plain text.
Hall of Famer II
sdgardne
Posts: 47,208
Registered: ‎11-28-2008
My Device: Z30, Z10 & Q10 (10.2.1.3247), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: New Bold 9700 not connected to BB Internest service

Next stop is calling them for direct assistance...it seems that their automated tools cannot do what is needed, whatever that is for their network.


Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Please use plain text.
New Contributor
aaronmakkc
Posts: 6
Registered: ‎11-18-2009
My Device: Not Specified

Re: New Bold 9700 not connected to BB Internest service

 

 

Thanks for the advices!

 

I phoned up T-mobile and paid the 5 pounds/ month and sorted the problem out.

 

However, everything seems to be working fine apart from this BIG problem.

 

My email is not receiving nor sending any email: (Its a Gmail account)

 

I have gone through the email set-up in the setup wizard with no problems; to check it further, I also went to my account in the T-mobile BIS and double checked that the email and setup is correct, but still cant receive nor send emails.

 

When I press the icon of my email account in the home screen, all that appears is "*No Messages*".

I can compose an email, and press send and it would appear that I have sent the email, but in fact no mails were sent.

 

This is really the final problem for me.

 

Any help is appreciated!

Aaron

 

Please use plain text.
Hall of Famer II
sdgardne
Posts: 47,208
Registered: ‎11-28-2008
My Device: Z30, Z10 & Q10 (10.2.1.3247), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: New Bold 9700 not connected to BB Internest service

Hmmm...well, I suggest the following steps (in order, test again after each step):

 

1) Register HRT


  • Homescreen > Options > Advanced Options > Host Routing Table > BBKey (it does not matter which line is current) > Register Now

2) Resend Service Books


  • KB02830 Send the service books for the BlackBerry Internet Service

3) Batt Pull Reboot


  • Anytime random strange behavior or sluggishness creeps in, the first thing to do is a battery pop reboot. With power ON, remove the back cover and pull out the battery. Wait about a minute then replace the battery and cover. Power up and wait patiently through the long reboot -- ~5 minutes. See if things have returned to good operation. Like all computing devices, BB's suffer from memory leaks and such...with a hard reboot being the best cure.

 

4) Completely delete and re-create the BIS conduit for that account. Wait an hour between deleting and recreating.

 

 


Hopefully that will get things going again for you!

 


Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Please use plain text.
New Contributor
aaronmakkc
Posts: 6
Registered: ‎11-18-2009
My Device: Not Specified

Re: New Bold 9700 not connected to BB Internest service

Hi again,

 

Thank you very much for your help and patience so far.

 

I have done the above steps and even the last one of deleting the the account and setting it up again.

 

During the re-setup of my email settings, I found that there seemed to be no problem whatsoever.

 

And after the set-up, I found out that I can send out emails with my bb, but when I press the email icon, it still says no "*No Messages*" and unable to receive any emails.

 

Another thing I found out is that in the "Service Book" category in "Advanced Options", there are 3 emails of my same email address:

 

xxxxx@gmail.com [SYNC]

xxxxx@gmail.com [CICAL]

xxxxx@gmail.com [CMIME]

 

and of all the applications, only the email with the [CMIME] ending had a lock icon beside it.

 

Is this related to this issue in any sense?

 

Please use plain text.
Hall of Famer II
sdgardne
Posts: 47,208
Registered: ‎11-28-2008
My Device: Z30, Z10 & Q10 (10.2.1.3247), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: New Bold 9700 not connected to BB Internest service

Hi again,

 

Here is a KB that describes the various Service Books and what they are for:

 

I'm not sure what it means if one of the SB's have a lock by them...I can't find any documentation about that. But you are welcome to search the KB's with search criteria that might be better than I am using:

 

 


aaronmakkc wrote:

And after the set-up, I found out that I can send out emails with my bb, but when I press the email icon, it still says no "*No Messages*" and unable to receive any emails.

 


 

 

Can you expand on that a little? Especially the last part? How, exactly, did you determine that you are unable to receive any emails?

 

As for "No Messages", BIS does not bring history, so upon first activation the only emails that would be on the BB would be new emails starting after activation. And you would not receive messages for about 15 or so minutes from activation, but again those would only be new emails that arrive after activation. No history.

 

 


 

I have a separate suspicion...can you check if you have an IT Policy on your BB? On mine, the screen is:

  • Homescreen > Options > Security Options > Information

On other OS levels, I think it's somewhere else, but definitely inside of Security Options (it might be called General Settings or something similar). You are looking for a screen that has multiple sections, separated by horizontal lines. The top section will be some selection boxes. The middle section would be the IT Policy. And the third section would be Services. If there is a section that says IT Policy (often using "Default" as the policy name), then you have an IT Policy on your BB that may well be latent from some prior usage in a BES environment. If there is an IT Policy, it could be interfering with your BIS configuration.

 

Let us know!


Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Please use plain text.
New Contributor
aaronmakkc
Posts: 6
Registered: ‎11-18-2009
My Device: Not Specified

Re: New Bold 9700 not connected to BB Internest service

Just to update on the latest info;

 

I called up the t-mobile technical support and the staff guided me through the whole set-up process again like you described earlier, and as usual, it didnt work. So the staff escalated the issue and told me he will call back later.

 

He didnt, so after a few days I went to the T-mobile store to seek help personally, and a more advanced staff guided me through different process;

 

First he told me to go to Options -> Security Options -> General Settings;

but for some odd reason, my phone does not have General Settings in the Security Options category.

 

So he told me to go to service books and delete every single service book deletable. He said in the end, only "Provisioning" should be undeletable, and as mine turned out, one of my email's service book with [CMIME] and a lock icon beside it was also undeletable.

 

I went into that service book and in the description, it says "This service record cannot be deleted due to your Firewall settings. Contact your wireless service provider for more information".

 

I then went to the Firewall settings and disabled it...didnt help.

 

So the last options was to completely reboot the Blackberry. He guided me to a reboot option which for some odd reasons again, my phone didnt have. (I forgot the specifics)

 

So he told me another option which is to enable password and turn off the blackberry and type a wrong password for 10X. I typed in the wrong password for at least 50X but it still says "Invalid Password" and let me to try continuously.

 

In the end, the staff said that this is the first time he has encountered this type of problem, and requested me to send in the phone for them to fix.

 

I am really disappointed that after all the things I did, the phone still wouldnt be fixed. From the looks of it, this sound like such a serious issue with this blackberry that I am starting to worry if it can be fixed, if not my blackberry would just be another ordinary phone that only do phone calls, take pictures and receive txts.

 

If there are any update, I will try to post it up.

Please use plain text.
New Contributor
aaronmakkc
Posts: 6
Registered: ‎11-18-2009
My Device: Not Specified

Re: New Bold 9700 not connected to BB Internest service

hey guys,

 

this will be my last post because I have found the solution and it was ridiculously simple.

 

Problem was email application was firewalled, hence undeletable in the service book and the reason for the lock icon beside my email service book. I went to the Firewall in security options, saw that the blackberry internet service was firewalled, I unticked it, and I was receiving mails ever after!!!

 

Now theres no major problem with my blackberry and I am starting to like it a lot, I probably wont love it because I prefer something more fun to play with. But heck I like it A LOT!!!

 

Anyhow, Thank you very much sdgarne!

Please use plain text.