Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Device software

Reply
New Member
gaiovskji13
Posts: 1
Registered: ‎11-28-2010
My Device: Curve 8520
My Carrier: Wind Italy

Unable to connect to the internet 8520

I am using BB Curve8520. Since radio signal has been turned off automatically because I was running out of battery the internet connection doesnìt work properly, trying to brose showing "Unable to connect to the internet please try again later. I this problem persists please contact your provider" actually i can use bb messenger and i am receiving my email...but I can't access internet through any application, even whatsapp messenger and facebook...I've got a blackberry service plan, i tried to connect with my house wifi and it was the same...and I've done hard reset twice...

Any one knows this problem please reply to me

Please use plain text.
Guru I
John_Clark
Posts: 15,165
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.3.0.1052; PlayBook w/OS 2.1.0.1917
My Carrier: at&t

Re: Unable to connect to the internet 8520

Charge the battery and then turn on all the connections and try again.

--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Please use plain text.
New Contributor
russellb99
Posts: 2
Registered: ‎11-28-2010
My Device: Blackberry Bold 9700
My Carrier: O2 - UK

Re: Unable to connect to the internet 8520

If you don't mind me saying, that is a rather poor and pointless piece of advice although we realise you are just trying to help. I have the same problem which has only started today, i.e. no internet access over BIS.

 

I have Opera Mini already downloaded onto my Bold 9700 and although I get web pages on Opera over Wi-Fi,  the native Blackberry browser does not load any pages, it just sits there until it times out. If I turn Wi-Fi off, there is no internet access at all from either browser.

 

I am on O2 in UK, and with the native browser I can access the O2-Active wap pages but that is all, i.e. these pages are accessed directly from the carrier, not via BIS. So that means that BIS is currently down, however the real problem is there is no support or information for those affected.

 

Anyone going to reply with: 'try contacting your service provider?' :manmad:

Please use plain text.
Guru I
John_Clark
Posts: 15,165
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.3.0.1052; PlayBook w/OS 2.1.0.1917
My Carrier: at&t

Re: Unable to connect to the internet 8520

Well, if you don't mind my saying that was a rather poor question.  You said your battery was dying so you turned off the radio. 

 

If you already know the answer, "try contacting your service provider" then why did you come to this forum to ask the question? 

 

It's obviously not a global issue since others' devices are working just fine. 

 

Did you try removing the battery to reboot the device?

--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Please use plain text.
New Contributor
russellb99
Posts: 2
Registered: ‎11-28-2010
My Device: Blackberry Bold 9700
My Carrier: O2 - UK

Re: Unable to connect to the internet 8520

It was a global issue and it's fine now,all working well and yet i've done nothing so it is not the device or anyone else's.

 

The problem is, when there are BIS outages like this, no-one in authority seems to know or care if it occurs or for how long or why!  There seems to be no BIS service status info that can be found anywhere which would show if there are any future planned maintenence outages.

 

The point I was making is that if you simply contact your service provider they are most likely to ask  questions that belittle the intelligence of most, such as 'have you tried rebooting the device?' and 'have you made sure the battery is fully charged?' etc. I would like to think that most blackberry users would be intelligent enough to think beyond that stage!

 

 

Please use plain text.
Guru I
John_Clark
Posts: 15,165
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.3.0.1052; PlayBook w/OS 2.1.0.1917
My Carrier: at&t

Re: Unable to connect to the internet 8520

Then why didn't you just post as such?  Were you just testing us?

 

No, many BB users are not that tech-savy.  I can't tell you how many times I post "remove the battery to reboot your device" and then get a reply a little later saying "thanks!  That worked!"  So, the fact that you got that from the support from your carrier is not surprising.

 

RIM, nor the carriers do not publicly announce their outages. 

--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Please use plain text.
New Member
monk21
Posts: 1
Registered: ‎07-27-2012
My Device: 8520 curve
My Carrier: Masser Merchandise & Accesories

Re: Unable to connect to the internet 8520

i have the same problem. whenever i go to the web browser there is always a pop up message saying unable to connect to internet. but i have a connection to my wifi. what do you think is the problem?

Please use plain text.
Visitor
Durai
Posts: 1
Registered: ‎07-25-2012
My Device: Curve 8520
My Carrier: Airtel

Re: Unable to connect to the internet 8520

I had the same Problem of "  Unable to connect to the internet 8520 "  - All other data service / email is working well.

Called service provider help desk - they gave me suggestion - to set the browser default as " Internet browser " - clear all catch memory - " Turn off all connection " - wait for ten seconds " restore the connection - I should be allright ":

 

But it didnt resolved !

 

As per the clu John_Clark - I have removed the battery and allowed the BB to reboot , it brought back everything as usual / great !..

 

Thanks !

Durai Anandan R
Please use plain text.