Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Device software

Reply
New Member
dotS
Posts: 1
Registered: ‎08-19-2008
My Device: Not Specified

gmail and blackberry... it's not working!

Hi there,

Can someone please tell me how to connect my gmail account to my blackberry curve. And yes, I have done all this:

  1. Enable IMAP in your Gmail settings.
  2. From your BlackBerry home screen, select the BlackBerry Set-up icon, then choose Personal Email Set-up. (On older devices, just look for the Personal Email Set-up icon.)
  3. Select Personal Email Set-up.
  4. Accept Terms and Conditions.
  5. On the 'Email Account Set-up' page, enter your full email address (including '@gmail.com' or '@your_domain.com') but leave the 'Password:' field blank. Select Next.
  6. You'll see a screen that says 'We were unable to configure [username@gmail.com].' Select I will provide the settings to add this email account, then Next.
  7. Select Internet Service Provider Email (POP/IMAP), then Next.
  8. Select I will provide the settings to add this email account, then Next.
  9. You'll see 'The BlackBerry Internet Service could not configure [username@gmail.com] email account.' Select Provide The Settings to continue.
  10. In the 'User name:' field, enter your full email address (including '@gmail.com'). Google Apps users, please enter your full email address at your domain. Then enter your password in the 'Password:' field.
  11. In the 'Email server:' field, enter 'imap.gmail.com,' then select Next. Google Apps users should enter the server name provided; don't add your domain name in this step.
  12. If IMAP access was successfully configured, select OK.
  13. Below your newly added Gmail address, select Edit.
  14. Select Advanced Settings at the bottom.
  15. Make sure the port is set to '993' and 'Use SSL' is set to 'Yes.'
  16. Select Save.
However! Whenever I get to step 12 I press okay and get the message 'An error according during email account validation. Please check your information and try again.' I've checked the information numerous times and it's all fine.

The funny thing is I have two gmail accounts and one of them connects very easily (I don't even need to go into the 'I will provide my own settings' bit. However, the other gmail just won't connect. (IMAP and POP and both enabled). I recently changed the password on this account... could that relate to the problem?

Please help, I'm so frustrated.

Thanks,
DotS
Forums Veteran I
BBsingh
Posts: 1,546
Registered: ‎04-01-2008
My Device: 8120, Storm, 8200

Re: gmail and blackberry... it's not working!

chk this link: http://supportforums.blackberry.com/rim/board/message?board.id=BlackBerryInternetSolution&message.id...

 

*****************************************************************************
Click on KUDOS to appreciate our efforts and mark the thread RESOLVED if your issue is resolved.
Contributor
ScRaSh
Posts: 45
Registered: ‎04-17-2008
My Device: 8520

Re: gmail and blackberry... it's not working!

Maybe your account is blocked, you need to go to https://www.google.com/accounts/DisplayUnlockCaptcha and unlock the account. Then try again.
New Member
sandeshraut
Posts: 1
Registered: ‎05-08-2012
My Device: 9220

Re: gmail and blackberry... it's not working!

[ Edited ]

:Angel: Hello,

 

I got solution

 

Log into the Google Mail account and go into Options and then Mail Settings.  Under the Labels tab enable the All Mail, Sent Mail, and Trash labels to show and to Show in IMAP.  Also, while in Mail Settings, under the Forwarding & POP/IMAP tab enable IMAP & POP then be sure to select Save Changes at bottom.

 

Sandesh (Sandy)

New Developer
tadwoods
Posts: 8
Registered: ‎01-01-2009
My Device: Not Specified

Re: gmail and blackberry... it's not working!

Thank you! Thank you! Thank you!

 

After a failed software update on my Blackberry 9930 I had to reload the device software from scratch. In the process Gmail stopped working --- I kept getting messages from BIS telling me to enable IMAP in my Gmail account, but IMAP was enabled and had been for years!! I spent hours trying to fix this including an hour on the phone with Blackberry support without a resolution. The problem was that All Mail and Trash labels had been (at some point in the past) unchecked for Show in IMAP. Not sure why this worked for years and suddenly stopped, but checking them fixed it.