Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Device software

Reply
Visitor
nevertwell
Posts: 1
Registered: ‎12-19-2012
My Device: BlackBerry Bold 9790
My Carrier: Wind Mobile

"Unable to connect using the current security settings" when accessing https site

TLDR:

 

HTTPS version of the site I'm testing works fine when connected to Wi-Fi but gives the error message "Unable to connect using the current secuirty settings. Please contact your service provider" when attempting to view the exact same site with Wi-Fi turned off (i.e. connected via my cell service provider). This happens across Bell & Wind BlackBerry phones connected via BIS.

 

Explanation:

I'm a developer and I've been trying and trying to get this to work for days. I'm hosting my application on the Google App Engine and have enabled SSL for it. I've installed and configured the necessary certificate files to ensure that the site runs securely across all major browsers and devices. The only combination that doesn't work is BlackBerry phones connected to the internet via the service provider (i.e. not through Wi-Fi).

 

I posted this question under "Device Software For BlackBerry" because this is not a dev question but more of an end-user question. 

 

Question:

 

My question is, what are the causes of the "Unable to connect ..." error stated above? If the SSL certificate works fine on the phone while connected via Wi-Fi why does it not work while connected via my cell service provider?

Test Phones:

BlackBerry Bold 9790 on WindMobile and BlackBerry Bold 9900 on Rogers both running OS7

Please use plain text.
Guru I
Xandrex
Posts: 18,377
Registered: ‎07-29-2008
My Device: Z10 10.1.0.2312 / Playbook 2.1 / 8900 5.0
My Carrier: Vodafone France (SFR) & B&You

Re: "Unable to connect using the current security settings" when accessing https site

when you go through your carrier provider, there is an additional step in the SSL tunnel. Not sure how this transcribes, but it is possible that your carrier does not use the same port as the one you want it to use.



The search box on top-right of this page is your true friend, and the public Knowledge Base too:
Please use plain text.
New Member
BBTZ
Posts: 1
Registered: ‎05-14-2013
My Device: blackberry torch
My Carrier: three

Re: "Unable to connect using the current security settings" when accessing https site

Please find the solution below (If you have a blackberry phone)

- click on options
-then select security settings
- scroll down and select advanced security settings
- then select TLS
- Make sure both 'permit SSL' and 'Permit unsecure renegotiation' are selected

- that should solve the problem

NB: once you' have finished with the website, go back and un-select 'permit unsecure renegotiation'

Please use plain text.