Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
Contributor
Posts: 23
Registered: ‎07-21-2014
My Device: DONT OWN

Re: BES 5.4 failed to install with MAPI to RPC/HTTP for Microsoft Exchange Server 2013

When I run IEMSTest.exe it fails with the same error/issue (which is the issue I am trying to voercome). I cannot create a MAPI profile as it will never resolve the name properly. It finds the user mailbox and resolves the Exchange server NP but as soon as I click OK, it sends the error that the name cannot be resolved. SO I am in a catch-22 issue here and cannot proceed.

Contributor
Posts: 23
Registered: ‎07-21-2014
My Device: DONT OWN

Re: BES 5.4 failed to install with MAPI to RPC/HTTP for Microsoft Exchange Server 2013

And all permissions are assigned properly, following the HOWTO docs from BES. I am able to load OWA from the BES server with no issues and I can add the mailbox with NP in Outlook from my workstation.

Guru III
Posts: 31,128
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: BES 5.4 failed to install with MAPI to RPC/HTTP for Microsoft Exchange Server 2013


GROOVYJOSHCLARK1975 wrote:

When I run IEMSTest.exe it fails with the same error/issue (which is the issue I am trying to voercome). I cannot create a MAPI profile as it will never resolve the name properly. It finds the user mailbox and resolves the Exchange server NP but as soon as I click OK, it sends the error that the name cannot be resolved. SO I am in a catch-22 issue here and cannot proceed.


and what would that error be exactly?

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V


Contributor
Posts: 23
Registered: ‎07-21-2014
My Device: DONT OWN

Re: BES 5.4 failed to install with MAPI to RPC/HTTP for Microsoft Exchange Server 2013

I either get "an unexpected error occured" or "the name cannot be resolved" (which it is and does but then it says network communication is preventing connection.

 

Here is the actual error log with company, exchange server and domain names replaced with example names (OU's were left):

 

LDAPSearch succeeds with ldap_search_s, search base [CN=EXCHANGESEREVER,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=companyname Technologies,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=companyname,DC=net] filter [(distinguishedName=CN=EXCHANGESEREVER,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=companyname Technologies,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=companyname,DC=net)]
SimpleLDAPSearch2 returned count of 1
LDAPSearch found attribute [serialNumber]=[Version 15.0 (Build 30847.32)]
EndLDAPSession successfully ends an LDAP session
CExchangeServer::GetExtendedInformation received unexpected version [Version 15.0 (Build 30847.32)] for Exchange server [EXCHANGESEREVER]
CExchangeServer::GetExtendedInformation result is [1] - Name:EXCHANGESEREVER,Version:0/0(Version 15.0 (Build 30847.32)),ADFor[example.com],GC[Name[ihdcsrv101.example.com] Addr[10.150.150.71] Domain[example.com] Forest[example.com] Site[companyname-Equinix] SB[DC=companyname,DC=net] PDC=1 GC=1 IsValid=1 NatRetCode=0 LDAPRetCode=0 ET=15 ],DN[CN=EXCHANGESEREVER,CN=Servers,CN=E...],EC[CN=...],Org[CN=companyname Technologies,CN=M...],AG[CN=Exchange Administrative Gro...],Loaded[1]
CMAPICon::ValidatePub begins - MAPI[BlackBerryServer/BESAdmin@example.com/EXCHANGESEREVER], ExchSvr[Name:EXCHANGESEREVER,Version:0/0(Version 15.0 (Build 30847.32)),ADFor[example.com],GC[Name[ihdcsrv101.example.com] Addr[10.150.150.71] Domain[example.com] Forest[example.com] Site[companyname-Equinix] SB[DC=companyname,DC=net] PDC=1 GC=1 IsValid=1 NatRetCode=0 LDAPRetCode=0 ET=15 ],DN[CN=EXCHANGESEREVER,CN=Servers,CN=E...],EC[CN=...],Org[CN=companyname Technologies,CN=M...],AG[CN=Exchange Administrative Gro...],Loaded[1]], UN[besadmin]UD[companyname], CES[1],
CMAPICon::EditMapiProfile (no UI) sent [BlackBerryServer/EXCHANGESEREVER/BESAdmin@example.com] and return code was [0x80040115]
CMAPICon::EditMapiProfile result for profile[BlackBerryServer]/user[BESAdmin@example.com]/server[EXCHANGESEREVER] was [23]
CMAPICon::ValidatePub validation result is [23], IsValidated=[0] - MAPI[BlackBerryServer/BESAdmin@example.com/EXCHANGESEREVER], ExchSvr[Name:EXCHANGESEREVER,Version:0/0(Version 15.0 (Build 30847.32)),ADFor[example.com],GC[Name[ihdcsrv101.example.com] Addr[10.150.150.71] Domain[example.com] Forest[example.com] Site[companyname-Equinix] SB[DC=companyname,DC=net] PDC=1 GC=1 IsValid=1 NatRetCode=0 LDAPRetCode=0 ET=15 ],DN[CN=EXCHANGESEREVER,CN=Servers,CN=E...],EC[CN=...],Org[CN=companyname Technologies,CN=M...],AG[CN=Exchange Administrative Gro...],Loaded[1]], UN[besadmin]UD[companyname], CES[1],

Contributor
Posts: 23
Registered: ‎07-21-2014
My Device: DONT OWN

Re: BES 5.4 failed to install with MAPI to RPC/HTTP for Microsoft Exchange Server 2013

One more thing to add is when I try to manually use IEMST.exe to create a profile for Exchange 2013, it errors with the following: "The .DLL file for this service is either damaged or could not be found.". Could this be an issue causing the backend error?

 

Is this normal or is this unique to my installation?

Guru III
Posts: 31,128
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: BES 5.4 failed to install with MAPI to RPC/HTTP for Microsoft Exchange Server 2013

this thread has some info in it, it might help

http://supportforums.blackberry.com/t5/BlackBerry-Enterprise-Server-5-x/New-installation-of-BES-5-0-...

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V


Contributor
Posts: 23
Registered: ‎07-21-2014
My Device: DONT OWN

Re: BES 5.4 failed to install with MAPI to RPC/HTTP for Microsoft Exchange Server 2013

Thanks, I went through all 4 pages and nothing was there that I havent already tried or fixed. What I did do was to force an upgrade by cancelling the install and then hacking the regkey "ConfigFirstRun" setting it to "0". So now at least I am on the latest SP and BES version (5.0.4 bundle0183).

 

I can at least start the services, all except the most important one which is the BES server. It is still failing on edit MAPI profile. When I try to locate the mailbox, it is still throwing the error "name cannot be resolved".

 

 

Guru III
Posts: 31,128
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: BES 5.4 failed to install with MAPI to RPC/HTTP for Microsoft Exchange Server 2013

Contributor
Posts: 23
Registered: ‎07-21-2014
My Device: DONT OWN

Re: BES 5.4 failed to install with MAPI to RPC/HTTP for Microsoft Exchange Server 2013

Thanks for the link but I already ran through that checklist before my initial posting and everything is already met or fixed.

Contributor
Posts: 23
Registered: ‎07-21-2014
My Device: DONT OWN

Re: BES 5.4 failed to install with MAPI to RPC/HTTP for Microsoft Exchange Server 2013

OK, so I finally got it working, it was a combination of NTLM2 with the full Exchange GUID. Thanks for everyones help! This was the longest and most difficult installation of any BES product I have ever dealt with. :Eek: