Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
Contributor
jikuma
Posts: 14
Registered: ‎03-08-2010
My Device: 8830
My Carrier: Tata Indicom

Blackberry Enterprise Server Dispatcher gets disconnected with Remote Router multiple times in single day

Dear All,

 

I am posting this message on behalf of my client.

 

We are facing an ackward issue.

 

We have BES 5.0.3 with Exchange 2010 Environment.

 

BES Router is installed on Remote machine and is placed in DMZ.

 

BES Server and Exchange server are in local LAN.

 

We are getting of BES dispatcher getting disconnect from last few days.

There has been no changes made on network or BES Configuration.

 

Kindly help in finding the root cause of the issue.

 

server01.XXXX.com:3101" @ [10.47.25.67] is my remote router machine.

 

I had kept whole day ping from BES system to Router system no drop was observed but dispatcher connection error still drops.

 

Telnet to SRP address on 3101 from BES machine and Router machine is also successful.

 

 

BB Dispatcher logs line is pasted below.

[40000] (03/17 11:41:00.561):{0x236C} [SRP:smileyfrustrated:XXXXXXX] CONFIG received
[40000] (03/17 11:41:00.561):{0x236C} [SRP:smileyfrustrated:XXXXXXX] CONFIG: BBR Relay Update.
[50097] (03/17 11:41:00.561):{0x236C} [SRP] Dispatcher\SRP Connection dropped, Error=0, Reason=-7 Router disconnected
[30490] (03/17 11:41:00.561):{0x236C} Health score: Health=0x000000073310150F
[40923] (03/17 11:41:00.561):{0x236C} [SRP] BBR Relay Connection Down.  Operating in wifi\bypass only mode until relay connection can be re-established
[40333] (03/17 11:41:10.626):{0xBD0} [BIPPe] (agent_sync,3) Received PING (6276)
[40335] (03/17 11:41:10.626):{0xBD0} [BIPPe] (agent_sync,3) Send PING_RESPONSE (6276)
[30450] (03/17 11:41:13.099):{0x1BA8} {Nitin Patil} User unchanged (disp): id=32, email=XXXX@XXXXX.com, device=12345678, routing=SXXXXXXXX, agent=001, time=4E9BEB4A, ext=1, wl=0, keys=(A:A:0)
[30450] (03/17 11:41:16.167):{0x1BB4} {XXXXXX} User unchanged (disp): id=30, email=XXXXXX@XXXXXX.com, device=12345678, routing=SXXXXXXXX, agent=001, time=4E8EB7AE, ext=1, wl=0, keys=(0:A:0)
[30498] (03/17 11:41:22.114):{0x10D4} SRPConnectTest: Test connection to Relay was successful
[30000] (03/17 11:41:22.114):{0x10D4} [SRP] Dropping connection to router to allow another router to connect
[40000] (03/17 11:41:22.115):{0x1B8C} [SRP] SRPClientReceiver thread stopped
[30000] (03/17 11:41:22.115):{0x1B8C} [DIAG] EVENT=Unregister_thread, THREADID=0x1B8C, THREADNAME="SRPClientReceiver"
[30000] (03/17 11:41:22.126):{0x2058} [SRP:smileyfrustrated:XXXXXXXX] Connection lost
[40000] (03/17 11:41:22.126):{0x2058} [SRP] Connecting to "server01.XXXX.com:3101"
[40000] (03/17 11:41:22.126):{0x2058} [SRP] SRPClient::Connect: Found 1 addresses for host "server01.XXXX.com:3101"
[40000] (03/17 11:41:22.126):{0x2058} [SRP] SRPClient::Connect: Host "server01.XXXX.com:3101" @ [10.47.25.67]
[40000] (03/17 11:41:22.127):{0x2058} [SRP] SRPClient::Connect: Trying "server01.XXXX.com:3101" @ [10.37.25.67]
[40000] (03/17 11:41:22.129):{0x2058} [SRP] EVENT=Send_CONNECT_UID_CLAIM, VERSION=1, UID=SXXXXXXXX, REQUEST_VERSION=3, FLAG=0
[40000] (03/17 11:41:32.820):{0xBD0} [BIPP] EVENT=Receive_INFO, VERSION=1, SIZE=41
[40355] (03/17 11:41:32.820):{0xBD0} [BIPPe] (IPPP,4) Received INFO
[30490] (03/17 11:41:32.820):{0x10D4} Health score: Health=0x000000073310150F
[40333] (03/17 11:41:38.471):{0xBD0} [BIPPe] (ITADMIN,1) Received PING (6649)
[40335] (03/17 11:41:38.471):{0xBD0} [BIPPe] (ITADMIN,1) Send PING_RESPONSE (6649)
[40333] (03/17 11:41:46.348):{0x227C} [BIPPa] (001,1) Received PING (2357)
[40335] (03/17 11:41:46.348):{0x227C} [BIPPa] (001,1) Send PING_RESPONSE (2357)
[40000] (03/17 11:41:48.227):{0x2058} [SRP] EVENT=Receive_CONNECT_CHALLENGE, VERSION=1, CHALLENGE=004559E8-00020000-B80F9EC3-15512824+1129944593+1363500715

 

 

Please use plain text.
Regular Contributor
orangekeeper
Posts: 50
Registered: ‎08-02-2010
My Device: z10
My Carrier: TMUK

Re: Blackberry Enterprise Server Dispatcher gets disconnected with Remote Router multiple times in single day

Hi there,

 

This might be a tough one and short of having anything reasonably constructive to add at the moment, I'd suggest having a look at the remote router logs. Do you see any router errors that correspond to the times when the Dispatcher dropped? At least you'll be able to determine whether the Router itself is OK.

 

If so, then what sits between the dispatcher and router? Could any of these components be contributing to the problem (I.e. Firewalls dropping packets/routing issues etc).

 

Sorry I can't be more specific...

Please use plain text.
Contributor
jikuma
Posts: 14
Registered: ‎03-08-2010
My Device: 8830
My Carrier: Tata Indicom

Re: Blackberry Enterprise Server Dispatcher gets disconnected with Remote Router multiple times in single day

Dear All,

 

Kindly find the remote Router logs as follows.

 

[30000] (04/03 05:46:20.686):{0x568} [SERVICE_RELAY_SESSION:UNKNOWN:0x00A13A68] Accept service session. IP=10.16.18.96, ServiceSession=0x009B1AF0
[30000] (04/03 05:46:20.686):{0xAFC} [DIAG] EVENT=Register_thread, THREADID=0xAFC, THREADNAME="Unnamed"
[30000] (04/03 05:46:20.686):{0xAFC} [RELAY_SRP:UNKNOWN:0x00A179A0] Connecting to relay at address "srp.eu.blackberry.net"
[30000] (04/03 05:46:20.811):{0xAFC} [RELAY_SRP:UNKNOWN:0x00A179A0] Connect: Found 2 addresses for host "srp.eu.blackberry.net"
[30000] (04/03 05:46:20.811):{0xAFC} [RELAY_SRP:UNKNOWN:0x00A179A0] Connect: Host "srp.eu.blackberry.net" @ [93.186.25.33]
[30000] (04/03 05:46:20.811):{0xAFC} [RELAY_SRP:UNKNOWN:0x00A179A0] Connect: Host "srp.eu.blackberry.net" @ [193.109.81.33]
[30000] (04/03 05:46:20.811):{0xAFC} [RELAY_SRP:UNKNOWN:0x00A179A0] Connect: Trying "srp.eu.blackberry.net" @ [93.186.25.33]
[30000] (04/03 05:46:21.139):{0xAFC} [SERVICE_RELAY_SESSION:UNKNOWN:0x00A13A68] Connection to relay established.
[30000] (04/03 05:46:21.139):{0xAFC} [DIAG] EVENT=Unregister_thread, THREADID=0xAFC, THREADNAME="Unnamed"
[30000] (04/03 05:46:21.467):{0x570} [SERVICE_SRP:UNKNOWN:0x009B1AF0] Receive: no data, ERROR=0
[30000] (04/03 05:46:21.467):{0x570} [SERVICE_RELAY_SESSION:UNKNOWN:0x00A13A68] Disconnect session. IP=10.16.18.96
[30000] (04/03 05:46:21.467):{0x570} [SERVICE_SRP:UNKNOWN:0x009B1AF0] disconnect
[30000] (04/03 05:46:21.467):{0x570} [RELAY_SRP:UNKNOWN:0x00A179A0] disconnect
[30000] (04/03 05:46:21.467):{0x570} [SERVICE_MANAGER] Delete session. UID=UNKNOWN, Session=0x00A13A68
[30000] (04/03 05:46:21.467):{0x570} [RELAY_SRP:UNKNOWN:0x00A179A0] Receive: invalid socket
[30000] (04/03 05:46:21.467):{0x570} [SERVICE_SRP:smileyfrustrated:XXXXXXX:0x009B1B80] Receive: no data, ERROR=0
[30000] (04/03 05:46:21.467):{0x570} [SERVICE_RELAY_SESSION:smileyfrustrated:XXXXXXX:0x00A13798] Disconnect session. IP=10.16.187.96
[30000] (04/03 05:46:21.467):{0x570} [SERVICE_SRP:smileyfrustrated:XXXXXXX:0x009B1B80] disconnect
[30000] (04/03 05:46:21.498):{0x568} [SERVICE_MANAGER] Connection established. Session=0x00A13900
[30000] (04/03 05:46:21.498):{0x568} [SERVICE_RELAY_SESSION:UNKNOWN:0x00A13900] Accept service session. IP=10.16.18.96, ServiceSession=0x009B1C10
[30000] (04/03 05:46:21.498):{0x8C8} [DIAG] EVENT=Register_thread, THREADID=0x8C8, THREADNAME="SRPReceiverHandler"
[30000] (04/03 05:46:22.467):{0xF0} [DIAG] EVENT=Unregister_thread, THREADID=0xF0, THREADNAME="SRPReceiverHandler"
[30000] (04/03 05:46:22.482):{0x570} [RELAY_SRP:smileyfrustrated:XXXXXXX:0x00A17F80] disconnect
[30000] (04/03 05:46:22.482):{0xB3C} [DIAG] EVENT=Unregister_thread, THREADID=0xB3C, THREADNAME="Unnamed"
[30000] (04/03 05:46:22.498):{0x570} [SERVICE_MANAGER] Delete session. UID=SXXXXXXX, Session=0x00A13798
[30000] (04/03 05:46:22.498):{0x570} [DEVICE_MANAGER] SRP StopListening. Port 4101.
[30000] (04/03 05:46:22.498):{0xA80} [DIAG] EVENT=Unregister_thread, THREADID=0xA80, THREADNAME="SRPListenerImp"
[30000] (04/03 05:46:22.514):{0x570} [SERVICE_RELAY_SESSION:smileyfrustrated:XXXXXXX:0x00A13900] Service claim UID. UID: SXXXXXXX Requested SRP Version:3, IP=10.16.18.96
[30000] (04/03 05:46:22.514):{0x768} [DIAG] EVENT=Register_thread, THREADID=0x768, THREADNAME="Unnamed"
[30000] (04/03 05:46:22.514):{0x768} [RELAY_SRP:UNKNOWN:0x00A17780] Connecting to relay at address "srp.eu.blackberry.net"
[30000] (04/03 05:46:22.514):{0x768} [RELAY_SRP:UNKNOWN:0x00A17780] Connect: Found 2 addresses for host "srp.eu.blackberry.net"
[30000] (04/03 05:46:22.514):{0x768} [RELAY_SRP:UNKNOWN:0x00A17780] Connect: Host "srp.eu.blackberry.net" @ [93.186.25.33]
[30000] (04/03 05:46:22.514):{0x768} [RELAY_SRP:UNKNOWN:0x00A17780] Connect: Host "srp.eu.blackberry.net" @ [193.109.81.33]
[30000] (04/03 05:46:22.514):{0x768} [RELAY_SRP:UNKNOWN:0x00A17780] Connect: Trying "srp.eu.blackberry.net" @ [93.186.25.33]
[30000] (04/03 05:46:22.810):{0x768} [SERVICE_RELAY_SESSION:smileyfrustrated:XXXXXXX:0x00A13900] Connection to relay established.
[30000] (04/03 05:46:22.810):{0x768} [DIAG] EVENT=Unregister_thread, THREADID=0x768, THREADNAME="Unnamed"
[30000] (04/03 05:46:23.357):{0x570} [SERVICE_SRP:UNKNOWN:0x009B1AF0] disconnect
[30000] (04/03 05:46:23.357):{0x570} [RELAY_SRP:UNKNOWN:0x00A179A0] disconnect
[30000] (04/03 05:46:23.357):{0x570} [SERVICE_SRP:smileyfrustrated:XXXXXXX:0x009B1B80] disconnect
[30000] (04/03 05:46:23.357):{0x570} [RELAY_SRP:smileyfrustrated:XXXXXXX:0x00A17F80] disconnect
[30000] (04/03 05:46:23.732):{0x570} [SERVICE_RELAY_SESSION:smileyfrustrated:XXXXXXX:0x00A13900] Service relay connection authenticated. SRPVersion: 3
[30000] (04/03 05:46:23.732):{0x570} [SERVICE_MANAGER] Session authenticated. UID=SXXXXXXX, Session=0x00A13900
[30000] (04/03 05:46:23.732):{0x570} [DEVICE_MANAGER] SRP StartListening. Port 4101.
[30000] (04/03 05:46:23.732):{0xA8C} [DIAG] EVENT=Register_thread, THREADID=0xA8C, THREADNAME="SRPListenerImp"
[10000] (04/03 06:16:13.709):{0x570} [SERVICE_RELAY_SESSION:smileyfrustrated:XXXXXXX:0x00A13900] Relay Ping Response not received
[30000] (04/03 06:16:26.068):{0x570} [RELAY_SRP:smileyfrustrated:XXXXXXX:0x00A17780] Receive: ERROR=10054
[30000] (04/03 06:16:26.068):{0x570} [SERVICE_RELAY_SESSION:smileyfrustrated:XXXXXXX:0x00A13900] Disconnect relay session. IP=10.16.18.96
[30000] (04/03 06:16:26.068):{0x570} [RELAY_SRP:smileyfrustrated:XXXXXXX:0x00A17780] disconnect
[30000] (04/03 06:16:26.068):{0x570} [SERVICE_RELAY_SESSION:smileyfrustrated:XXXXXXX:0x00A13900] Relay connection down. Continuing in bypass mode until relay connection can be re-established.
[30000] (04/03 06:16:26.068):{0xAC0} [DIAG] EVENT=Register_thread, THREADID=0xAC0, THREADNAME="Unnamed"
[30000] (04/03 06:16:26.068):{0x568} [SERVICE_MANAGER] Connection established. Session=0x00A13798
[30000] (04/03 06:16:26.068):{0x568} [SERVICE_RELAY_SESSION:UNKNOWN:0x00A13798] Accept service session. IP=10.16.18.96, ServiceSession=0x009B1B80
[30000] (04/03 06:16:26.068):{0x954} [DIAG] EVENT=Register_thread, THREADID=0x954, THREADNAME="Unnamed"
[30000] (04/03 06:16:26.068):{0x954} [RELAY_SRP:UNKNOWN:0x00A17F80] Connecting to relay at address "srp.eu.blackberry.net"
[30000] (04/03 06:16:26.178):{0x954} [RELAY_SRP:UNKNOWN:0x00A17F80] Connect: Found 2 addresses for host "srp.eu.blackberry.net"
[30000] (04/03 06:16:26.178):{0x954} [RELAY_SRP:UNKNOWN:0x00A17F80] Connect: Host "srp.eu.blackberry.net" @ [93.186.25.33]
[30000] (04/03 06:16:26.178):{0x954} [RELAY_SRP:UNKNOWN:0x00A17F80] Connect: Host "srp.eu.blackberry.net" @ [193.109.81.33]
[30000] (04/03 06:16:26.178):{0x954} [RELAY_SRP:UNKNOWN:0x00A17F80] Connect: Trying "srp.eu.blackberry.net" @ [93.186.25.33]
[30000] (04/03 06:16:26.490):{0x954} [SERVICE_RELAY_SESSION:UNKNOWN:0x00A13798] Connection to relay established.
[30000] (04/03 06:16:26.490):{0x954} [DIAG] EVENT=Unregister_thread, THREADID=0x954, THREADNAME="Unnamed"
[30000] (04/03 06:16:26.803):{0x570} [SERVICE_SRP:UNKNOWN:0x009B1B80] Receive: no data, ERROR=0
[30000] (04/03 06:16:26.803):{0x570} [SERVICE_RELAY_SESSION:UNKNOWN:0x00A13798] Disconnect session. IP=10.16.18.96
[30000] (04/03 06:16:26.803):{0x570} [SERVICE_SRP:UNKNOWN:0x009B1B80] disconnect
[30000] (04/03 06:16:26.803):{0x570} [RELAY_SRP:UNKNOWN:0x00A17F80] disconnect
[30000] (04/03 06:16:26.803):{0x570} [SERVICE_MANAGER] Delete session. UID=UNKNOWN, Session=0x00A13798
[30000] (04/03 06:16:26.803):{0x570} [RELAY_SRP:UNKNOWN:0x00A17F80] Receive: invalid socket
[30000] (04/03 06:16:26.803):{0x570} [SERVICE_SRP:smileyfrustrated:XXXXXXX:0x009B1C10] Receive: no data, ERROR=0
[30000] (04/03 06:16:26.803):{0x570} [SERVICE_RELAY_SESSION:smileyfrustrated:XXXXXXX:0x00A13900] Disconnect session. IP=10.16.18.96
[30000] (04/03 06:16:26.803):{0x570} [SERVICE_SRP:smileyfrustrated:XXXXXXX:0x009B1C10] disconnect
[30000] (04/03 06:16:26.818):{0x568} [SERVICE_MANAGER] Connection established. Session=0x00A13A68
[30000] (04/03 06:16:26.818):{0x568} [SERVICE_RELAY_SESSION:UNKNOWN:0x00A13A68] Accept service session. IP=10.16.18.96, ServiceSession=0x009B19D0
[30000] (04/03 06:16:26.818):{0x618} [DIAG] EVENT=Register_thread, THREADID=0x618, THREADNAME="SRPReceiverHandler"
[30000] (04/03 06:16:27.803):{0x8C8} [DIAG] EVENT=Unregister_thread, THREADID=0x8C8, THREADNAME="SRPReceiverHandler"
[30000] (04/03 06:16:27.834):{0x570} [RELAY_SRP:smileyfrustrated:XXXXXXX:0x00A17780] disconnect
[30000] (04/03 06:16:27.834):{0xAC0} [DIAG] EVENT=Unregister_thread, THREADID=0xAC0, THREADNAME="Unnamed"
[30000] (04/03 06:16:27.865):{0x570} [SERVICE_MANAGER] Delete session. UID=SXXXXXXX, Session=0x00A13900
[30000] (04/03 06:16:27.865):{0x570} [DEVICE_MANAGER] SRP StopListening. Port 4101.
[30000] (04/03 06:16:27.865):{0xA8C} [DIAG] EVENT=Unregister_thread, THREADID=0xA8C, THREADNAME="SRPListenerImp"
[30000] (04/03 06:16:27.897):{0x570} [SERVICE_RELAY_SESSION:smileyfrustrated:XXXXXXX:0x00A13A68] Service claim UID. UID: SXXXXXXX Requested SRP Version:3, IP=10.16.18.96
[30000] (04/03 06:16:27.897):{0xAB8} [DIAG] EVENT=Register_thread, THREADID=0xAB8, THREADNAME="Unnamed"
[30000] (04/03 06:16:27.897):{0xAB8} [RELAY_SRP:UNKNOWN:0x00A17948] Connecting to relay at address "srp.eu.blackberry.net"
[30000] (04/03 06:16:27.897):{0xAB8} [RELAY_SRP:UNKNOWN:0x00A17948] Connect: Found 2 addresses for host "srp.eu.blackberry.net"
[30000] (04/03 06:16:27.897):{0xAB8} [RELAY_SRP:UNKNOWN:0x00A17948] Connect: Host "srp.eu.blackberry.net" @ [93.186.25.33]
[30000] (04/03 06:16:27.897):{0xAB8} [RELAY_SRP:UNKNOWN:0x00A17948] Connect: Host "srp.eu.blackberry.net" @ [193.109.81.33]
[30000] (04/03 06:16:27.897):{0xAB8} [RELAY_SRP:UNKNOWN:0x00A17948] Connect: Trying "srp.eu.blackberry.net" @ [93.186.25.33]
[30000] (04/03 06:16:28.193):{0xAB8} [SERVICE_RELAY_SESSION:smileyfrustrated:XXXXXXX:0x00A13A68] Connection to relay established.
[30000] (04/03 06:16:28.193):{0xAB8} [DIAG] EVENT=Unregister_thread, THREADID=0xAB8, THREADNAME="Unnamed"
[30000] (04/03 06:16:29.100):{0x570} [SERVICE_RELAY_SESSION:smileyfrustrated:XXXXXXX:0x00A13A68] Service relay connection authenticated. SRPVersion: 3
[30000] (04/03 06:16:29.100):{0x570} [SERVICE_MANAGER] Session authenticated. UID=SXXXXXXX, Session=0x00A13A68
[30000] (04/03 06:16:29.100):{0x570} [DEVICE_MANAGER] SRP StartListening. Port 4101.
[30000] (04/03 06:16:29.100):{0xB5C} [DIAG] EVENT=Register_thread, THREADID=0xB5C, THREADNAME="SRPListenerImp"
[30000] (04/03 06:16:33.334):{0x570} [SERVICE_SRP:UNKNOWN:0x009B1B80] disconnect
[30000] (04/03 06:16:33.334):{0x570} [RELAY_SRP:UNKNOWN:0x00A17F80] disconnect
[30000] (04/03 06:16:33.334):{0x570} [SERVICE_SRP:smileyfrustrated:XXXXXXX:0x009B1C10] disconnect

 

 

Please use plain text.
Regular Contributor
orangekeeper
Posts: 50
Registered: ‎08-02-2010
My Device: z10
My Carrier: TMUK

Re: Blackberry Enterprise Server Dispatcher gets disconnected with Remote Router multiple times in single day

It looks like your router is having connectivity problems out to Blackberry, although the time stamp of these logs differs from the Dispatcher logs so we can't immediately tie the 2 together.

 

I see a ERROR=10054 log line, which is referenced here: http://www.blackberry.com/btsc/KB17160 and suggests general connectivity problems (I.e. Firewall, NIC, internet connection etc).

 

Also, there's a log line showing "Invalid Socket" which I can't find referenced in the KB, but I seem to remember seeing that before when there have been problems with an SRP ID (I.e it's disabled or it's been temporary and run out). If this were the case though, I'd expect the BES to lose all connectivity...

 

Do you guys use multiple remote routers?

If so are both configured using the same SRP ID or is this one different?

Could this router be using a temporary SRP ID that has expired?

Please use plain text.
Contributor
jikuma
Posts: 14
Registered: ‎03-08-2010
My Device: 8830
My Carrier: Tata Indicom

Re: Blackberry Enterprise Server Dispatcher gets disconnected with Remote Router multiple times in single day

Dear Orangekeeper,

 

Thanks for prompt reply.

 

We do not have multiple BES Router in our Environment .

 

For checking connectivity issue, I had placed continuos ping to SRP and from BES to Remote Router.

 

but i had not received any drop in ping stats.

 

So something strange is going on.

 

Can you suggest any way to get to the root of the issue ?

Please use plain text.
Regular Contributor
orangekeeper
Posts: 50
Registered: ‎08-02-2010
My Device: z10
My Carrier: TMUK

Re: Blackberry Enterprise Server Dispatcher gets disconnected with Remote Router multiple times in single day

No worries,

 

With the information we have so far, I'd probably focus on the drops between the router and RIMs SRP host initially.

 

How often do these occur from the logs (Check for the instances of the 10054 or the invalid socket error)?

 

Are users experiencing a full service outage or is the router reconnecting immediately again after it drops?

 

If you have any firewalls between the BES and internet, do the logs show any packet drops at these time periods (I know you are pinging the SRP host, however this will go over a different port to the Router connection, so it's feasible that one can work while the other fails)?

 

 

 

Please use plain text.