If you are using Internet Explorer, please remove blackberry.com from your compatibility view settings.

Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
New Contributor
epoitier
Posts: 4
Registered: ‎08-23-2013
My Device: Z10
My Carrier: Orange

Compatibility document (BES10_and_Mobile_Device_OS_Compatibility_Matrix_en.pdf) mention SQLServer 2012 supported

All,

 

I am trying to install BES10 and did prepare a virtual machine to host this service.

 

I ensured all the software requirements were supported using the BES10_and_Mobile_Device_OS_Compatibility_Matrix_en.pdf document, and found that SQL Server 2012 is supported, though when I install BES10 and especially creating the database, it does fail due to SQL Server 2008 ADO client missing.

 

Is it normal to reference some software version which should be supported and seems not to be; or requires a previous version or mix of different software versions ?

 

Also our company would have prefered to use Linux systems and servers, so is there any plans to support other systems outside of the Windows ecosystem, as it is quite a big investment to deploy a BES 10 server with all the Windows components licenses to pay (Windows 2012 server, SQLServer 2012/2008, Exchange 2013) ?

 

Please note that after installing the SQLServer 2008 ADO client, it does seem SALServer 2008 is still required as it still fails with the error below when creating the database, and following the BES10_v10.1.2_Installation_Guide_en document:

 

<#03>[30000] (08/23 22:56:51.492):{0x1B18} ADO ConnectionTimeout value = 30s
<#03>[30000] (08/23 22:56:51.492):{0x1B18} ADO ConnectionTimeout for re-initalizing the pool = 45s
<#02>[25137] (08/23 22:56:52.688):{0x1B18} {ConnectionItem::ConnectToDB} Failed to connect.  Connection string is Provider=SQLNCLI10;Server=localhost;Database=master;Network=dbmssocn;uid=ENMAN\BES10Admin;pwd=
<#02>[25000] (08/23 22:56:52.762):{0x1B18} ConnectionItem::ConnectToDB: COM Error 0x80040E4D - IDispatch error #3149 - Source: "Microsoft SQL Server Native Client 10.0" - Description "Login failed for user 'ENMAN\BES10Admin'." - Command "ConnectionItem::ConnectToDB"
<#02>[20000] (08/23 22:56:52.801):{0x1B18} [CBESDBInstaller::Connect] : Pool failed to initialize

I would really appreciate that Blackberry envisage a plan for companies having already other servers deployed such as Postfix and Linux based systems.

 

Thanks in advance for your consideration and help on this matter.

 

Best regards,

Emmanuel Poitier

Please use plain text.
Guru III
knottyrope
Posts: 29,925
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Compatibility document (BES10_and_Mobile_Device_OS_Compatibility_Matrix_en.pdf) mention SQLServer 2012 supported

did you apply SQL permissions for the BESAdmin account?

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 5.0.4 and BES 10.2.2 with Exchange 2010 and SQL 2008


Please use plain text.
New Contributor
epoitier
Posts: 4
Registered: ‎08-23-2013
My Device: Z10
My Carrier: Orange

Re: Compatibility document (BES10_and_Mobile_Device_OS_Compatibility_Matrix_en.pdf) mention SQLServer 2012 supported

All,

 

I have set the SQL permissions as listed in the document. I have been able to create the database manually without providing SQL usernamane and password, as SQL Server account was created using the Windows authentication method.

 

The IIS server is not detected (though the document mention BES supports IIS v8) and the BES installer installs a new IIS intance. The BES installer complains about registry keys missing when checking IIS presence as mentioned in the KB34268 so it is quite disappointing to have installed all the supported components when the BES installer reinstall other version of the same component.

 

Though I am still looking to an answer about the Linux support for BES and if any plans are in discussion.

 

Best regards,

Emmanuel Poitier

Please use plain text.
Guru III
knottyrope
Posts: 29,925
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Compatibility document (BES10_and_Mobile_Device_OS_Compatibility_Matrix_en.pdf) mention SQLServer 2012 supported

when you created the database did you use the BESAdmin account to do it?

 

When I installed BES 10, I used a new 2012 Vm and only installed the .net 3.5, I let the installer do the rest.

 

 

As for Linux, I have not seen anything mentioned for BES in past 6 years

 

there are a few email servers you can connect BES 5 to bu you still need AD present to run it.

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 5.0.4 and BES 10.2.2 with Exchange 2010 and SQL 2008


Please use plain text.
New Contributor
epoitier
Posts: 4
Registered: ‎08-23-2013
My Device: Z10
My Carrier: Orange

Re: Compatibility document (BES10_and_Mobile_Device_OS_Compatibility_Matrix_en.pdf) mention SQLServer 2012 supported

All,

 

> when you created the database did you use the BESAdmin account to do it?

 

Yes, as I mentioned, I followed the installation guide detailing the BESAdmin account creation.

 

 

> When I installed BES 10, I used a new 2012 Vm and only installed the .net 3.5, I let the installer do the rest.

 

I am using as well a Windows 2012 Server VM, though as mentioned I installed all th software first-hand, which may be something I should not have done (and hoped the installation process would have been easier, which is possibly something I have not assessed correctly).

 

I will inform you once I will have my server setup.

 

Best regards,

Emmanuel Poitier

Please use plain text.
New Contributor
epoitier
Posts: 4
Registered: ‎08-23-2013
My Device: Z10
My Carrier: Orange

Re: Compatibility document (BES10_and_Mobile_Device_OS_Compatibility_Matrix_en.pdf) mention SQLServer 2012 supported

All,

 

so I have been able to install BES10 on the virtual machine and I have been able to use it and activate a device so far.

 

I have passed the Linux support to some people at Blackberry, and it seems it is something asked already and will see what will happen.

 

Best regards,

Emmanuel Poitier

Please use plain text.
Guru III
knottyrope
Posts: 29,925
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Compatibility document (BES10_and_Mobile_Device_OS_Compatibility_Matrix_en.pdf) mention SQLServer 2012 supported

glad to hear you have made some progress

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 5.0.4 and BES 10.2.2 with Exchange 2010 and SQL 2008


Please use plain text.