Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
Contributor
LeighMo
Posts: 11
Registered: ‎06-09-2011
My Device: 9780
My Carrier: ...

MsAddresses, ServerName field not updating

[ Edited ]

Hi BB Community,

 

We have just migrated some users from Lotus Notes to Microsoft Exchange 2010 SP2 RU4, we run BES 5.0.4 for Exchange. Users who were previously migrated (eg a few weeks ago are working fine still, SRP is connected fine, CAL's are fine, I completely wiped the blackberry’s and then reset to factory (to remove old BES keys) and installed the latest ROM. However when I go to activate any of them it just sits on the Contacting Server... Users get the ETP.dat sitting in their Exchange mailboxes but it never gets cleared out by the BES server.

 

Looking through the logs i believe my problem is due to the following error.

 

[30041] (05/01 23:34:53.960):{0x4CC} Starting handheld for User1

[30463] (05/01 23:34:53.960):{0x4CC} User User1 can not be started, ServerDN not defined, user may restart after ScanGAL

[20154] (05/01 23:34:53.960):{0x4CC} User User1 not started

 

I have checked the ServerName field for the respective user in the MSAddresses table and I can see the entry does not exist for these new users. I did a rebuild of the Exchange offline address book, gave it a while and then have tried multiple times to execute the "Refresh available user list from company directory" from the new user section and also the Blackberry Solution Topology > Blackberry Domain > Component View > Email

 

The following article describes my exact problem. Unfortunately these users will want their blackberry’s back in about 8 hours so i am really hoping someone can point me in the direction to force the ServerName field to update and or it magically happens in less than the "24 hour" period.

 

http://www.blackberry.com/btsc/KB22568

 

Thanks in advance

Leigh

Please use plain text.
Administrator (Retired)
FozzieBear
Posts: 2,372
Registered: ‎07-13-2009
My Device: BlackBerry Z10 smartphone

Re: MsAddresses, ServerName field not updating

Hello LeighMo,

 

Thank you for your question regarding the ServerName field not updating.

 

The following article will show you how to manually “Refresh available user list from company directory” -  http://www.blackberry.com/btsc/KB17400

 

If this process does not work you may need to check the BlackBerry Enterprise Server logs located at C:\Program Files(x86)\Research In Motion\BlackBerry Enterprise Server\Logs\<Today's Date>. If you look at the MAST log it will show an attempt to update and will show any changes or fails at the bottom of the file. 

 

We hope this helps.


-FB


 


Come follow your BlackBerry Technical Team on Twitter! @BlackBerryHelp


Be sure to click Kudos! for those who have helped you.

Click "Accept as a Solution" for posts that have solved your issue(s)!


Please use plain text.
Contributor
LeighMo
Posts: 11
Registered: ‎06-09-2011
My Device: 9780
My Carrier: ...

Re: MsAddresses, ServerName field not updating

Thanks for the reply FozzieBear, I did try that on the day, however it did not seem to update those fields, do you know how long it can typically take, we have another release this weekend so i will retry the steps in the KB again.
Please use plain text.
Retired
SmoothRider
Posts: 2,649
Registered: ‎04-01-2008
My Device: 9500, 8110, 8700, 8220, 9100, 9800, 9810, Z10

Re: MsAddresses, ServerName field not updating

Hello LeighMo

 

Normally the ScanGal will start after 12 minutes; this can be forced by the “Refresh from company directory” feature in BAS. If forcing the update and all things being equal with no issues in communication in the environment, the BES should retrieve the updated Global Catalog or GC fairly quickly, although this can depend on the size of the user base.

 

  1. Can you confirm that the BlackBerry Mail Store Service remains running?
  2. If you create a new test user in active directory and add that user to the BES, perform a “refresh company directory” from the BAS, does this new test user appear?
  3. Have you tried a restart of the BlackBerry Mail Store Service to see if it will populate the necessary end user information?

If you have confirmed the above I suggest contacting BlackBerry Support for further assistance.

-SR

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!

Please use plain text.
Contributor
LeighMo
Posts: 11
Registered: ‎06-09-2011
My Device: 9780
My Carrier: ...

Re: MsAddresses, ServerName field not updating

Thanks for the reply smoothrider, I have tried all of your suggestions and I am still having the same problems. I am not sure if the fact these users are mail-enabled (AD user as a contact, no mailbox on exchange) to start with and then because we are migrating them over to be full mailbox enabled users something weird is happening. But that ServerName field still has not updated after trying all of the above suggestions, also tried rebuilding the GAL thought that could have been part of the cause as it would have had them as a contact, yet now they are mailbox enabled.

 

Either way our last migration is this weekend so looks like its going to remain unresolved, but thanks for the assistance Fozzie and SmoothRider

Please use plain text.