Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
New Contributor
Posts: 7
Registered: ‎10-17-2008
My Device: Torch 9800
My Carrier: Telus

Upgrading BES

I've recently inherited a BES server with less than 10 users on it. It is running version 4.1.1.10 and I'd like to upgrade to a newer version.

I looked at the service packs, and it doesn't look like I can install the latest one as my version is too old.

Anyone know if I can install a full new version over top of the existing old one without losing any settings?

Thanks,
Rob

Forums Veteran II
Posts: 2,744
Registered: ‎04-01-2008
My Device: Bold

Re: Upgrading BES

4.1.1 can be upgraded all the way through 4.1.6 MR1 for free

 

Simply download the service pack and maintenance release; making sure you take a backup of the database and bes prior to the upgrade.

------------------------------
If you've found a solution through a post; please mark it as a solution.
If someone's was particularly helpful, give them kudo's!.


Get busy living, or get busy dying.

http://blog.port3101.org/hdawg/
New Contributor
Posts: 7
Registered: ‎10-17-2008
My Device: Torch 9800
My Carrier: Telus

Re: Upgrading BES

Thanks - I was able to upgrade to version 4.1.5.26 and the server is working with the exception of the MDS Admin - it keeps wanting the SSL Certificate installed. I've done that as requested (even manually placing it in the right store) but keep getting an error in retrieving data from the server...

In my ignorance, I don't know if that is important as the BES is still working with no complaints from any users after a couple weeks since the update.

Highlighted
Forums Veteran II
Posts: 2,744
Registered: ‎04-01-2008
My Device: Bold

Re: Upgrading BES


rmaccara wrote:

Thanks - I was able to upgrade to version 4.1.5.26 and the server is working with the exception of the MDS Admin - it keeps wanting the SSL Certificate installed. I've done that as requested (even manually placing it in the right store) but keep getting an error in retrieving data from the server...

In my ignorance, I don't know if that is important as the BES is still working with no complaints from any users after a couple weeks since the update.


 

The MDS Admin thing is actually MDS-IS (MDS Integration Services) ... unless you're tying your BES into some back-office type application and deploying applications to your handhelds that use such integrated data you'll have no use for this.  In fact I'd disable the service if you're not using it.

 

This is no what the traditional MDS is; which is what people reference as the BlackBerry Browser / web browsing on the HH through the BES.

 

If you really want to get it working make sure you add the certificate to the trusted root store and it should open right up for you.

------------------------------
If you've found a solution through a post; please mark it as a solution.
If someone's was particularly helpful, give them kudo's!.


Get busy living, or get busy dying.

http://blog.port3101.org/hdawg/