Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
New Contributor
mwreede
Posts: 2
Registered: ‎09-17-2008
My Device: Not Specified

BPS and Exchange 2007 SP1

Howdy.

 

We're planning on upgrading to SP1 for our Exchange 2007 SP1 server this weekend.

 

Our current version of BPS is the latest, I believe, at 4.1.4.3, Service Pack 4A. I realize there is a 4B as well, and will upgrade to that if need be.

 

Dumb question, though: Can I just download the entire ~ 311MB service pack file and run that on top of the existing BPS server, and it'll upgrade it?

 

Anyways, my main question is this: Post SP1 install on Exchange 2007, is there anything I'll need to do on the BPS side of things?

 

Thanks for any information, and I can clarify any points.

 

Matt

Please use plain text.
Forums Veteran II
AndyDufresne
Posts: 2,744
Registered: ‎04-01-2008
My Device: Bold

Re: BPS and Exchange 2007 SP1

4.1.3 or > is supported with Exchange 2007 (and SP1)

 

Make sure you're using the latest version of the MAPI / CDO components on the BES.  BPS 4.1.4B I think only adds language support; no real value in it for you. ... but yes, you download the big upgrade file and run that to upgrade if you want.

 

Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1

------------------------------
If you've found a solution through a post; please mark it as a solution.
If someone's was particularly helpful, give them kudo's!.


Get busy living, or get busy dying.

http://blog.port3101.org/hdawg/
Please use plain text.
New Contributor
mwreede
Posts: 2
Registered: ‎09-17-2008
My Device: Not Specified

Re: BPS and Exchange 2007 SP1

Interesting, did not know they had released a new version of the MAPI controls. Thanks for pointing that out.

 

I assume the newer version of the Exchange MAPI controls can just be installed over the existing MAPI controls I have on the BES now?

Please use plain text.
Forums Veteran II
AndyDufresne
Posts: 2,744
Registered: ‎04-01-2008
My Device: Bold

Re: BPS and Exchange 2007 SP1

Depends what you currently have installed.

 

If you have Exchange 2003 ESM installed you'll want to remove that and replace with this.

------------------------------
If you've found a solution through a post; please mark it as a solution.
If someone's was particularly helpful, give them kudo's!.


Get busy living, or get busy dying.

http://blog.port3101.org/hdawg/
Please use plain text.