Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Trusted Contributor
Fooled
Posts: 226
Registered: ‎07-07-2010
My Device: Blackberry BOLD 9700
My Carrier: ATT

Re: BES 5.0.2 message to user delay after migrate

My 2 cents:

 

RIM says they support SP1, well it does work, but not as we've all been accustomed to. Why? Because as of SP1 Microsoft dramatically changed the infrastructure of exchange which is actually the root cause for most of the issues. As of SP1 the resouces required to run an exchange environment about quadrupled!

 

Do not install the mapi cdo in exchange. Not needed, these packs are for systems that integrate and work with exchange.

 

If you still hvae delays, in particular to clients, then this is not BES related. IF they happen when the BES in on there, whoever ran the specs for what you needed to deploy exchange with BES in your environment was dead wrong.

Please use plain text.
Contributor
ManuNarayan
Posts: 14
Registered: ‎01-11-2011
My Device: Not Specified

Re: BES 5.0.2 message to user delay after migrate

Thanks for clearing up the MAPI/CDO on Exchange for me.  I thought that it was odd CDO would be a separate pack and not updated with exchange updates.

Please use plain text.
Contributor
rueburbon
Posts: 16
Registered: ‎10-14-2009
My Device: Not Specified

Re: BES 5.0.2 message to user delay after migrate

Jbrass123,  this is probably the singularly most helpful post that I've received.  Not that the others weren't helpful, but this one has improved our performance, but not resolved it.

 

The last two regisitry entries, although I've seen them before as I had the 1st on already configured, has extented the delayed time to about 6 hours.  Meaning, we dont start experiencing the delays until 6 hours after the reboot of the server.  Its allowed me to semi function while waiting on suppport to review my logs.


http://www.blackberry.com/btsc/KB22812 Intermittent mail delivery issues via Load balancer
http://www.blackberry.com/btsc/KB03193 enable ldap
http://www.blackberry.com/btsc/KB20157 ews  Calander helper

[HKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion\BlackBerry Enterprise Server\Agents]
"NumAgents"=dword:00000005

[HKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion\BlackBerry Enterprise Server\Dispatcher]
"MaxUsersPerAgent"=dword:0000004b
"AgentOptimizeAlgorithm"=dword:00000001

 

 

 

 

Please use plain text.
Contributor
jbrass123
Posts: 11
Registered: ‎02-16-2011
My Device: 9550
My Carrier: Verizon

Re: BES 5.0.2 message to user delay after migrate

Cool, glad the post helped, I was using our TSupport agreement with RIM to help gather all the things that RIM had me apply to help resolve this issue. Things are still good here, just waiting for the real fix from RIM/MS

John

Quest Software  

Please use plain text.
Trusted Contributor
Fooled
Posts: 226
Registered: ‎07-07-2010
My Device: Blackberry BOLD 9700
My Carrier: ATT

Re: BES 5.0.2 message to user delay after migrate

The need to know regarding these changes:

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion\BlackBerry Enterprise Server\Agents]
"NumAgents"=dword:00000005

 

Sets your number of agents to 5. This is more or less the default.

 

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion\BlackBerry Enterprise Server\Dispatcher]
"MaxUsersPerAgent"=dword:0000004b
"AgentOptimizeAlgorithm"=dword:00000001

 

These are pretty dramatic changes, so becareful using them.

 

"MaxUsersPerAgent"=dword:0000004b means a maximum of 75 users per agent. Therefore if you have more than 375 users per BES (75x5)-- well you can do the math. I havent tested, so there is a chance a 6th agent would spawn, but I don't believe it does, unless you have modified the MaxAgentsPerServer key.

 

The algorithm simply put, moves users into an agent based on the load of the agents, spreading them evenly across. This SHOULD NOT be used unless you are in an exchange 2010 environment.

Please use plain text.
Contributor
ALS_72
Posts: 17
Registered: ‎03-06-2011
My Device: Bold 9700
My Carrier: Optus Australia

Re: BES 5.0.2 message to user delay after migrate

[ Edited ]

FYI, BES 5.0.2 MR5 has been delayed...no new date as yet.

 

Also, since the installation of E2K10 SP1 RU3 over the weekend, we have seen some random email delivery delays on Outlook 2010 (very odd as seems to be reverse of the fix done for UDP and Outlook 2003 in online mode ?).  We are engaging Microsoft on this one....

 

So far BB email delivery delays are still OK since MR4.

Please use plain text.
Contributor
ALS_72
Posts: 17
Registered: ‎03-06-2011
My Device: Bold 9700
My Carrier: Optus Australia

Re: BES 5.0.2 message to user delay after migrate


knottyrope wrote:

Look like Exchange 2010 SP1 RU3 is acting up

http://blogs.technet.com/b/exchange/archive/2011/0​3/14/exchange-2010-sp1-rollup-3-and-blackberrys-s...


FYI...knottyrope posted this over on another article we are also experiencing since RU3

(http://supportforums.blackberry.com/t5/BlackBerry-Enterprise-Server/Exchange-2010-SP1-RU3-Duplicate-...)

Please use plain text.
Contributor
ManuNarayan
Posts: 14
Registered: ‎01-11-2011
My Device: Not Specified

Re: BES 5.0.2 message to user delay after migrate

We started seeing some significant Outlook client issues the past few days.  Random lockups or slow message delivery to devices.  Our Average Disk Queue was fairly high and physical memory usage was riding high as well.

 

The moment I turned down blackberry services we saw disk queue length get cut to literally 1/100th of what it was and physical memory consumption drop by 6.5GB.  We decided to rush or MR4 update and are currently looking at performance.  Will let everyone know where we are in a few days.  But wanted to give a quick update.

Please use plain text.
Contributor
GaryCutri
Posts: 13
Registered: ‎01-18-2009
My Device: Torch 9800
My Carrier: Telstra

Re: BES 5.0.2 message to user delay after migrate

  To correct this issue you will need to apply BES 5.0.2 MR4 and update to the latest MAPI\CDO client.  Please note that you need to uninstall the old client > install the new client > delete and recreate the MAPI profiles.

 

More Info:  http://www.blackberryforums.com.au/forums/blogs/garycutri/54-guide-bes-5-0-2-exchange-2010-sp1-laten...

www.blackberryforums.com.au
Please use plain text.
Contributor
ManuNarayan
Posts: 14
Registered: ‎01-11-2011
My Device: Not Specified

Re: BES 5.0.2 message to user delay after migrate

We did MR4 and the security patch as well as the MAPI / CDO, but no change.

Please use plain text.