Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

New Contributor
Posts: 2
Registered: ‎05-21-2014
My Device: Q30
My Carrier: Rogers

BES10.1 to 10.2.0 Upgrade Fails

UDS Services are installed on the same server as BDS.  When upgrading from 10.1 to 10.2.0 I get an error during the finalizaing stage of deployment.  I have checked KB34268 and KB35633 and neither have provided me with a solution.  Below is my error log from the Installer logs


<#01>[10000] (05/20 20:56:18.520):{0xA04} CXMLImplement::setNamedAttributeValue: Failed to set the value for named attribute [/configuration/appSettings/add[@key="DataProviderEncryptionKey"]/@value]

<#01>[10000] (05/20 20:56:18.520):{0xA04} GenerateRijndaelKeyAndVector: Failed to update DataProviderEncryptionKey value in Core's web.config to [Ihã˜RnòsÐz¡£þÌ×›D,ËEm5ªø恍Bƒ‰ƒA,[R/œ}5—.³].

<#01>[10000] (05/20 20:56:18.520):{0xA04} CDataContainer:Smiley Very HappyoApplyImpl: UbitexxCoreDataCon failed to apply. Result: 486055.

<#01>[10000] (05/20 20:56:18.520):{0xA04} [CUbitexxCoreDataCon::Apply]: Error calling GenerateRijndaelKeyAndVector

<#02>[20000] (05/20 20:56:18.520):{0xA04} CInstallStepSeq:Smiley TonguereApplyProcess: Errors encountered while applying Core Module. Core module may not be operational.

<#03>[30000] (05/20 20:56:23.805):{0xA04} CInstallStepSeq:Smiley TonguereApplyProcess: Core module application failed. User elected to cancel, exiting install

<#03>[30000] (05/20 20:56:23.805):{0xA04} Step PreApplyProcess failed

<#01>[10000] (05/20 20:56:23.805):{0xA04} [CInstallStepSeq:Smiley TonguereApplyProcess]: Core module application failed.

Guru III
Posts: 31,535
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: BES10.1 to 10.2.0 Upgrade Fails

possible to try this

BlackBerry Enterprise Service 10 version 10.1.3 upgrade fails at the "Finalize Installation" stage   


Click here to Backup the data on your BlackBerry Device! It's important, and FREE!

Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.

SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope

Want to thank me? Buy my KnottyRope App here

BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V

New Contributor
Posts: 2
Registered: ‎05-21-2014
My Device: Q30
My Carrier: Rogers

Re: BES10.1 to 10.2.0 Upgrade Fails

Thanks, I just tried that and no change in the result.  One thing of note is that the directory I have is different.


C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Service 10\RIM.BUDS.Gui\ssl