Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
New Contributor
icebalm
Posts: 7
Registered: ‎05-06-2013
My Device: None
My Carrier: Rogers

BES10 Install Failure

Hi All,

 

I'm trying to install the UDS (first component) and at the finalizing prtion of the installation I get "The Universal Device Service has failed."  Here's the last bit of my setup log file:

 

<#03>[30000] (05/06 14:07:05.636):{0x4C74} CWebRequestWrapper starting...
<#04>[40000] (05/06 14:07:05.636):{0x4C74} CWebRequestWrapper::RetrieveData&colon; Starting retrieve data...
<#04>[40000] (05/06 14:07:05.636):{0x4C74} CWebRequestWrapper::RetrieveData&colon; WinHttpOpenRequest succeeded. SecureConnection: [1].
<#04>[40000] (05/06 14:07:05.636):{0x4C74} CWebRequestWrapper::RetrieveData&colon; WinHttpSetOption succeeded. Flags: 12544.
<#01>[10000] (05/06 14:07:06.644):{0x4C74} CWebRequestWrapper::RetrieveData&colon; WinHttpSendRequest failing. Error code: 12029. Header length: 82.
<#01>[10000] (05/06 14:07:06.644):{0x4C74} CRestApiWrapper::GetUserProperties: Failed to retrieve the user account's properties. name: [ubi], type: [1], return: [486003].
<#02>[20000] (05/06 14:07:06.644):{0x4C74} CUbitexxCoreConnectionDC::CheckCore: Unable to pass the authentication check.
<#03>[30000] (05/06 14:07:06.644):{0x4C74} CUbitexxCoreConnectionDC::GetCoreConnectPassword: return specified password.
<#03>[30000] (05/06 14:07:06.644):{0x4C74} CRestApiWrapper starting requests to 'https://staff.kupar.com:8081' ...
<#03>[30000] (05/06 14:07:06.644):{0x4C74} CPasswordDataCon::Base64Encode succeeded
<#03>[30000] (05/06 14:07:06.644):{0x4C74} CWebRequestWrapper starting...
<#03>[30000] (05/06 14:07:06.644):{0x4C74} CWebRequestWrapper::smileyfrustrated:ubmitData&colon; Starting sending data...
<#04>[40000] (05/06 14:07:06.645):{0x4C74} CWebRequestWrapper::smileyfrustrated:ubmitData&colon; WinHttpOpenRequest succeeded. SecureConnection: [1]
<#04>[40000] (05/06 14:07:06.645):{0x4C74} CWebRequestWrapper::smileyfrustrated:ubmitData&colon; WinHttpSetOption succeeded. Flags: 12544.
<#01>[10000] (05/06 14:07:07.653):{0x4C74} CWebRequestWrapper::smileyfrustrated:ubmitData&colon; WinHttpSendRequest failing. Error code: 12029. Header length: 86.
<#01>[10000] (05/06 14:07:07.653):{0x4C74} CRestApiWrapper::smileyfrustrated:etCertificateAttributes error sending data, result is [486003]
<#01>[10000] (05/06 14:07:07.653):{0x4C74} CUbitexxSRPInfoCon::UpdateSRPAddress failed to apply SRP Address and Port.
<#03>[30000] (05/06 14:07:07.653):{0x4C74} CUbitexxSRPInfoCon::UpdateSRPAddress wrote SRPHost[ca.srp.blackberry.com] SRPPort[3101], result [12]
<#03>[30000] (05/06 14:07:07.653):{0x4C74} CUbitexxSRPAddressCon::Apply result is [12] - [SRPHost[ca.srp.blackberry.com], SRPPort[3101], CES[0], IVA[1/1/0] LD[1]WD[0] RO[0]]
<#01>[10000] (05/06 14:07:07.653):{0x4C74} CDataContainer::smileyvery-happy:oApply: CUbitexxSRPAddressCon failed to apply. Result: 12.
<#03>[30000] (05/06 14:07:07.653):{0x4C74} Step ApplyProduct failed
<#01>[10000] (05/06 14:07:07.653):{0x4C74} [CInstallStepSeq::ApplyProduct]: Product application failed.

 

Any help would be appreciated.

Please use plain text.
Guru III
knottyrope
Posts: 29,749
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: BES10 Install Failure

did you allow port 3101 outbound on your firewall?

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 5.0.4 and BES 10.2.2 with Exchange 2010 and SQL 2008


Please use plain text.
New Contributor
icebalm
Posts: 7
Registered: ‎05-06-2013
My Device: None
My Carrier: Rogers

Re: BES10 Install Failure


knottyrope wrote:

did you allow port 3101 outbound on your firewall?


Yeah, there are no ports that are blocked for outbound communication, but would I have to open it up for inbound?

Please use plain text.
New Contributor
icebalm
Posts: 7
Registered: ‎05-06-2013
My Device: None
My Carrier: Rogers

Re: BES10 Install Failure

Well I think I fixed that issue, was a DNS failure causing the hostname not to be resolved, but now I've run into another issue:

 

<#03>[30000] (05/07 15:06:51.244):{0x2058}  CUbitexxCoreDataCon::Apply executing - ["C:\Program Files (x86)\IIS\Microsoft Web Deploy V2\msdeploy.exe" -source:smileytongue:ackage="C:\Program Files (x86)\Research In Motion\Universal Device Service\setup\core\RIM.BUDS.CoreServer.zip" -dest:auto,includeAcls="False" -verb:sync -disableLink:AppPoolExtension -disableLink:ContentExtension -disableLink:CertificateExtension -setParam:name="IIS Web Application Name",value="UDS.CoreModule"]
<#03>[30000] (05/07 15:07:01.164):{0x2058} CProcessWrapper::RunCommand: The exit code of the process for "C:\Program Files (x86)\IIS\Microsoft Web Deploy V2\msdeploy.exe" -source:smileytongue:ackage="C:\Program Files (x86)\Research In Motion\Universal Device Service\setup\core\RIM.BUDS.CoreServer.zip" -dest:auto,includeAcls="False" -verb:sync -disableLink:AppPoolExtension -disableLink:ContentExtension -disableLink:CertificateExtension -setParam:name="IIS Web Application Name",value="UDS.CoreModule" is [-1].
<#03>[30000] (05/07 15:07:01.165):{0x2058} CProcessWrapper::RunCommand: Successfully launched the process: "C:\Program Files (x86)\IIS\Microsoft Web Deploy V2\msdeploy.exe" -source:smileytongue:ackage="C:\Program Files (x86)\Research In Motion\Universal Device Service\setup\core\RIM.BUDS.CoreServer.zip" -dest:auto,includeAcls="False" -verb:sync -disableLink:AppPoolExtension -disableLink:ContentExtension -disableLink:CertificateExtension -setParam:name="IIS Web Application Name",value="UDS.CoreModule"
<#03>[30000] (05/07 15:07:01.165):{0x2058} CProcessWrapper::WriteOutputToSetupLog: ===process output===
<#03>[30000] (05/07 15:07:01.167):{0x2058} Info: Adding sitemanifest (sitemanifest).
<#03>[30000] (05/07 15:07:01.167):{0x2058} Info: Adding createApp (UDS.CoreModule).
<#03>[30000] (05/07 15:07:01.167):{0x2058} Info: Adding contentPath (UDS.CoreModule).
<#03>[30000] (05/07 15:07:01.167):{0x2058}
<#03>[30000] (05/07 15:07:01.167):{0x2058}  CUbitexxCoreDataCon::Apply executed Return Code is [-1]
<#03>[30000] (05/07 15:07:01.167):{0x2058} [CUbitexxCoreDataCon::Apply] Parsing the config file: [C:\Program Files (x86)\Research In Motion\Universal Device Service\Core\Web.config].
<#01>[10000] (05/07 15:07:01.169):{0x2058} CXMLImplement::setNamedAttributeValue: Failed to set the value for named attribute [/configuration/appSettings/add[@key="DataProviderConnectionString"]/@value]
<#01>[10000] (05/07 15:07:01.169):{0x2058} [CUbitexxCoreDataCon::Apply] Failed to update the ServerUrl value to [Data Source=KUPARDC01\BLACKBERRY;Network Library=DBMSSOCN;Initial Catalog=UDSMgmt_20130503162722;Persist Security Info=True;Integrated Security=SSPI;MultipleActiveResultSets=True;].
<#01>[10000] (05/07 15:07:01.169):{0x2058} CDataContainer::smileyvery-happy:oApply: UbitexxCoreDataCon failed to apply. Result: 486054.
<#03>[30000] (05/07 15:07:01.169):{0x2058} Step ApplyProduct failed
<#01>[10000] (05/07 15:07:01.169):{0x2058} [CInstallStepSeq::ApplyProduct]: Product application failed.

Anyone have any idea why this msdeploy command is failing?

Please use plain text.
Guru III
knottyrope
Posts: 29,749
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: BES10 Install Failure

See if this applies

Article ID: KB32021

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 5.0.4 and BES 10.2.2 with Exchange 2010 and SQL 2008


Please use plain text.
New Contributor
icebalm
Posts: 7
Registered: ‎05-06-2013
My Device: None
My Carrier: Rogers

Re: BES10 Install Failure

No, that KB article doesn't work. I'm completely stuck at this point...

Please use plain text.