Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
New Contributor
JonasS
Posts: 4
Registered: ‎08-27-2013
My Device: Z10
My Carrier: Telekom
Accepted Solution

Blackberry Management Studio - Email Notification Error when activating Blackberry 10 Devices

Hi Community!

I've been setting up an MDM Environment with the BES10.1 on a Windows Server 2008 R2, after encountering various problems I could figure out by myself I'm now facing one I could really use some help with.

I've configured the SMTP-Connection for the activation emails on both the UDS and BB-Administration-Service and on both of those sites the email-tests are successeful.
When activating new devices with the Management Studio however I receive an error when trying to activate BB10-Devices and sending the activating email (works just fine for iOS/android).

Here's the Error code:
"An error has occurred and the requested action cannot be performed. [140bf1aecb1-6b-12aaee8]"

When looking at the Logfiles the only thing that pops up is this:

 

BWS.log:


(08/27 11:32:49.377):{http-.DE%2F10.138.10.100-38443-9} [com.rim.bes.bas.bws.BWSBean] [DEBUG] [BWS-200] {u=9, uc=0, o=0, t=881343} {a57a7b8c-07b0-4b3c-82cc-10cfce1e4554} {setUsersActivationPassword} Entering method...
(08/27 11:32:52.070):{http.DE%2F10.138.10.100-38443-9} [com.rim.bes.bas.bws.handlers.SetUsersActivationPassword] [DEBUG] [BWS-200] {u=9, uc=0, o=0, t=881535} {a57a7b8c-07b0-4b3c-82cc-10cfce1e4554} {setUsersActivationPassword} Could not send activation email.
(08/27 11:32:52.070):{http-.DE%2F10.138.10.100-38443-9} [com.rim.bes.bas.bws.BWSBean] [DEBUG] [BWS-200] {u=9, uc=0, o=0, t=881535} {a57a7b8c-07b0-4b3c-82cc-10cfce1e4554} {setUsersActivationPassword} ...Exiting method (ONE_OR_MORE_FAILURES-COULD_NOT_SEND_ACTIVATION_MESSAGE)

 

I would really appreciate any help, if you guys need to know anything else just let me know!

Thanks in advance!

 

 

 

Please use plain text.
New Contributor
JonasS
Posts: 4
Registered: ‎08-27-2013
My Device: Z10
My Carrier: Telekom

Re: Blackberry Management Studio - Email Notification Error when activating Blackberry 10 Devices

*push*
Please use plain text.
New Contributor
geronimoo
Posts: 2
Registered: ‎10-17-2013
My Device: Q10
My Carrier: bouygues

Re: Blackberry Management Studio - Email Notification Error when activating Blackberry 10 Devices

Hello,

 

I have the same problem, have you find the answer?

regards,

Please use plain text.
New Contributor
JonasS
Posts: 4
Registered: ‎08-27-2013
My Device: Z10
My Carrier: Telekom

Re: Blackberry Management Studio - Email Notification Error when activating Blackberry 10 Devices

[ Edited ]

Actually, yes.
It was so simple, I almost feel ashamed that I overlooked it, as it was very obvious   :smileyvery-happy:

In the Blackberry Admin-Service, under Devices > Wireless Activation > Device activation settings there is a option called:

"Allow activation information to be emailed:"

 

I just had to activate it.... yeah I don't know how I wasn't able to find this.

 

But anyway way to go with the error message Blackberry, way to go...

 

Hope this solves the problem for you as well!

Please use plain text.
New Contributor
geronimoo
Posts: 2
Registered: ‎10-17-2013
My Device: Q10
My Carrier: bouygues

Re: Blackberry Management Studio - Email Notification Error when activating Blackberry 10 Devices

great! thanks a lot.

 

But I have another question, I m able to connect my BB to BES10 but after I have a password pb. (he ask to update my password, but wrong)

 

Maybe the problem is under "Email Settings" I have try tu put my ip / dns mail name address under "server mail" and activate / desactivate "ssl" but nothing...

 

Please use plain text.
New Contributor
JonasS
Posts: 4
Registered: ‎08-27-2013
My Device: Z10
My Carrier: Telekom

Re: Blackberry Management Studio - Email Notification Error when activating Blackberry 10 Devices

[ Edited ]

Well, if I recall correctly the default password routine is, that it sends you an activation password to the users emailaddress.

 

So lets say you created  a new user, the username is "test" the emailadress is "test@test.com".

 

If you are working with the Blackberry Administration Service you need to go to User > Manage users then click on the test user, now on the bottom-right of the page you'll find the option to Specify an activation password or Generate an activation email.
(If you would select this option the password would be send to test@test.com)

 

For the sake of testing simply select the first option, and choose a password.
After that you can connect the account on your BlackBerry device as it is documented (https://www.blackberry.com/lms/item/6f019f7e-eaff-f02a-5f09-ff8c981a6b32) and use your specified password.

 

Hope that helps!

 

regards

Please use plain text.