Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
New Developer
lund
Posts: 58
Registered: ‎07-15-2009
My Device: 9900 + 32 GB PB
My Carrier: Netcom

Dispatcher service won't start - terminates with service-specific error 5009

[ Edited ]

I Just did a fresh install of BES 5.0 on a Win 2003 R2 Box for use in an Exchange 2003 SP2 Environment.

The server is a physical box, not a VM - I also installed BES 5.0 on another server to use as a standby server for High Availability.

 

BESMgmt is on a remote SQL 2005 server.

 

When the services were started at the end of the installation process, the Dispatcher Service was reported to have started successfully but after a reboot of the server a message appeared at logon sayin that a service failed to start.

 

When I check the event viewer it is reports problems with starting the Dispatcher Service, I have also tried restarting the service manually in the Windows Services window without any luck.

 

Here is one of the error entries from the Event Viewer regardin the Dispatcher Service:

 

Event Type: Error Event Source: Service Control Manager Event Category: None Event ID: 7024 Date: 7/15/2009 Time: 2:22:20 PM User: N/A Computer: ******

Description: The BlackBerry Dispatcher service terminated with service-specific error 5009 (0x1391). For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

 

 

 

The same thing happened with the Standby server, the service started successfully at the end of the install procedure but not after a reboot, and the entries in the event viewer of this server are identical to the one above.

 

I have searched around but I cannot find any articles or any other posts adressing the 5009 error message. There are several other posts regarding the dispatcher service on this and other forums but none of the other issues people are having seem to be related to the problem I am experiencing so I decided to post here hoping that someone might be able to help me.

 

Message Edited by lund on 07-15-2009 09:17 AM
Please use plain text.
New Developer
lund
Posts: 58
Registered: ‎07-15-2009
My Device: 9900 + 32 GB PB
My Carrier: Netcom

Re: Dispatcher service won't start - terminates with service-specific error 5009

I'm not sure if it is related or relevant but I can't login to the Blackberry Administration Service anymore either, not sure why but this occured just recently after a reboot.

Also, the last time I was able to login to the service, I did not get any results when searching for an e-mail address to add as a user.

 

Please use plain text.
BlackBerry Technical Advisor (Retired)
enterprisexpert
Posts: 34
Registered: ‎03-25-2009
My Device: Not Specified

Re: Dispatcher service won't start - terminates with service-specific error 5009

Have you checked permissions on the SQL server for the service account? Was the server installed as a Service account with the correct permissions? Do you remember when you did the installation if you selected a Dynamic or Static port for the database? Try changing the port to Dynamic.
Please use plain text.
New Developer
lund
Posts: 58
Registered: ‎07-15-2009
My Device: 9900 + 32 GB PB
My Carrier: Netcom

Re: Dispatcher service won't start - terminates with service-specific error 5009

THanks for the reply, I have checked the account permissions and played around with the SQL settings without any results.

 

I also forwarded the case to RIM and they suggested that I install MR1 which they thin might resolve the problem so I will do that now and post any results here.

Please use plain text.
New Developer
lund
Posts: 58
Registered: ‎07-15-2009
My Device: 9900 + 32 GB PB
My Carrier: Netcom

Re: Dispatcher service won't start - terminates with service-specific error 5009

Unfortunately the MR1 did not resolve the issue so I am still having the same problems, RIM has been contacted for assistance but I probably won't hear anything more until Monday.
Please use plain text.
Visitor
haraball
Posts: 1
Registered: ‎12-17-2009
My Device: Bold 9000
My Carrier: Trigcom

Re: Dispatcher service won't start - terminates with service-specific error 5009

Hi

 

Did you find a solution for this ?

I just started getting the same error.

Please use plain text.
Visitor
lrowden
Posts: 1
Registered: ‎04-29-2010
My Device: yes
My Carrier: Telstra

Re: Dispatcher service won't start - terminates with service-specific error 5009

did anyone get a solution to this. I have the same problem.

 

many thanks

Please use plain text.
New Member
taquitosunrise
Posts: 1
Registered: ‎11-22-2010
My Device: Not Specified

Re: Dispatcher service won't start - terminates with service-specific error 5009

Old thread but posting for posterity:  Had this problem after updating and restarting the BES and SQL servers.  I had to manually reenter the service account password for the SQL Server Agent and start the service.

 

SQL Server:  Start > Run > services.msc > Right click SQL Server Agent (MSSQLServer) > Log On Tab > Enter username / password > Appy > General Tab > Start

 

You may have to start the SQL Server (DB) instance as well.

 

I had originally done this process for the BB Admin Service (Native Code Container) on the BES server.  That allowed me to start most of the BB processes.  After realizing I didn't have SQL connectivity, I went through the above SQL steps and it auto started the BB server serivces.

 

Hope this helps anyone having similar problems.

Please use plain text.
New Developer
lund
Posts: 58
Registered: ‎07-15-2009
My Device: 9900 + 32 GB PB
My Carrier: Netcom

Re: Dispatcher service won't start - terminates with service-specific error 5009

Sorry for abandoning this thread for a while - I just discovered that the e-mail subscriptions from this forum went straight to my spam-folder :smileysad:

 

regarding the issue i first reported, the BESMgmt DB was placed on an remote SQL server - this turned out to be too much of a bother so I ended up doing a reinstallation with a local DB setup instad.

 

taquitosunrise's solution seems reasonable though, as the 5009 error is (as far as I can remember from the prevoious troubleshooting) related to database connectivity issues

Please use plain text.
New Contributor
ecsw
Posts: 7
Registered: ‎02-14-2013
My Device: Q10
My Carrier: Telus

Re: Dispatcher service won't start - terminates with service-specific error 5009

I got similar problem today on my BES10. 

 

I tried many different things to bring it back including account changes on SQL Agent service but nothing works. 

Test DB connection from configuration and it says it's working but it just wont start. 

 

After hours of fighting, I install BES10 on top of existing one without change of any setting at all and it started working. 

 

All settings remains after re-install of BES10 and problem was solved. 

Please use plain text.